aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'grumpy/testsuite/pkgmodel.py')
-rw-r--r--grumpy/testsuite/pkgmodel.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/grumpy/testsuite/pkgmodel.py b/grumpy/testsuite/pkgmodel.py
index 1d73435..bd9f26b 100644
--- a/grumpy/testsuite/pkgmodel.py
+++ b/grumpy/testsuite/pkgmodel.py
@@ -13,7 +13,7 @@ from . import GrumpyTestCase
from pkgcore.ebuild.repo_objs import Maintainer
from grumpy.models import Category, Developer, Ebuild, Herd, Package
-import copy, unittest
+import unittest
class PkgModelTestCase(GrumpyTestCase):
@@ -30,9 +30,9 @@ class PkgModelTestCase(GrumpyTestCase):
'herds': (None, '', 'kala', 'test'), \
'maintainers': (Maintainer('test@gentoo.org'), Maintainer('nobody@gentoo.org'))
}
- p1 = self.get_pkg('%s/testpkg-1.0-r3' % C1, sdata, copy.copy(data))
+ p1 = self.get_pkg('%s/testpkg-1.0-r3' % C1, sdata, data)
data['KEYWORDS'] = 'x86 ~amd64'
- p2 = self.get_pkg('%s/testpkg-1.0-r4' % C1, sdata, copy.copy(data))
+ p2 = self.get_pkg('%s/testpkg-1.0-r4' % C1, sdata, data)
# app-test/testpkg
C2 = 'app-test'
@@ -41,7 +41,7 @@ class PkgModelTestCase(GrumpyTestCase):
'HOMEPAGE': 'http://example.org/testpkg-app-test', \
'KEYWORDS':'x86 ~amd64', \
'IUSE':'test +positive flags -negative split-flag'}
- p3 = self.get_pkg('%s/testpkg-1.0-r3' % C2, sdata, copy.copy(data))
+ p3 = self.get_pkg('%s/testpkg-1.0-r3' % C2, sdata, data)
with self.app.test_request_context():
## Create and test categories
@@ -80,7 +80,7 @@ class PkgModelTestCase(GrumpyTestCase):
# Test changes in herds
sdata['herds'] = ()
- px = self.get_pkg('%s/testpkg-1.0-r3' % C1, sdata, copy.copy(data))
+ px = self.get_pkg('%s/testpkg-1.0-r3' % C1, sdata, data)
c[0].packages[px.key].sync(px)
self.db.session.commit()