summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-02-12 21:15:20 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-02-17 15:30:40 +0530
commit71bf93a7f5a745e92e4684d961107fb39bbf8b65 (patch)
tree7cab3f747f20abdb9d068f8018f10798b988c839 /dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
parentgnome-extra/accountsdialog: actually depends on obsolete polkit-gnome (diff)
downloadgnome-71bf93a7f5a745e92e4684d961107fb39bbf8b65.tar.gz
gnome-71bf93a7f5a745e92e4684d961107fb39bbf8b65.tar.bz2
gnome-71bf93a7f5a745e92e4684d961107fb39bbf8b65.zip
dev-python/pygobject, gobject-introspection: bump + live ebuilds
Diffstat (limited to 'dev-libs/gobject-introspection/gobject-introspection-9999.ebuild')
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-9999.ebuild32
1 files changed, 29 insertions, 3 deletions
diff --git a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
index bbc0c3de..0083c023 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
@@ -33,11 +33,14 @@ DEPEND="${RDEPEND}
sys-devel/flex
doc? ( >=dev-util/gtk-doc-1.15 )
test? ( x11-libs/cairo )"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="x11-libs/cairo[glib]"
pkg_setup() {
DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
G2CONF="${G2CONF}
--disable-static
+ YACC=$(type -p yacc)
$(use_enable test tests)"
python_set_active_version 2
@@ -48,11 +51,34 @@ src_prepare() {
# FIXME: Parallel compilation failure with USE=doc
use doc && MAKEOPTS="-j1"
- # Don't pre-compile .py
- ln -sf $(type -P true) py-compile
- ln -sf $(type -P true) build-aux/py-compile
+ # https://bugzilla.gnome.org/show_bug.cgi?id=659824
+ sed -i -e '/^TAGS/s/[{}]//g' "${S}/giscanner/docbookdescription.py" || die
gnome2_src_prepare
+
+ # Don't pre-compile .py
+ echo > py-compile
+ echo > build-aux/py-compile
+
+ gi_skip_tests=
+ if ! has_version "x11-libs/cairo[glib]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ export CAIRO_GOBJECT_LIBS="-lcairo-gobject"
+ export CAIRO_GOBJECT_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ if use test; then
+ G2CONF="${G2CONF} --disable-tests"
+ gi_skip_tests=yes
+ ewarn "Tests will be skipped because x11-libs/cairo[glib] is not present"
+ ewarn "on your system. Consider installing it to get tests to run."
+ fi
+ fi
+}
+
+src_test() {
+ [[ -z ${gi_skip_tests} ]] && default
}
src_install() {