summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 11:43:28 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-10-13 12:03:58 +0200
commit59ee6d012e2ef13ee9062e47b628541ecc7559a0 (patch)
treed9a434408a2caa30de7c5c0c43390990898a56f9 /app-dicts
parentnet-misc/rygel: 0.18.4 → 0.20.0 (diff)
downloadgnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.tar.gz
gnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.tar.bz2
gnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.zip
app-dicts/gnome-dictionary: 3.8.0 → 3.10.0
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/Manifest11
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.10.0.ebuild41
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild21
3 files changed, 63 insertions, 10 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
new file mode 100644
index 00000000..e54ce38c
--- /dev/null
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-dictionary-3.10.0.tar.xz 779272 SHA256 258b60fe50f7d0580a7dc3bb83f7fe2f6f0597d4013d97ac083c3f062c350ed7 SHA512 cbf5eedf1af8f08f696d2b94ae5bdf82295523cb31e6d1907e6a8698eb94526659a2cc887aa0c9c5b339324502160a7090b28250b412e747f412137d9e711edb WHIRLPOOL 1d945c19d8ccd63da7d067dabec0ee25847fd3f98f5e68ebe97ea351ea609425eaa6ffdeaf36cf94401f4c22e708b1d39ec79bce6b1da10034b866f7d86b0f3f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlJaa0AACgkQ1fmVwcYIWAbEEQCdEaiblNFmZakJSru5BvXtf18r
+nK0AoMrIUUtqIf6I7wdyZKtFhiHm5eNS
+=VowW
+-----END PGP SIGNATURE-----
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.10.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.10.0.ebuild
new file mode 100644
index 00000000..912ac71c
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://live.gnome.org/GnomeUtils"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/6" # subslot = suffix of libgdict-1.0.so
+IUSE="ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3:3
+ x11-libs/pango
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable ipv6) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
index f56df823..3bf42a3e 100644
--- a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
@@ -11,11 +11,11 @@ if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
-DESCRIPTION="Dictionary utility for GNOME 3"
+DESCRIPTION="Dictionary utility for GNOME"
HOMEPAGE="https://live.gnome.org/GnomeUtils"
-LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
-SLOT="0"
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/6" # subslot = suffix of libgdict-1.0.so
IUSE="ipv6"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
@@ -26,7 +26,7 @@ fi
COMMON_DEPEND="
>=dev-libs/glib-2.28:2
- x11-libs/cairo
+ x11-libs/cairo:=
>=x11-libs/gtk+-3:3
x11-libs/pango
"
@@ -49,8 +49,9 @@ if [[ ${PV} = 9999 ]]; then
fi
src_configure() {
- DOCS="AUTHORS NEWS README TODO"
- G2CONF="${G2CONF} $(use_enable ipv6)"
- [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
- gnome2_src_configure
+ local myconf=""
+ [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
+ gnome2_src_configure \
+ $(use_enable ipv6) \
+ ${myconf}
}