summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-02-24 19:43:41 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-02-24 19:43:41 +0100
commit1998f2fe0b1b485aada6113b568c2b72b6a3b54d (patch)
tree5ecbf246bee7f339d849cc9f8144365a9d66478a
parentapp-cdr/brasero: blind sync live ebuild (diff)
downloadgnome-1998f2fe0b1b485aada6113b568c2b72b6a3b54d.tar.gz
gnome-1998f2fe0b1b485aada6113b568c2b72b6a3b54d.tar.bz2
gnome-1998f2fe0b1b485aada6113b568c2b72b6a3b54d.zip
dev-util/itstool: updated live ebuild
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> added PYTHON 3 to PYTHON_COMPAT added segfault-patch Package-Manager: Portage-2.3.51, Repoman-2.3.11 Manifest-Sign-Key: 0xD39C7B0122696620
-rw-r--r--dev-util/itstool/itstool-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-util/itstool/itstool-9999.ebuild b/dev-util/itstool/itstool-9999.ebuild
index bbf2589d..bd66841d 100644
--- a/dev-util/itstool/itstool-9999.ebuild
+++ b/dev-util/itstool/itstool-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
PYTHON_REQ_USE="xml"
inherit autotools python-single-r1
@@ -36,7 +36,12 @@ RDEPEND="${PYTHON_DEPS}
dev-libs/libxml2[python,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-segfault.patch"
+)
+
src_prepare() {
+ python_fix_shebang .
eapply_user
eautoreconf
}