aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
commit2fa30f99c9476940431563b8f2efced907d7e092 (patch)
treed8e5aca296c24224a0752687ff2134d4ce8791f8 /Makefile
parentadded systemd service file, systemd helper script; wrt bug 353492 (diff)
downloadgentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.gz
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.bz2
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.zip
added Makefiles for systemd relevanted files; systemd handling in main Makefile added
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 25021b8..32b01c5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,16 @@
-# $Id$
+# $Id: $
SHELL = /bin/bash
+# systemd support
+VDRSYSTEMD ?= 1
+
SUBDIRS = etc usr vdrplugin-rebuild
+ifeq ($(VDRSYSTEMD),1)
+SUBDIRS += etc/systemd/system/vdr.services.d usr/lib/systemd/system var/vdr/tmp
+endif
+
all:
VERSION := $(shell grep '^Version' README | awk '{ print $$2 }')