summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:07:09 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-16 16:07:09 +0100
commit62ae13348523b0fa45d3a951002e7e2505c97103 (patch)
treee65dc8d55d67a082722ca8ed831be57ee1a08e8a /x11-misc
parentmate-extra/mate-utils: Version bump to 1.18.0 (diff)
downloadgentoo-mate-62ae13348523b0fa45d3a951002e7e2505c97103.tar.gz
gentoo-mate-62ae13348523b0fa45d3a951002e7e2505c97103.tar.bz2
gentoo-mate-62ae13348523b0fa45d3a951002e7e2505c97103.zip
x11-misc/mozo: Version bump to 1.18.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.18.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index bf6435e..77144e8 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -2,3 +2,4 @@ DIST mozo-1.12.0-gtk3.patch.bz2 6562 SHA256 b8aed33b49bd7d5c09d9546770ba79d8643b
DIST mozo-1.12.0.tar.xz 163820 SHA256 59ab1c873064177e5515ba31c493fe9fd158c37b1054f7ae638c6571640aecc7 SHA512 93e760b791a74b6a6ca0377d5aaa060c8bf339dcfde91fcb146ef1e37cc25912b3c93fa2b4d612c0abf2bbd00597c80b58769bc88b57925ec4c465967f32c05b WHIRLPOOL 188419370e749b984d6cc1437baf67dc2611e255d9e18ee2cee113eff578cde8db078064050d63e523d457d5b1fa391a6f1a1db0e95f23c0c79742e484670932
DIST mozo-1.14.1.tar.xz 171576 SHA256 6ec9afc8de9c61ac44d0a65e09bdad847caae5050b1ffe66ca02bc6d479f7163 SHA512 62269ed358807d7ebcf04e6bcbfd3689f019396ebd43a8634bca752f13d6609e94b97688b5fdfa83b1168f0e1cdf284275dc08054e27ab507ce40c2de881bc76 WHIRLPOOL ef795b2268a05ebc6343b62d67e0546b993fe4d6e01d4fbba5c4e8528cb7dae267116de22ddc9dcda91d6aeb332d41411efa2e598ed322ca4acf9da6403f0ea9
DIST mozo-1.16.0.tar.xz 172312 SHA256 1bba88f32caafbc2b1c6bd3095acc07d10de40f242b8c15acb98f0b6e1747432 SHA512 507a35bbdad944ec55ce81e5193af9e5697747c2fc55817b3e3913aca68f1d99caa75df1d79f3b7abc1ba354a5c4f34c868e054e20cb86e5d0a7d65b463af57a WHIRLPOOL dd55a9510784927b11d3bbdccb26dfaa5901769cea0e817fcfeeaaee42220296424599eac6887968724729020594a27ab0d5d4b2a39056c6739b62d240db0300
+DIST mozo-1.18.0.tar.xz 173432 SHA256 ab24241d3203aca75974f0aeb96dbd215c5ac7ca67cd7af72caa6062f84ad613 SHA512 e333c572e5bc1d0905daed17eacd3dda10df5f80ed5b5b01ca3478d345a8c724e0161ccf51914f4982f16df71f252a3b08b194bec18e6aee05eb7af021369a12 WHIRLPOOL 825ae8090e505c71d0daca5373944b8251360a367ec3c6b05b92dcdf21f4216d1aa71083973b3f18bdad8fddabbf9c03fbbe7d08ee6ed5d955b2ee2271dadb22
diff --git a/x11-misc/mozo/mozo-1.18.0.ebuild b/x11-misc/mozo/mozo-1.18.0.ebuild
new file mode 100644
index 0000000..5d07223
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.18.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.6[introspection,python]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ virtual/libintl:0
+ !!x11-misc/mate-menu-editor"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}