summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordol-sen <brian.dolbec@gmail.com>2011-05-26 22:11:17 -0700
committerdol-sen <brian.dolbec@gmail.com>2011-05-26 22:14:41 -0700
commit6b08239f24c4bed3ad16074fe925b84ed9175b76 (patch)
tree4e35670c244f7ab7dc2ec18e735a4ff254878c9a
parentupdate layman's manifest (diff)
downloadgentoo-guis-6b08239f24c4bed3ad16074fe925b84ed9175b76.tar.gz
gentoo-guis-6b08239f24c4bed3ad16074fe925b84ed9175b76.tar.bz2
gentoo-guis-6b08239f24c4bed3ad16074fe925b84ed9175b76.zip
update portage-8888 to match latest -9999 changes
-rw-r--r--sys-apps/portage/ChangeLog5
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-8888.ebuild69
3 files changed, 55 insertions, 21 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 74146ea..40bd0fe 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sys-apps/portage
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: Exp $
+ 27 May 2011; Brian Dolbec <brian.dolbec@gmail.com> portage-8888.ebuild:
+ update portage-8888.ebuild to the latest-9999.ebuild changes
+
*portage-8888 (1 Aug 2010)
1 Aug 2010; Brian Dolbec <brian.dolbec@gmail.com> +portage-8888.ebuild:
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index 3b1de4d..c809263 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,2 +1,2 @@
-EBUILD portage-8888.ebuild 10134 RMD160 8e36eafa87b3fe53e2c0acec747dc110ac843c33 SHA1 ec90ed8f5761941b34719dd437ee7c8c8a8659fc SHA256 0fe72b5671b435dcf564a7e8acfc60f6e81ef4ea2e4418aa4f33630d07e1168a
+EBUILD portage-8888.ebuild 11281 RMD160 2ea90c35486dde626a75d61adb4da28c53beadfb SHA1 349ab4574244bf0c4e63b596fc4f19c269215638 SHA256 d4a57fe4d78e69b4b4c029172052f29eb67d5f3e0b9adcec1d7aee8219fface4
MISC ChangeLog 407 RMD160 7131f6d313087dd7a29f45f83c128c25decb7444 SHA1 27796a8cce236f8150c90385708bb0c182325880 SHA256 108009e9e1e3345d0d3e0d905d129d0af95dc3bfa840ed41b59372b2879b2657
diff --git a/sys-apps/portage/portage-8888.ebuild b/sys-apps/portage/portage-8888.ebuild
index 6348aac..82173c4 100644
--- a/sys-apps/portage/portage-8888.ebuild
+++ b/sys-apps/portage/portage-8888.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.4 2010/04/28 07:26:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-8888.ebuild,v 1.23 2011/05/26 dol-sen Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
EAPI=2
EGIT_BRANCH="public_api"
-inherit git eutils multilib python
+inherit git-2 eutils multilib python
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
@@ -14,10 +14,14 @@ LICENSE="GPL-2"
KEYWORDS=""
PROVIDE="virtual/portage"
SLOT="0"
-IUSE="build doc epydoc python3 selinux"
+IUSE="build doc epydoc +ipc python2 python3 selinux"
python_dep="python3? ( =dev-lang/python-3* )
- !python3? ( || ( dev-lang/python:2.8 dev-lang/python:2.7 dev-lang/python:2.6 >=dev-lang/python-3 ) )"
+ !python2? ( !python3? (
+ build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6 ) )
+ !build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6 >=dev-lang/python-3 ) )
+ ) )
+ python2? ( !python3? ( || ( dev-lang/python:2.7 dev-lang/python:2.6 ) ) )"
# The pysqlite blocker is for bug #282760.
DEPEND="${python_dep}
@@ -33,7 +37,8 @@ RDEPEND="${python_dep}
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
>=app-misc/pax-utils-0.1.17
- selinux? ( sys-libs/libselinux )"
+ selinux? ( || ( >=sys-libs/libselinux-2.0.94[python] <sys-libs/libselinux-2.0.94 ) )
+ !<app-shells/bash-3.2_p17"
PDEPEND="
!build? (
>=net-misc/rsync-2.6.4
@@ -61,7 +66,15 @@ compatible_python_is_selected() {
}
pkg_setup() {
- if ! use python3 && ! compatible_python_is_selected ; then
+ # Bug #359731 - Die early if get_libdir fails.
+ [[ -z $(get_libdir) ]] && \
+ die "get_libdir returned an empty string"
+
+ if use python2 && use python3 ; then
+ ewarn "Both python2 and python3 USE flags are enabled, but only one"
+ ewarn "can be in the shebangs. Using python3."
+ fi
+ if ! use python2 && ! use python3 && ! compatible_python_is_selected ; then
ewarn "Attempting to select a compatible default python interpreter"
local x success=0
for x in /usr/bin/python2.* ; do
@@ -83,17 +96,35 @@ pkg_setup() {
if use python3; then
python_set_active_version 3
+ elif use python2; then
+ python_set_active_version 2
fi
}
src_prepare() {
- local _version="'$(cd "${S}/.git" && git describe --tags | sed -e 's|-\([0-9]\+\)-.\+$|_p\1|')'[1:]"
+ local _version=$(cd "${S}/.git" && git describe --tags | sed -e 's|-\([0-9]\+\)-.\+$|_p\1|')
+ _version=${_version:1}
einfo "Setting portage.VERSION to ${_version} ..."
- sed -i "s/^VERSION=.*/VERSION=${_version}/" pym/portage/__init__.py || \
+ sed -e "s/^VERSION=.*/VERSION='${_version}'/" -i pym/portage/__init__.py || \
die "Failed to patch portage.VERSION"
+ sed -e "1s/VERSION/${_version}/" -i doc/fragment/version || \
+ die "Failed to patch VERSION in doc/fragment/version"
+ sed -e "1s/VERSION/${_version}/" -i man/* || \
+ die "Failed to patch VERSION in man page headers"
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i pym/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
if use python3; then
+ einfo "Converting shebangs for python3..."
python_convert_shebangs -r 3 .
+ elif use python2; then
+ einfo "Converting shebangs for python2..."
+ python_convert_shebangs -r 2 .
fi
}
@@ -123,10 +154,7 @@ src_compile() {
}
src_test() {
- PYTHONPATH=${S}/pym:${PYTHONPATH:+:}${PYTHONPATH} \
- ./pym/portage/tests/runTests || die "test(s) failed"
- # Prevent installation of *.pyc for python scripts.
- find "$S/bin" -name "*.py[co]" -print0 | xargs -0 rm
+ ./runtests.sh || die "tests failed"
}
src_install() {
@@ -164,14 +192,16 @@ src_install() {
rm "${S}"/bin/ebuild-helpers/sed || die "Failed to remove sed wrapper"
fi
- local x symlinks
+ local x symlinks files
cd "$S" || die "cd failed"
for x in $(find bin -type d) ; do
exeinto $portage_base/$x || die "exeinto failed"
cd "$S"/$x || die "cd failed"
- doexe $(find . -mindepth 1 -maxdepth 1 -type f ! -type l) || \
- die "doexe failed"
+ files=$(find . -mindepth 1 -maxdepth 1 -type f ! -type l)
+ if [ -n "$files" ] ; then
+ doexe $files || die "doexe failed"
+ fi
symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
if [ -n "$symlinks" ] ; then
cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
@@ -182,6 +212,8 @@ src_install() {
for x in $(find pym/* -type d) ; do
insinto $portage_base/$x || die "insinto failed"
cd "$S"/$x || die "cd failed"
+ # __pycache__ directories contain no py files
+ [[ "*.py" != $(echo *.py) ]] || continue
doins *.py || die "doins failed"
symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
if [ -n "$symlinks" ] ; then
@@ -202,13 +234,13 @@ src_install() {
doman "${S}"/man/*.[0-9]
echo 'Producing ChangeLog from Git history...'
- ( cd "${S}/.git" && git log --stat > "${S}"/ChangeLog )
+ ( cd "${S}/.git" && git log > "${S}"/ChangeLog )
dodoc "${S}"/{ChangeLog,NEWS,RELEASE-NOTES} || die 'dodoc failed'
use doc && dohtml -r "${S}"/doc/*
use epydoc && dohtml -r "${WORKDIR}"/api
dodir /usr/bin
- for x in ebuild egencache emerge portageq repoman ; do
+ for x in ebuild egencache emerge portageq quickpkg repoman ; do
dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
done
@@ -220,7 +252,6 @@ src_install() {
env-update
etc-update
fixpackages
- quickpkg
regenworld"
local x
for x in ${my_syms}; do