aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2014-06-17 02:26:50 +0000
committerRyan Hill <rhill@gentoo.org>2014-06-17 02:26:50 +0000
commita3ed27c4d5e66c6a09a377895df45efbbd472896 (patch)
treecccb922b1443d1e929bdced9939583f6370761f0
parentAdd initial 4.7.4 patchset based on latest 4.7.3 patchset. (diff)
downloadgcc-patches-a3ed27c4d5e66c6a09a377895df45efbbd472896.tar.gz
gcc-patches-a3ed27c4d5e66c6a09a377895df45efbbd472896.tar.bz2
gcc-patches-a3ed27c4d5e66c6a09a377895df45efbbd472896.zip
Add patch by Martin von Gagern for bug #372377.
-rw-r--r--4.7.4/gentoo/20_all_msgfmt-libstdc++-link.patch39
-rw-r--r--4.7.4/gentoo/README.history1
2 files changed, 40 insertions, 0 deletions
diff --git a/4.7.4/gentoo/20_all_msgfmt-libstdc++-link.patch b/4.7.4/gentoo/20_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 0000000..a70ea50
--- /dev/null
+++ b/4.7.4/gentoo/20_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.am
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.in
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
diff --git a/4.7.4/gentoo/README.history b/4.7.4/gentoo/README.history
index 6258a4f..3efa980 100644
--- a/4.7.4/gentoo/README.history
+++ b/4.7.4/gentoo/README.history
@@ -7,6 +7,7 @@
+ 16_all_libgo-Werror-pr53679.patch
+ 17_all_libitm-Werror.patch
+ 18_all_libgcc-cross-canadian.patch
+ + 20_all_msgfmt-libstdc++-link.patch
+ 25_all_alpha-mieee-default.patch
+ 26_all_alpha-asm-mcpu.patch
+ 29_all_arm_armv4t-default.patch