aboutsummaryrefslogtreecommitdiff
path: root/3.3.6
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-15 04:42:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-15 04:42:22 +0000
commite4d600f674a9a6ddb89de6b5a9d876c35ea9943d (patch)
tree7ecbe8fa7fffb359944cfe12b59bc3d1df58600c /3.3.6
parentAdd patch to fix upstream pr25662 (diff)
downloadgcc-patches-e4d600f674a9a6ddb89de6b5a9d876c35ea9943d.tar.gz
gcc-patches-e4d600f674a9a6ddb89de6b5a9d876c35ea9943d.tar.bz2
gcc-patches-e4d600f674a9a6ddb89de6b5a9d876c35ea9943d.zip
dont try and create libstdc++_pic.a if shared support is disabled
Diffstat (limited to '3.3.6')
-rw-r--r--3.3.6/gentoo/25_all_gcc33-libstdc++-pic.patch17
1 files changed, 10 insertions, 7 deletions
diff --git a/3.3.6/gentoo/25_all_gcc33-libstdc++-pic.patch b/3.3.6/gentoo/25_all_gcc33-libstdc++-pic.patch
index 9c508a9..7ae4071 100644
--- a/3.3.6/gentoo/25_all_gcc33-libstdc++-pic.patch
+++ b/3.3.6/gentoo/25_all_gcc33-libstdc++-pic.patch
@@ -1,21 +1,22 @@
# DP: Build and install libstdc++_pic.a library.
---- libstdc++-v3/src/Makefile.am~ 2003-02-28 09:21:05.000000000 +0100
-+++ libstdc++-v3/src/Makefile.am 2003-02-28 09:28:50.000000000 +0100
-@@ -224,6 +224,10 @@
+--- gcc/libstdc++-v3/src/Makefile.am
++++ gcc/libstdc++-v3/src/Makefile.am
+@@ -224,6 +224,12 @@
@OPT_LDFLAGS@ @SECTION_LDFLAGS@ $(AM_CXXFLAGS) $(LDFLAGS) -o $@
+install-exec-local:
++ifeq ($(enable_shared),yes)
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
++endif
+
# Added bits to build debug library.
if GLIBCPP_BUILD_DEBUG
all-local: build_debug
-
---- libstdc++-v3/src/Makefile.in~ 2003-02-28 09:21:05.000000000 +0100
-+++ libstdc++-v3/src/Makefile.in 2003-02-28 09:30:13.000000000 +0100
+--- gcc/libstdc++-v3/src/Makefile.in
++++ gcc/libstdc++-v3/src/Makefile.in
@@ -415,7 +415,7 @@
installcheck: installcheck-am
install-info-am:
@@ -34,14 +35,16 @@
install-data-am install-data install-am install uninstall-am uninstall \
all-local all-redirect all-am all installdirs mostlyclean-generic \
distclean-generic clean-generic maintainer-clean-generic clean \
-@@ -527,6 +527,10 @@
+@@ -527,6 +527,12 @@
$(LTCXXCOMPILE) -D_GLIBCPP_CONCEPT_CHECKS -fimplicit-templates -c $<
concept-inst.o: concept-inst.cc
$(CXXCOMPILE) -D_GLIBCPP_CONCEPT_CHECKS -fimplicit-templates -c $<
+
+install-exec-local:
++ifeq ($(enable_shared),yes)
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
++endif
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.