summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2014-08-02 02:14:43 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2014-08-02 02:14:43 +0600
commitaf97cc83bc24ec1edcb296d0faaab069c49999dc (patch)
tree4b95e6e5f8d6efc76462fb0ea4eb08363b41f65e /games-puzzle/phlipple
parent[games-action/rochard] bump (diff)
downloadgamerlay-af97cc83bc24ec1edcb296d0faaab069c49999dc.tar.gz
gamerlay-af97cc83bc24ec1edcb296d0faaab069c49999dc.tar.bz2
gamerlay-af97cc83bc24ec1edcb296d0faaab069c49999dc.zip
[games-puzzle/phlipple] Fix linker error with -lm
Package-Manager: portage-2.2.8-r1 Manifest-Sign-Key: A018DE8C
Diffstat (limited to 'games-puzzle/phlipple')
-rw-r--r--games-puzzle/phlipple/files/phlipple-0.8.5_check-math-lib.patch17
-rw-r--r--games-puzzle/phlipple/phlipple-0.8.5.ebuild10
2 files changed, 25 insertions, 2 deletions
diff --git a/games-puzzle/phlipple/files/phlipple-0.8.5_check-math-lib.patch b/games-puzzle/phlipple/files/phlipple-0.8.5_check-math-lib.patch
new file mode 100644
index 0000000..00f1853
--- /dev/null
+++ b/games-puzzle/phlipple/files/phlipple-0.8.5_check-math-lib.patch
@@ -0,0 +1,17 @@
+diff -Nuar phlipple-0.8.5.orig/configure.ac phlipple-0.8.5/configure.ac
+--- phlipple-0.8.5.orig/configure.ac 2014-08-02 01:58:49.961024685 +0600
++++ phlipple-0.8.5/configure.ac 2014-08-02 02:02:28.574032234 +0600
+@@ -14,11 +14,13 @@
+
+ AC_CHECK_LIB(GL, main, [], AC_MSG_ERROR([OpenGL library not found.]))
+ AC_CHECK_LIB(GLU, gluPerspective, [], AC_MSG_ERROR([GLU library not found.]))
++AC_CHECK_LIB(m, cos, [], AC_MSG_ERROR([math library not found.]))
+
+ AC_CHECK_HEADER(GL/gl.h, [], AC_MSG_ERROR(no GL/gl.h found))
+ AC_CHECK_HEADER(GL/glu.h, [], AC_MSG_ERROR(no GL/glu.h found))
+ AC_CHECK_HEADER(SDL/SDL_image.h, [], AC_MSG_ERROR(no SDL/SDL_image.h found))
+ AC_CHECK_HEADER(SDL/SDL_mixer.h, [], AC_MSG_ERROR(no SDL/SDL_mixer.h found))
++AC_CHECK_HEADER(math.h, [], AC_MSG_ERROR(no math.h found))
+
+ AC_ARG_WITH(icondir,
+ AS_HELP_STRING([--with-icondir=DIR],[icon files [DATAROOTDIR/pixmaps]]),
diff --git a/games-puzzle/phlipple/phlipple-0.8.5.ebuild b/games-puzzle/phlipple/phlipple-0.8.5.ebuild
index 1b176cb..c538001 100644
--- a/games-puzzle/phlipple/phlipple-0.8.5.ebuild
+++ b/games-puzzle/phlipple/phlipple-0.8.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: games-puzzle/phlipple/phlipple-0.8.1.ebuild frostwork Exp $
EAPI=5
-inherit eutils games flag-o-matic
+inherit autotools eutils games flag-o-matic
DESCRIPTION="An unique puzzle game with the goal to reduce a 3D shape to a single square"
HOMEPAGE="http://phlipple.sourceforge.net/"
@@ -21,3 +21,9 @@ DEPEND="media-libs/libsdl:0
media-libs/sdl-ttf:0
virtual/opengl
virtual/glu"
+
+src_prepare() {
+ # fix fails to link on new glibc
+ epatch "${FILESDIR}/${P}_check-math-lib.patch"
+ eautoreconf
+}