aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvolpino <fox91@anche.no>2012-03-27 18:58:19 +0200
committervolpino <fox91@anche.no>2012-03-27 18:58:19 +0200
commit06bef562e837c2bf6e5c0b003262b2af8bc8b1d2 (patch)
tree4f48ac763696316d162bb68867f8897f31627831 /setup.py
parentadding django-annoying to requirements and deleting it from the codebase (diff)
downloadeuscan-06bef562e837c2bf6e5c0b003262b2af8bc8b1d2.tar.gz
euscan-06bef562e837c2bf6e5c0b003262b2af8bc8b1d2.tar.bz2
euscan-06bef562e837c2bf6e5c0b003262b2af8bc8b1d2.zip
cleaning up, pep8 fix and changing tabs to spaces
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py120
1 files changed, 60 insertions, 60 deletions
diff --git a/setup.py b/setup.py
index 3b4eed5..f466c1f 100755
--- a/setup.py
+++ b/setup.py
@@ -6,9 +6,9 @@ import re
import sys
from distutils import log
try:
- from setuptools import setup, Command
+ from setuptools import setup, Command
except ImportError:
- from distutils.core import setup, Command
+ from distutils.core import setup, Command
from glob import glob
import os
@@ -22,75 +22,75 @@ cwd = os.getcwd()
# Load EPREFIX from Portage, fall back to the empty string if it fails
try:
- from portage.const import EPREFIX
+ from portage.const import EPREFIX
except ImportError:
- EPREFIX = ''
+ EPREFIX = ''
# Python files that need `__version__ = ""` subbed, relative to this dir:
python_scripts = [os.path.join(cwd, path) for path in (
- 'bin/euscan',
+ 'bin/euscan',
)]
class set_version(Command):
- """Set python __version__ to our __version__."""
- description = "hardcode scripts' version using VERSION from environment"
- user_options = [] # [(long_name, short_name, desc),]
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- ver = 'git' if __version__ == '9999' else __version__
- print("Settings version to %s" % ver)
-
- def sub(files, pattern):
- for f in files:
- updated_file = []
- with io.open(f, 'r', 1, 'utf_8') as s:
- for line in s:
- newline = re.sub(pattern, '"%s"' % ver, line, 1)
- if newline != line:
- log.info("%s: %s" % (f, newline))
- updated_file.append(newline)
- with io.open(f, 'w', 1, 'utf_8') as s:
- s.writelines(updated_file)
- quote = r'[\'"]{1}'
- python_re = r'(?<=^__version__ = )' + quote + '[^\'"]*' + quote
- sub(python_scripts, python_re)
+ """Set python __version__ to our __version__."""
+ description = "hardcode scripts' version using VERSION from environment"
+ user_options = [] # [(long_name, short_name, desc),]
+
+ def initialize_options(self):
+ pass
+
+ def finalize_options(self):
+ pass
+
+ def run(self):
+ ver = 'git' if __version__ == '9999' else __version__
+ print("Settings version to %s" % ver)
+
+ def sub(files, pattern):
+ for f in files:
+ updated_file = []
+ with io.open(f, 'r', 1, 'utf_8') as s:
+ for line in s:
+ newline = re.sub(pattern, '"%s"' % ver, line, 1)
+ if newline != line:
+ log.info("%s: %s" % (f, newline))
+ updated_file.append(newline)
+ with io.open(f, 'w', 1, 'utf_8') as s:
+ s.writelines(updated_file)
+ quote = r'[\'"]{1}'
+ python_re = r'(?<=^__version__ = )' + quote + '[^\'"]*' + quote
+ sub(python_scripts, python_re)
packages = [
- str('.'.join(root.split(os.sep)[1:]))
- for root, dirs, files in os.walk('pym/euscan')
- if '__init__.py' in files
+ str('.'.join(root.split(os.sep)[1:]))
+ for root, dirs, files in os.walk('pym/euscan')
+ if '__init__.py' in files
]
setup(
- name='euscan',
- version=__version__,
- description='Ebuild upstream scan utility.',
- author='Corentin Chary',
- author_email='corentin.chary@gmail.com',
- maintainer='Corentin Chary',
- maintainer_email='corentin.chary@gmail.com',
- url='http://euscan.iksaif.net',
- download_url=(
- 'https://github.com/iksaif/euscan/tarball/' +
- ('master' if __version__ == '9999' else ('euscan-%s' % __version__))
- ),
- install_requires=['django-annoying'],
- package_dir={'': 'pym'},
- packages=packages,
- package_data={},
- scripts=python_scripts,
- data_files=(
- (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/man1'),
- glob('man/*')),
- ),
- cmdclass={
- 'set_version': set_version,
- },
+ name='euscan',
+ version=__version__,
+ description='Ebuild upstream scan utility.',
+ author='Corentin Chary',
+ author_email='corentin.chary@gmail.com',
+ maintainer='Corentin Chary',
+ maintainer_email='corentin.chary@gmail.com',
+ url='http://euscan.iksaif.net',
+ download_url=(
+ 'https://github.com/iksaif/euscan/tarball/' +
+ ('master' if __version__ == '9999' else ('euscan-%s' % __version__))
+ ),
+ install_requires=['django-annoying'],
+ package_dir={'': 'pym'},
+ packages=packages,
+ package_data={},
+ scripts=python_scripts,
+ data_files=(
+ (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/man1'),
+ glob('man/*')),
+ ),
+ cmdclass={
+ 'set_version': set_version,
+ },
)