summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-08-31 14:58:07 +0000
committerThomas Sachau <tommy@gentoo.org>2013-08-31 14:58:07 +0000
commita2225a79d60b75dcc33962cfaba8354d8b2ebcae (patch)
treeac22789f7dbd2c0561e5c9e7b4405dbfb3d4ba71
parentSwitch to git (diff)
downloadenlightenment-a2225a79d60b75dcc33962cfaba8354d8b2ebcae.tar.gz
enlightenment-a2225a79d60b75dcc33962cfaba8354d8b2ebcae.tar.bz2
enlightenment-a2225a79d60b75dcc33962cfaba8354d8b2ebcae.zip
Switch to git and adjust version to allow live ebuild for future e18 versions
-rw-r--r--x11-wm/enlightenment/enlightenment-0.17.9999.ebuild (renamed from x11-wm/enlightenment/enlightenment-9999.ebuild)49
1 files changed, 29 insertions, 20 deletions
diff --git a/x11-wm/enlightenment/enlightenment-9999.ebuild b/x11-wm/enlightenment/enlightenment-0.17.9999.ebuild
index 2d39e0e..efcb110 100644
--- a/x11-wm/enlightenment/enlightenment-9999.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.17.9999.ebuild
@@ -2,19 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=5
+
+EGIT_SUB_PROJECT="core"
+EGIT_URI_APPEND=${PN}
+EGIT_BRANCH=${PN}-0.17
-ESVN_URI_APPEND="e"
inherit enlightenment
DESCRIPTION="Enlightenment DR17 window manager"
-SLOT="0.17"
+LICENSE="BSD-2"
+SLOT="0.17/${PV}"
# The @ is just an anchor to expand from
__EVRY_MODS=""
__CONF_MODS="
- +@applications +@comp +@dialogs +@display +@edgebindings
+ +@applications +@dialogs +@display +@edgebindings
+@interaction +@intl +@keybindings +@menus
+@paths +@performance +@randr +@shelves +@theme
+@wallpaper2 +@window-manipulation +@window-remembers"
@@ -27,46 +31,51 @@ IUSE_E_MODULES="
${__CONF_MODS//@/enlightenment_modules_conf-}
${__NORM_MODS//@/enlightenment_modules_}"
-IUSE="pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
+IUSE="emotion pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
RDEPEND="
pam? ( sys-libs/pam )
- >=dev-libs/efreet-1.7
- >=dev-libs/eio-1.7
- >=dev-libs/eina-1.7[mempool-chained]
- || ( >=dev-libs/ecore-1.7[X,evas,inotify] >=dev-libs/ecore-1.7[xcb,evas,inotify] )
- >=media-libs/edje-1.7
- >=dev-libs/e_dbus-1.7[libnotify,udev?]
- ukit? ( >=dev-libs/e_dbus-1.7[udev] )
- enlightenment_modules_connman? ( >=dev-libs/e_dbus-1.7[connman] )
+ >=dev-libs/eet-1.7.8
+ >=dev-libs/efreet-1.7.8
+ >=dev-libs/eio-1.7.8
+ >=dev-libs/eina-1.7.8[mempool-chained]
+ || ( >=dev-libs/ecore-1.7.8[X,evas,inotify] >=dev-libs/ecore-1.7.4[xcb,evas,inotify] )
+ >=media-libs/edje-1.7.8
+ >=dev-libs/e_dbus-1.7.8[libnotify,udev?]
+ ukit? ( >=dev-libs/e_dbus-1.7.8[udev] )
+ enlightenment_modules_connman? ( >=dev-libs/e_dbus-1.7.8[connman] )
enlightenment_modules_physics? ( >=dev-libs/ephysics-9999 )
- || ( >=media-libs/evas-1.7[eet,X,jpeg,png] >=media-libs/evas-1.7[eet,xcb,jpeg,png] )
- >=dev-libs/eeze-1.7"
+ enlightenment_modules_shot? ( >=dev-libs/ecore-1.7.8[curl] )
+ || ( >=media-libs/evas-1.7.8[eet,X,jpeg,png] >=media-libs/evas-1.7.8[eet,xcb,jpeg,png] )
+ >=dev-libs/eeze-1.7.8
+ emotion? ( >=media-libs/emotion-1.7.8 )
+ x11-libs/xcb-util-keysyms"
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/quickstart.diff
+# epatch "${FILESDIR}"/quickstart.diff
enlightenment_src_prepare
}
src_configure() {
- export MY_ECONF="
+ E_ECONF+=(
--disable-install-sysactions
--disable-elementary
$(use_enable doc)
--disable-device-hal
+ $(use_enable emotion)
--disable-mount-hal
$(use_enable nls)
$(use_enable pam)
--enable-device-udev
$(use_enable udev mount-eeze)
$(use_enable ukit mount-udisks)
- "
+ )
local u c
for u in ${IUSE_E_MODULES} ; do
u=${u#+}
c=${u#enlightenment_modules_}
- MY_ECONF+=" $(use_enable ${u} ${c})"
+ E_ECONF+=( $(use_enable ${u} ${c}) )
done
enlightenment_src_configure
}
@@ -74,5 +83,5 @@ src_configure() {
src_install() {
enlightenment_src_install
insinto /etc/enlightenment
- newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf || die
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
}