aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-utils/Manifest8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.22-r1.ebuild104
-rw-r--r--media-sound/alsa-utils/files/alsa-modules.conf-rc38
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.22-cross-ncurses.patch20
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch12
-rw-r--r--media-sound/alsa-utils/files/alsasound.confd-r331
-rw-r--r--media-sound/alsa-utils/files/alsasound.initd-r4218
-rw-r--r--portage-flags-target/keywords/alsa-lib2
-rw-r--r--portage-flags-target/keywords/alsa-utils2
9 files changed, 433 insertions, 2 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
new file mode 100644
index 0000000..234d75a
--- /dev/null
+++ b/media-sound/alsa-utils/Manifest
@@ -0,0 +1,8 @@
+AUX alsa-modules.conf-rc 1028 RMD160 8e115310eb0e13e08b21304c98a78e721be0029a SHA1 7a2b5fed91fa640894efaf2f557eb2b04aff1a40 SHA256 6060c101ca0793ea80e2b6b5bb8d6b118325092788ff26f07c280dd1ff546570
+AUX alsa-utils-1.0.22-cross-ncurses.patch 711 RMD160 c7e30788dbaa5eff1d56e939ac0d7e14dd910d93 SHA1 919d855cebe3f38bf47b42cd5092c0cd5b213fe5 SHA256 04af30473d8a5cc3b406c2f67a13e8d1b0febae086cfb1c1a488f27a85c5e3bb
+AUX alsa-utils-1.0.22-modprobe.d.patch 501 RMD160 072188940d24966698fd9b488a13eead2d8d114d SHA1 c1097f57094559512b974f705918a07d4e232d11 SHA256 a39df3d44dadfd0469e4d0dca836b1db38e06b8cbbf68ca33e368188f1b45c96
+AUX alsasound.confd-r3 874 RMD160 2e3ea587fd55757ec26c60a3bb86fcd697f48e67 SHA1 9561a56c1a3a1d0ecdef42655ecc1e2c12340852 SHA256 e5d26a6ea993540ca2d67aee4b40f1351b13f2c8023d53cb67c22cb3707e72de
+AUX alsasound.initd-r4 6231 RMD160 39e28ae5d17c7bb45a1010a9e9a25d79d1b6fc60 SHA1 d68c209ee7b6c04248bfd01ad5bae52fa21aa789 SHA256 b6909ef321a57b586a2cc1f2665c544cf2cfc9b07e3e66592cc649abee57f576
+DIST alsa-driver-1.0.22.1.tar.bz2 3218678 RMD160 ad139cf0b4769f0a27afd0aa4d91cb808d43a589 SHA1 603f0caff5307c68be4d941c841d892e376e4ae9 SHA256 2c69f4fa72f55e85f32db696f3a6497642ebfe1204ca8f30d328f177176c6782
+DIST alsa-utils-1.0.22.tar.bz2 1075216 RMD160 f9f9c3cc81e9c0d97fd62c3f91424a8f117ca6c3 SHA1 3587dc19d9a60ab9bb2bfe2d23491230eae99fe1 SHA256 95133815d2c1c11396d75951b4db253b8c3010ea4c352cfa9fcd7d122cbd8d13
+EBUILD alsa-utils-1.0.22-r1.ebuild 3040 RMD160 8cbf742c2acda2123882bb89d74701dd9346908d SHA1 beb6f14102411d6ec7a30840a2c66898c18103d8 SHA256 19453858a585912b0adb6f0b1e131b2855fbc6fd88876a5d679afe7bac3d613d
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.22-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.22-r1.ebuild
new file mode 100644
index 0000000..7992c14
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.22-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.22-r1.ebuild,v 1.2 2010/01/08 02:19:41 beandog Exp $
+
+EAPI=2
+inherit autotools eutils toolchain-funcs
+
+MY_P=${P/_rc/rc}
+ALSA_DRIVER_VER="1.0.22.1"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-${ALSA_DRIVER_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc nls minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ doc? ( app-text/xmlto )"
+RDEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [[ -e "${ROOT}etc/modules.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modules.d/alsa found."
+ die "Move /etc/modules.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+
+ if [[ -e "${ROOT}etc/modprobe.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modprobe.d/alsa found."
+ die "Move /etc/modprobe.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-modprobe.d.patch
+ epatch "${FILESDIR}"/${P}-cross-ncurses.patch
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-xmlto"
+
+ if tc-is-cross-compiler; then
+ myconf="${myconf} --with-curses=cross"
+ fi
+
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+
+ newbin "${WORKDIR}/alsa-driver-${ALSA_DRIVER_VER}/utils/alsa-info.sh" \
+ alsa-info
+
+ newinitd "${FILESDIR}/alsasound.initd-r4" alsasound
+ newconfd "${FILESDIR}/alsasound.confd-r3" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-modules.conf-rc b/media-sound/alsa-utils/files/alsa-modules.conf-rc
new file mode 100644
index 0000000..40e99df
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-modules.conf-rc
@@ -0,0 +1,38 @@
+# Alsa kernel modules' configuration file.
+
+# ALSA portion
+alias char-major-116 snd
+# OSS/Free portion
+alias char-major-14 soundcore
+
+##
+## IMPORTANT:
+## You need to customise this section for your specific sound card(s)
+## and then run `update-modules' command.
+## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
+##
+## ALSA portion
+## alias snd-card-0 snd-interwave
+## alias snd-card-1 snd-ens1371
+## OSS/Free portion
+## alias sound-slot-0 snd-card-0
+## alias sound-slot-1 snd-card-1
+##
+
+# OSS/Free portion - card #1
+alias sound-service-0-0 snd-mixer-oss
+alias sound-service-0-1 snd-seq-oss
+alias sound-service-0-3 snd-pcm-oss
+alias sound-service-0-8 snd-seq-oss
+alias sound-service-0-12 snd-pcm-oss
+## OSS/Free portion - card #2
+## alias sound-service-1-0 snd-mixer-oss
+## alias sound-service-1-3 snd-pcm-oss
+## alias sound-service-1-12 snd-pcm-oss
+
+alias /dev/mixer snd-mixer-oss
+alias /dev/dsp snd-pcm-oss
+alias /dev/midi snd-seq-oss
+
+# Set this to the correct number of cards.
+options snd cards_limit=1
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.22-cross-ncurses.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.22-cross-ncurses.patch
new file mode 100644
index 0000000..ee2dbef
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.22-cross-ncurses.patch
@@ -0,0 +1,20 @@
+--- configure.in 2009-12-16 16:28:45.000000000 +0100
++++ configure.in.new 2010-02-07 19:01:40.000000000 +0100
+@@ -142,6 +142,17 @@
+ AC_CHECK_LIB(curses, initscr,
+ [ CURSESINC='<curses.h>'; CURSESLIB='-lcurses'; curseslib="curses"])
+ fi
++ if test "$curseslib" = "cross" -o "$curseslib" = "auto"; then
++ AC_CHECK_LIB(ncursesw,
++ initscr,
++ [CURSESINC='<ncurses.h>'; CURSESLIB='-lncursesw'; curseslib="ncursesw"],
++ [AC_CHECK_LIB(ncurses,
++ initscr,
++ [CURSESINC='<ncurses.h>'; CURSESLIB='-lncurses'; curseslib="ncurses"]
++ )]
++ )
++ fi
++
+ if test -z "$CURSESINC"; then
+ AC_MSG_ERROR(this packages requires a curses library)
+ fi
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch
new file mode 100644
index 0000000..cea2724
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch
@@ -0,0 +1,12 @@
+diff -ur alsa-utils-1.0.21.orig/alsaconf/alsaconf.in alsa-utils-1.0.21/alsaconf/alsaconf.in
+--- alsa-utils-1.0.21.orig/alsaconf/alsaconf.in 2009-05-06 10:07:24.000000000 +0300
++++ alsa-utils-1.0.21/alsaconf/alsaconf.in 2009-08-04 12:36:38.000000000 +0300
+@@ -301,7 +301,7 @@
+ fi
+ else
+ if [ "$distribution" = "gentoo" ]; then
+- cfgfile="/etc/modules.d/alsa"
++ cfgfile="/etc/modprobe.d/alsa.conf"
+ elif [ "$kernel" = "new" ]; then
+ cfgfile="/etc/modprobe.conf"
+ if [ -d /etc/modprobe.d ]; then
diff --git a/media-sound/alsa-utils/files/alsasound.confd-r3 b/media-sound/alsa-utils/files/alsasound.confd-r3
new file mode 100644
index 0000000..0a5d58f
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsasound.confd-r3
@@ -0,0 +1,31 @@
+# ENABLE_OSS_EMUL:
+# Do you want to enable in-kernel oss emulation?
+# no - Do not load oss emul drivers
+# yes - Load oss emul drivers if they're found
+
+ENABLE_OSS_EMUL="yes"
+
+# RESTORE_ON_START:
+# Do you want to restore your mixer settings? If not, your cards will be
+# muted.
+# no - Do not restore state
+# yes - Restore state
+
+RESTORE_ON_START="yes"
+
+# SAVE_ON_STOP:
+# Do you want to save changes made to your mixer volumes when alsasound
+# stops?
+# no - Do not save state
+# yes - Save state
+
+SAVE_ON_STOP="yes"
+
+# LOAD_ON_START:
+# Do you want to load sound modules when alsasound starts?
+# Note: The Gentoo ALSA developers encourage you to build your sound
+# drivers into the kernel unless the device is hotpluggable or
+# you need to supply specific options (such as model= to HD-Audio).
+# no - Do not load modules
+# yes - Load modules
+LOAD_ON_START="yes"
diff --git a/media-sound/alsa-utils/files/alsasound.initd-r4 b/media-sound/alsa-utils/files/alsasound.initd-r4
new file mode 100644
index 0000000..35e4a23
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsasound.initd-r4
@@ -0,0 +1,218 @@
+#!/sbin/runscript
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound.initd-r4,v 1.1 2009/08/02 11:27:26 ssuominen Exp $
+# Copyright 2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+alsastatedir=/var/lib/alsa
+alsascrdir=/etc/alsa.d
+
+opts="save restore"
+
+depend() {
+ need localmount
+ after bootmisc modules isapnp coldplug hotplug
+}
+
+load_modules() {
+ # List of drivers for each card.
+ local DRIVERS="$(modprobe -c | sed -n -e 's/^alias \(snd-card-[[:digit:]]\+\) .*/\1/p')"
+
+ # Fall back on the automated aliases if we don't have ALSA configured properly...
+ if [ -z "${DRIVERS}" ] && \
+ ( [ ! -r /proc/asound/cards ] || grep -q ' no soundcards ' /proc/asound/cards 2>/dev/null ) ; then
+ ewarn "Could not detect custom ALSA settings. Loading all detected alsa drivers."
+ DRIVERS="$(modprobe -c | sed -n -e '/^alias pci:.* snd.*/ s/^alias pci:[^ ]* \(.*\)/\1/p' | sort | uniq)"
+ if [ -z "${DRIVERS}" ] ; then
+ eerror "Unable to find any ALSA drivers. Have you compiled alsa-drivers correctly?"
+ fi
+ fi
+
+ if [ "${ENABLE_OSS_EMUL}" = "yes" ] ; then
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.*oss/ s:.*\/\([[:alnum:]_-]\+\).ko:\1:p')"
+ fi
+
+ # We want to ensure snd-seq is loaded as it is needed for things like
+ # timidity even if we don't use a real sequencer.
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.seq\./ s:.*\/\([[:alnum:]_-]\+\).ko:\1:p')"
+
+ # We want to ensure snd-ioctl32 is loaded as it is needed for 32bit
+ # compatibility
+ DRIVERS="${DRIVERS} $(modprobe -l | sed -n -e '/snd.ioctl32\./ s:.*\/\([[:alnum:]_-]\+\).ko:\1:p')"
+
+ local DRIVER= DMOD=
+ for DRIVER in ${DRIVERS} ; do
+ [ "${DRIVER}" = "off" ] && continue
+ DMOD="$(echo "${DRIVER}" | sed -e 's/-/_/g')"
+ if ! grep -q "^${DMOD} " /proc/modules ; then
+ ebegin "Loading: ${DRIVER}"
+ modprobe ${DRIVER}
+ eend $?
+ fi
+ done
+
+ if [ -f /proc/asound/seq/drivers ] ; then
+ local SEQUENCERS="$(sed -n -e 's/\([^,]*\),empty,.*/\1/p' /proc/asound/seq/drivers)"
+ local SEQUENCER
+ for SEQUENCER in ${SEQUENCERS} ; do
+ DMOD="$(echo "${SEQUENCER}" | sed -e 's/-/_/g')"
+ if ! grep -q "^${DMOD} " /proc/modules ; then
+ ebegin "Loading: ${SEQUENCER}"
+ modprobe ${SEQUENCER}
+ eend $?
+ fi
+ done
+ fi
+
+ for DRIVER in ${DRIVERS}
+ do
+ local TMP=${DRIVER##snd-}
+ TMP=${TMP##snd_}
+ if [ -x "${alsascrdir}/${TMP}" ] ; then
+ ebegin "Running: ${alsascrdir}/${TMP}"
+ "${alsascrdir}/${TMP}"
+ eend $?
+ fi
+ done
+
+ if [ ! -d /proc/asound ] || grep -q ' no soundcards ' /proc/asound/cards ; then
+ eerror "ERROR: Failed to load necessary drivers"
+ return 1
+ fi
+}
+
+unload_modules_24() {
+ local LOADED_MODULES="$(lsmod | sed -n -e 's/^\(snd[^ ]*\) .*/\1/p')"
+ local MODULE
+ for MODULE in ${LOADED_MODULES} ; do
+ rmmod "${MODULE}"
+ done
+ rmmod soundcore 2>/dev/null
+ rmmod gameport 2>/dev/null
+
+ lsmod | grep -vq '^snd'
+}
+
+unload_modules_recursive() {
+ local revdeps="$(lsmod | sed -n -e "s/,/ /g" -e "s/^$1 *[0-9]* *[0-9]* \(.*\)/\1/p")"
+
+ for module in ${revdeps} ; do
+ unload_modules_recursive "${module}"
+ done
+
+ vebegin "Unloading: $1"
+ rmmod --wait "$1"
+ veend $?
+}
+
+unload_modules_26() {
+ # First of all, remove the snd module and all the modules depending
+ # on it, this should remove already most of ALSA modules.
+ lsmod | grep -q "^snd[[:space:]]" && unload_modules_recursive snd
+
+ # Then find the remaining ones, and handle them too.
+ for module in $(lsmod | sed -n -e 's/^\(snd[^ ]*\) .*/\1/p'); do
+ unload_modules_recursive "${module}"
+ done
+
+ lsmod | grep -vq "^snd"
+}
+
+terminate() {
+ #
+ # Kill processes holding open sound devices
+ #
+ # DEVS=`find /dev/ -follow -type c -maxdepth 1 -print 2>/dev/null | xargs ls -dils | grep "1*1[46]," | cut -d: -f2 | cut -d" " -f2; echo /proc/asound/dev/*`
+ local ossdevs="/dev/admmidi* /dev/adsp* /dev/amidi* /dev/audio* /dev/dmfm* \
+ /dev/dmmidi* /dev/dsp* /dev/dspW* /dev/midi0* /dev/mixer* /dev/music \
+ /dev/patmgr* /dev/sequencer* /dev/sndstat"
+ local alsadevs="/proc/asound/dev/* /dev/sound/* /dev/snd/*"
+ fuser -k ${ossdevs} ${alsadevs} >/dev/null 2>/dev/null
+
+ # remove all sequencer connections if any
+ [ -f /proc/asound/seq/clients ] && type aconnect >/dev/null 2>/dev/null && aconnect --removeall
+}
+
+restore() {
+ ebegin "Restoring Mixer Levels"
+
+ if [ ! -r "${alsastatedir}/asound.state" ] ; then
+ ewarn "No mixer config in ${alsastatedir}/asound.state, you have to unmute your card!"
+ eend 0
+ return 0
+ fi
+
+ local cards="$(sed -n -e 's/ *\([[:digit:]]*\) .*/\1/p' /proc/asound/cards)"
+ local CARDNUM
+ for cardnum in ${cards}; do
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ [ -e /dev/snd/controlC${cardnum} ] || sleep 2
+ alsactl -f "${alsastatedir}/asound.state" restore ${cardnum} \
+ || ewarn "Errors while restoring defaults, ignoring"
+ done
+
+ for ossfile in "${alsastatedir}"/oss/card*_pcm* ; do
+ [ -e "${ossfile}" ] || continue
+ # We use cat because I'm not sure if cp works properly on /proc
+ local procfile=${ossfile##${alsastatedir}/oss}
+ procfile="$(echo "${procfile}" | sed -e 's,_,/,g')"
+ if [ -e /proc/asound/"${procfile}"/oss ] ; then
+ cat "${ossfile}" > /proc/asound/"${procfile}"/oss
+ fi
+ done
+
+ eend 0
+}
+
+save() {
+ ebegin "Storing ALSA Mixer Levels"
+
+ mkdir -p "${alsastatedir}"
+ if ! alsactl -f "${alsastatedir}/asound.state" store; then
+ eerror "Error saving levels."
+ eend 1
+ return 1
+ fi
+
+ for ossfile in /proc/asound/card*/pcm*/oss; do
+ [ -e "${ossfile}" ] || continue
+ local device=${ossfile##/proc/asound/} ; device=${device%%/oss}
+ device="$(echo "${device}" | sed -e 's,/,_,g')"
+ mkdir -p "${alsastatedir}/oss/"
+ cp "${ossfile}" "${alsastatedir}/oss/${device}"
+ done
+
+ eend 0
+}
+
+start() {
+ if [ -f /proc/modules ] && [ "${LOAD_ON_START}" = "yes" ]; then
+ ebegin "Loading ALSA modules"
+ eindent
+ load_modules
+ eoutdent
+ eend $? || return 1
+ fi
+
+ if [ ! -d /proc/asound ]; then
+ eerror "ALSA failed to load."
+ eend 1
+ return 1
+ elif [ "${RESTORE_ON_START}" = "yes" ]; then
+ restore
+ fi
+
+ return 0
+}
+
+stop() {
+ if [ ! -d /proc/asound ] ; then
+ eerror "ALSA is not loaded"
+ return 0
+ fi
+
+ [ "${SAVE_ON_STOP}" = "yes" ] && save
+
+ return 0
+}
diff --git a/portage-flags-target/keywords/alsa-lib b/portage-flags-target/keywords/alsa-lib
index 710fcff..7a6c727 100644
--- a/portage-flags-target/keywords/alsa-lib
+++ b/portage-flags-target/keywords/alsa-lib
@@ -1 +1 @@
-=media-libs/alsa-lib-1.0.20 ~arm
+~media-libs/alsa-lib-1.0.22 ~arm
diff --git a/portage-flags-target/keywords/alsa-utils b/portage-flags-target/keywords/alsa-utils
index 18011f6..a3b7a4c 100644
--- a/portage-flags-target/keywords/alsa-utils
+++ b/portage-flags-target/keywords/alsa-utils
@@ -1 +1 @@
-=media-sound/alsa-utils-1.0.20* ~arm
+~media-sound/alsa-utils-1.0.22 ~arm