aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-07-02 16:30:21 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-07-02 16:30:21 +0000
commit3d056cd7d20b8061a6770a4093008dd5d5d23fe8 (patch)
tree3c5a0f2f95860699a87a0d35605a7ec46abda78e /sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild
parentKeyword the elementary python bindings. (diff)
downloadembedded-cross-3d056cd7d20b8061a6770a4093008dd5d5d23fe8.tar.gz
embedded-cross-3d056cd7d20b8061a6770a4093008dd5d5d23fe8.tar.bz2
embedded-cross-3d056cd7d20b8061a6770a4093008dd5d5d23fe8.zip
Add up-to-date kernel snapshot and keyword it.
Diffstat (limited to 'sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild')
-rw-r--r--sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild b/sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild
new file mode 100644
index 0000000..a7854ca
--- /dev/null
+++ b/sys-kernel/openmoko-sources/openmoko-sources-20090624.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Andy-tracking kernel for Openmoko devices"
+HOMEPAGE="http://www.openmoko.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://git.openmoko.org/git/kernel.git"
+# This needs to be the COMMIT!!!!! else the git eclass is not able
+# to checkout the correct branch at the given commit!
+EGIT_TREE="e03b339e05fbf46836c83d5595d4db77112b429d"
+EGIT_BRANCH="andy-tracking"
+
+ETYPE="sources"
+OKV="2.6.29"
+CKV="-${PVR}"
+
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="yes"
+
+inherit git kernel-2 toolchain-funcs
+detect_version
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+
+IUSE=""
+DOCS=""
+
+RDEPEND=""
+DEPEND="sys-devel/gcc
+ dev-embedded/u-boot-tools"
+
+MY_P="linux-${OKV}${CKV}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+}
+
+pkg_postinst() {
+ postinst_sources
+ einfo "The kernel source is now installed in"
+ einfo " ${ROOT}/usr/src/linux."
+ einfo "Please change to this directory to configure and build the kernel."
+ einfo ""
+ einfo "To use a default kernel-configuration for your device, rename one"
+ einfo "of the defconfig-<device> files to .config"
+
+ if tc-is-cross-compiler ; then
+ ewarn ""
+ ewarn "NOTE: If you are cross-compiling you have to run"
+ ewarn " make ARCH=arm CROSS_COMPILE=${CHOST}- INSTALL_MOD_PATH=${ROOT}"
+ ewarn "instead of just"
+ ewarn " make"
+ ewarn "to configure, compile and install the kernel + modules."
+ fi
+}