aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-07-02 16:15:33 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-07-02 16:15:33 +0000
commit173e04b07f822d2d3faac3746416c0444778577b (patch)
treed58c70ba2daa63019ee78edc52957346e7a9086b /dev-python
parentKeyword libyaml for arm. (diff)
downloadembedded-cross-173e04b07f822d2d3faac3746416c0444778577b.tar.gz
embedded-cross-173e04b07f822d2d3faac3746416c0444778577b.tar.bz2
embedded-cross-173e04b07f822d2d3faac3746416c0444778577b.zip
Add $ROOT to the specified lib for pyxml, else it will try to link against the host lib.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyxml/Manifest3
-rw-r--r--dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch28
-rw-r--r--dev-python/pyxml/pyxml-0.8.4-r2.ebuild60
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/pyxml/Manifest b/dev-python/pyxml/Manifest
new file mode 100644
index 0000000..a0c2ca2
--- /dev/null
+++ b/dev-python/pyxml/Manifest
@@ -0,0 +1,3 @@
+AUX pyxml-0.8.4-python-2.6.patch 1749 RMD160 f8eb2f581a953e8a2b2968cea9a88fe5a1353243 SHA1 787a92081dd172aa36d5c52344e74ef922073bc0 SHA256 03c4eb073c58e7c28a22ff702a296ba4c4fe11a64d931ada6216d1876c6118e8
+DIST PyXML-0.8.4.tar.gz 734954 RMD160 976e618d99fb29840e36eb2c7662c1d0a1f2bca9 SHA1 6f30d5907b75ef76809c19e0103d78f4a5fb027c SHA256 9fab66f9584fb8e67aebd8745a5c97bf1c5a2e2e461adf68862bcec64e448c13
+EBUILD pyxml-0.8.4-r2.ebuild 1465 RMD160 8cb3eaf6ee58e90a14f224db86811d3803ae199c SHA1 b5d4fa45e14c2e91c7dce1880ff24e1e24abbe9b SHA256 3d6ba9c36a182f7e65ac663abef6999647c841ba289061ca5a80fdb2e2baac3b
diff --git a/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch b/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch
new file mode 100644
index 0000000..d29b0b6
--- /dev/null
+++ b/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch
@@ -0,0 +1,28 @@
+diff -rupN PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py PyXML-0.8.4/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py
+--- PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2008-12-15 16:54:36.000000000 +0900
++++ PyXML-0.8.4/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2008-12-15 16:57:02.000000000 +0900
+@@ -24,8 +24,8 @@ class ParsedAbbreviatedAbsoluteLocationP
+ self._rel = rel
+ nt = ParsedNodeTest.ParsedNodeTest('node', '')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._step = ParsedStep.ParsedStep(as, nt, ppl)
++ as_ = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._step = ParsedStep.ParsedStep(as_, nt, ppl)
+ return
+
+ def evaluate(self, context):
+diff -rupN PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py PyXML-0.8.4/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py
+--- PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2008-12-15 16:54:36.000000000 +0900
++++ PyXML-0.8.4/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2008-12-15 16:58:58.000000000 +0900
+@@ -28,8 +28,8 @@ class ParsedAbbreviatedRelativeLocationP
+ self._right = right
+ nt = ParsedNodeTest.ParsedNodeTest('node','')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._middle = ParsedStep.ParsedStep(as, nt, ppl)
++ as_ = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._middle = ParsedStep.ParsedStep(as_, nt, ppl)
+
+ def evaluate(self, context):
+ res = []
diff --git a/dev-python/pyxml/pyxml-0.8.4-r2.ebuild b/dev-python/pyxml/pyxml-0.8.4-r2.ebuild
new file mode 100644
index 0000000..ac17f81
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.4-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.4-r2.ebuild,v 1.2 2009/03/14 17:40:25 armin76 Exp $
+
+inherit distutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND=">=dev-libs/expat-1.95.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ distutils_src_unpack
+ epatch "${FILESDIR}"/${P}-python-2.6.patch
+}
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ # use the already-installed shared copy of libexpat
+ distutils_src_compile --with-libexpat="${ROOT}/usr" ${myconf}
+}
+
+src_install() {
+ DOCS="ANNOUNCE CREDITS doc/*.txt"
+ distutils_src_install
+
+ doman doc/man/*
+ if use doc; then
+ dohtml -A api,web -r doc/*
+ insinto /usr/share/doc/${PF} && doins doc/*.tex
+ fi
+ use examples && cp -r demo "${D}"/usr/share/doc/${PF}
+}
+
+pkg_postinst(){
+ python_mod_optimize "$(python_get_sitedir)/_xmlplus"
+}
+
+src_test() {
+ cd test
+ PYTHONPATH="$(ls -d ../build/lib.*)" "${python}" regrtest.py \
+ || die "tests failed"
+}