aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-09-24 16:46:10 +0200
committerUlrich Müller <ulm@gentoo.org>2023-09-24 16:46:10 +0200
commit4045e58e88a876541a93857f45b4a69fcb78e347 (patch)
tree25f5944a66d1804fdae033b457ac0831c3a954fe
parent29.1: Fix build failure with tree-sitter (diff)
downloademacs-patches-4045e58e88a876541a93857f45b4a69fcb78e347.tar.gz
emacs-patches-4045e58e88a876541a93857f45b4a69fcb78e347.tar.bz2
emacs-patches-4045e58e88a876541a93857f45b4a69fcb78e347.zip
29.1: Regenerate Japanese dictionaryemacs-29.1-patches-4
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--emacs/29.1/05_all_small-ja-dic.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/emacs/29.1/05_all_small-ja-dic.patch b/emacs/29.1/05_all_small-ja-dic.patch
new file mode 100644
index 0000000..117edbd
--- /dev/null
+++ b/emacs/29.1/05_all_small-ja-dic.patch
@@ -0,0 +1,92 @@
+Regenerate Japanese dictionary with --with-small-ja-dic option
+Patch from emacs-29 branch
+https://debbugs.gnu.org/66125
+
+Also update the following generated files:
+* leim/small-ja-dic-option
+* lisp/leim/ja-dic/ja-dic.{el,elc}
+
+commit 7d5fee0feaa5740f3fbbfc6d5f13855bf58b9c25
+Author: Eli Zaretskii <eliz@gnu.org>
+Date: Sun Sep 24 15:30:01 2023 +0300
+
+ Support regeneration of ja-dic.el under '--with-small-ja-dic'
+
+--- a/.gitignore
++++ b/.gitignore
+@@ -95,6 +95,7 @@ lisp/cedet/semantic/grammar-wy.el
+ lisp/eshell/esh-groups.el
+ lisp/finder-inf.el
+ lisp/leim/ja-dic/
++leim/small-ja-dic-option
+ lisp/leim/leim-list.el
+ lisp/leim/quail/4Corner.el
+ lisp/leim/quail/ARRAY30.el
+--- a/leim/Makefile.in
++++ b/leim/Makefile.in
+@@ -26,6 +26,7 @@ SHELL =
+ # Here are the things that we expect ../configure to edit.
+ srcdir=@srcdir@
+ top_builddir = @top_builddir@
++top_srcdir = @top_srcdir@
+
+ # Where the generated files go.
+ leimdir = ${srcdir}/../lisp/leim
+@@ -134,9 +135,15 @@ ${leimdir}/leim-list.el:
+
+ ${leimdir}/ja-dic/ja-dic.el: | $(leimdir)/ja-dic
+
++# This is used to support regeneration of ja-dic when the SMALL_JA_DIC
++# option is flipped by the configure-time option.
++small-ja-dic-option: ../config.status
++ $(AM_V_GEN)echo "Small ja-dic option: $(SMALL_JA_DIC)" > $@.$$$$ && \
++ ${top_srcdir}/build-aux/move-if-change $@.$$$$ $@
++
+ .PHONY: generate-ja-dic
+ generate-ja-dic: ${leimdir}/ja-dic/ja-dic.el
+-${leimdir}/ja-dic/ja-dic.el: $(srcdir)/SKK-DIC/SKK-JISYO.L
++${leimdir}/ja-dic/ja-dic.el: $(srcdir)/SKK-DIC/SKK-JISYO.L small-ja-dic-option
+ $(AM_V_GEN)$(RUN_EMACS) -batch -l ja-dic-cnv \
+ -f batch-skkdic-convert -dir "$(leimdir)/ja-dic" $(JA_DIC_NO_REDUCTION_OPTION) "$<"
+
+--- a/lisp/international/ja-dic-cnv.el
++++ b/lisp/international/ja-dic-cnv.el
+@@ -346,6 +346,8 @@ skkdic-convert
+ (erase-buffer)
+ (buffer-disable-undo)
+ (generate-lisp-file-heading ja-dic-filename 'skkdic-convert :code nil)
++ (insert (format ";; Generated with small ja-dic option: %s\n\n"
++ (if no-reduction "no" "yes")))
+ (insert ";; Original SKK dictionary file: "
+ (file-relative-name (expand-file-name filename) dirname)
+ "\n\n"
+--- a/make-dist
++++ b/make-dist
+@@ -357,6 +357,7 @@ possibly_non_vc_files=
+ MANIFEST aclocal.m4 configure
+ admin/charsets/jisx2131-filter
+ src/config.in
++ leim/small-ja-dic-option
+ "$(
+ find admin doc etc lisp \
+ \( -name '*.el' -o -name '*.elc' -o -name '*.map' -o -name '*.stamp' \
+--- /dev/null
++++ b/leim/small-ja-dic-option
+@@ -0,0 +1 @@
++Small ja-dic option: no
+--- a/lisp/leim/ja-dic/ja-dic.el
++++ b/lisp/leim/ja-dic/ja-dic.el
+@@ -3,6 +3,8 @@
+
+ ;; This file is part of GNU Emacs.
+
++;; Generated with small ja-dic option: no
++
+ ;; Original SKK dictionary file: ../../../leim/SKK-DIC/SKK-JISYO.L
+
+ ;;; Start of the header of the original SKK dictionary.
+--- a/lisp/leim/ja-dic/ja-dic.elc
++++ b/lisp/leim/ja-dic/ja-dic.elc
+@@ -5,1 +5,1 @@
+-
++