diff options
author | Sebastian Parborg <darkdefende@gmail.com> | 2011-08-16 21:06:41 +0200 |
---|---|---|
committer | Sebastian Parborg <darkdefende@gmail.com> | 2011-08-16 21:06:41 +0200 |
commit | 96333c9e80eea0d62421143f3c98ec1fc8db13f9 (patch) | |
tree | e5c25be1eb2625398af5832078048e2864c0edd3 | |
parent | Forgot to rename .dir to .url (diff) | |
download | ebuildgen-96333c9e80eea0d62421143f3c98ec1fc8db13f9.tar.gz ebuildgen-96333c9e80eea0d62421143f3c98ec1fc8db13f9.tar.bz2 ebuildgen-96333c9e80eea0d62421143f3c98ec1fc8db13f9.zip |
Added the ebuild to the git repo
-rw-r--r-- | README | 5 | ||||
-rw-r--r-- | overlay/app-portage/ebuildgen/Manifest | 1 | ||||
-rw-r--r-- | overlay/app-portage/ebuildgen/ebuildgen-9999.ebuild | 36 | ||||
-rw-r--r-- | overlay/profiles/repo_name | 1 |
4 files changed, 43 insertions, 0 deletions
@@ -0,0 +1,5 @@ +This is the ebuild generator project. + +Run "genebuild" to execute the program. + +The sources files is in the dir "ebuildgen" and the ebuild for the project is in the dir "overlay" diff --git a/overlay/app-portage/ebuildgen/Manifest b/overlay/app-portage/ebuildgen/Manifest new file mode 100644 index 0000000..c1b1ed6 --- /dev/null +++ b/overlay/app-portage/ebuildgen/Manifest @@ -0,0 +1 @@ +EBUILD ebuildgen-9999.ebuild 634 RMD160 e66ddff45ce97c0c07d4cf1997adb5d645f9408e SHA1 dd4c88878a911073370b3934cd6eaffeafdb928f SHA256 42811afa69a15c8da80e19ad15370d828718b29fb3b156d0549167799a7ed1f1 diff --git a/overlay/app-portage/ebuildgen/ebuildgen-9999.ebuild b/overlay/app-portage/ebuildgen/ebuildgen-9999.ebuild new file mode 100644 index 0000000..6ae7622 --- /dev/null +++ b/overlay/app-portage/ebuildgen/ebuildgen-9999.ebuild @@ -0,0 +1,36 @@ +# Copyright 1999-2011 Gentoo Foundation +# Distributed under the terms of the GNU General Public License v2 +# $Header: $ + +EAPI=3 + +PYTHON_DEPEND="3:3.2" +SUPPORT_PYTHON_ABIS=1 +RESTRICT_PYTHON_ABIS="2.*" +inherit git distutils + +DESCRIPTION="A python script to generate ebuilds for autotool C/C++ projects" +HOMEPAGE="" +EGIT_REPO_URI="git://github.com/DarkDefender/ebuildgen.git" + +LICENSE="" +SLOT="0" +KEYWORDS="" +IUSE="" + +DEPEND="dev-python/ply + app-portage/gentoopm + app-portage/portage-utils" +RDEPEND="${DEPEND}" + +src_prepare() { + distutils_src_prepare +} + +src_compile() { + distutils_src_compile +} + +src_install() { + distutils_src_install +} diff --git a/overlay/profiles/repo_name b/overlay/profiles/repo_name new file mode 100644 index 0000000..5e3b76f --- /dev/null +++ b/overlay/profiles/repo_name @@ -0,0 +1 @@ +ebuildgen |