aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-15 13:03:16 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-15 13:03:16 -0700
commit2731f5f4571c91acb0e459ddcec6582bba25f5ce (patch)
treeff752a8dec417bd67cbe772955a20dbe2a36cb02
parentcatalyst: Remove unused import and reorder (diff)
downloadcatalyst-2731f5f4571c91acb0e459ddcec6582bba25f5ce.tar.gz
catalyst-2731f5f4571c91acb0e459ddcec6582bba25f5ce.tar.bz2
catalyst-2731f5f4571c91acb0e459ddcec6582bba25f5ce.zip
catalyst: Fix and enable bad-continuation checks
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--.pylintrc2
-rw-r--r--catalyst/base/stagebase.py8
-rwxr-xr-xsetup.py2
3 files changed, 5 insertions, 7 deletions
diff --git a/.pylintrc b/.pylintrc
index 8caafef1..5428e349 100644
--- a/.pylintrc
+++ b/.pylintrc
@@ -26,7 +26,6 @@ load-plugins=
# We should clean up things so we can enable:
# missing-docstring -- add lots of docstrings everywhere!
# bad-whitespace -- fix spacing everywhere
-# bad-continuation -- might be hard with tab indentation policy
# invalid-name -- need to manage constants better
# line-too-long -- figure out a length and stick to it
# super-init-not-called -- fix the classes __init__ structure
@@ -46,7 +45,6 @@ disable=
fixme,
broad-except,
bad-whitespace,
- bad-continuation,
invalid-name,
line-too-long,
super-init-not-called,
diff --git a/catalyst/base/stagebase.py b/catalyst/base/stagebase.py
index d2f16f9b..f673382f 100644
--- a/catalyst/base/stagebase.py
+++ b/catalyst/base/stagebase.py
@@ -443,8 +443,8 @@ class StageBase(TargetBase, ClearBase, GenBase):
if os.path.exists(self.settings["source_path"]):
self.settings["source_path_hash"] = \
self.settings["hash_map"].generate_hash(
- self.settings["source_path"],
- hash_=self.settings["hash_function"])
+ self.settings["source_path"],
+ hash_=self.settings["hash_function"])
log.notice('Source path set to %s', self.settings['source_path'])
def set_dest_path(self):
@@ -470,8 +470,8 @@ class StageBase(TargetBase, ClearBase, GenBase):
log.info('SNAPSHOT_PATH set to: %s', self.settings['snapshot_path'])
self.settings["snapshot_path_hash"] = \
self.settings["hash_map"].generate_hash(
- self.settings["snapshot_path"],
- hash_=self.settings["hash_function"])
+ self.settings["snapshot_path"],
+ hash_=self.settings["hash_function"])
def set_snapcache_path(self):
self.settings["snapshot_cache_path"] = \
diff --git a/setup.py b/setup.py
index fef09622..7a97b30c 100755
--- a/setup.py
+++ b/setup.py
@@ -93,7 +93,7 @@ _setup(
long_description=_codecs.open(
_os.path.join(_this_dir, 'README'), 'r', 'utf-8').read(),
classifiers=[
- 'Development Status :: 5 - Production/Stable',
+ 'Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
'Intended Audience :: System Administrators',
'Operating System :: POSIX',