aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2018-08-25 11:54:26 -0500
committerDoug Goldstein <cardoe@cardoe.com>2018-08-26 12:56:12 -0500
commitd9b2cb3ae2aca5206248e2ea7d56f51126ecfb60 (patch)
treef054db7daac62397d21a2f661339a7308d2bdde3 /test-crate
parentadd colored help and removed clap settings (diff)
downloadcargo-ebuild-d9b2cb3ae2aca5206248e2ea7d56f51126ecfb60.tar.gz
cargo-ebuild-d9b2cb3ae2aca5206248e2ea7d56f51126ecfb60.tar.bz2
cargo-ebuild-d9b2cb3ae2aca5206248e2ea7d56f51126ecfb60.zip
add a basic hello world application for testing
This is a really basic hello world application (literally `cargo init --bin`) to be used for testing.
Diffstat (limited to 'test-crate')
-rw-r--r--test-crate/Cargo.lock4
-rw-r--r--test-crate/Cargo.toml6
-rw-r--r--test-crate/src/main.rs3
3 files changed, 13 insertions, 0 deletions
diff --git a/test-crate/Cargo.lock b/test-crate/Cargo.lock
new file mode 100644
index 0000000..d540813
--- /dev/null
+++ b/test-crate/Cargo.lock
@@ -0,0 +1,4 @@
+[[package]]
+name = "test-crate"
+version = "0.1.0"
+
diff --git a/test-crate/Cargo.toml b/test-crate/Cargo.toml
new file mode 100644
index 0000000..910a22d
--- /dev/null
+++ b/test-crate/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "test-crate"
+version = "0.1.0"
+authors = ["Doug Goldstein <cardoe@cardoe.com>"]
+
+[dependencies]
diff --git a/test-crate/src/main.rs b/test-crate/src/main.rs
new file mode 100644
index 0000000..e7a11a9
--- /dev/null
+++ b/test-crate/src/main.rs
@@ -0,0 +1,3 @@
+fn main() {
+ println!("Hello, world!");
+}