summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2014-09-20 20:17:50 +0200
committerSebastian Pipping <sebastian@pipping.org>2014-09-20 20:39:54 +0200
commit7d920494dd39bcb954789111b5d10a1a29a1b388 (patch)
tree00e5f3e30f4b458be859d41a58f3502c57be503c /gnome-extra
parentgames-board/gambit: 0_p31 (diff)
downloadbetagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.tar.gz
betagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.tar.bz2
betagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.zip
gnome-extra/gnome-paint: 0.4.0-r1
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-paint/Manifest15
-rw-r--r--gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch38
-rw-r--r--gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch28
-rw-r--r--gnome-extra/gnome-paint/gnome-paint-0.4.0-r1.ebuild (renamed from gnome-extra/gnome-paint/gnome-paint-0.4.0.ebuild)11
4 files changed, 77 insertions, 15 deletions
diff --git a/gnome-extra/gnome-paint/Manifest b/gnome-extra/gnome-paint/Manifest
index 8e40083..2239981 100644
--- a/gnome-extra/gnome-paint/Manifest
+++ b/gnome-extra/gnome-paint/Manifest
@@ -1,14 +1 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
-
-DIST gnome-paint-0.4.0.tar.gz 432754 RMD160 ad112e4d35f9c4db8d663f5c7b3f70744ca9de3d SHA1 b8fc8602fdb9c6f8c8476509d12a9ee8f569ef5e SHA256 2028d539354acd29d8d480a0588991b1edf90d2a3d43ab00d76a0a607d5398c9
-EBUILD gnome-paint-0.4.0.ebuild 702 RMD160 480f710a58bcc596ac1737a7c1af3b27dabf970e SHA1 e5931abe5ed264d7be4ecd549680f1b954bc0226 SHA256 7a6346934cbc9376c7b790ff74ff918e717bdc1842a9a56611a7acc2a7a51b45
-MISC ChangeLog 234 RMD160 9774c3ee423b605f91a48908cd6f07f2f84484eb SHA1 95bf39f9c416c0f78568da204a363810bb8daabb SHA256 4ea7f389e6fc5491bd32c30593a1afd8da3f8010c1554891df068be4970f46eb
-MISC metadata.xml 235 RMD160 e964157be48c204555d79827e1bf79c9d9fb23a5 SHA1 767b5eb408113ae55d84adcb94d44a692285d175 SHA256 095e4ee6b3ae673e7ddf0d4e166a632d3384d6374c6dd86d8c401a8f5c43f7fe
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.18 (GNU/Linux)
-
-iEYEAREKAAYFAk6piUoACgkQgAnW8HDreRZhPACglu1wDuTAjGYhPLQ5hlQgEIg5
-6hsAoLBkpUF+bgKyE+sF8g7qd2BrQ8db
-=qwTL
------END PGP SIGNATURE-----
+DIST gnome-paint-0.4.0.tar.gz 432754 SHA256 2028d539354acd29d8d480a0588991b1edf90d2a3d43ab00d76a0a607d5398c9 SHA512 baa45055fa3b0840d712a9181f475b0063944ff073d76e56e2dca653dd636bc733511dc237f0c9f733b7ab1ac616d74c16e197576faeaae46d8a02ec2e7d7a9e WHIRLPOOL dd275e236a5eabb00dda1abb118af9930543625a986ef6cb93627940f39b9804b72b331cba11d640f92d30283464f42f91dfa56eadb5b2e20f310e8e33aa1bec
diff --git a/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch
new file mode 100644
index 0000000..8fe68b2
--- /dev/null
+++ b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch
@@ -0,0 +1,38 @@
+From 80957a66306bc68af9119808f81b8e42171a39e4 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 20 Sep 2014 20:31:39 +0200
+Subject: [PATCH] Fix crash in get_gtk_image
+
+Based on https://bazaar.launchpad.net/~andrewwang43/gnome-paint/nosegfault/diff/84
+---
+ src/toolbar.c | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/src/toolbar.c b/src/toolbar.c
+index 1c5ba03..ad5cffd 100644
+--- a/src/toolbar.c
++++ b/src/toolbar.c
+@@ -497,15 +497,13 @@ on_brush11_realize (GtkObject *object, gpointer user_data)
+ static GtkWidget *
+ get_gtk_image ( GtkWidget *widget, gchar** xpm )
+ {
+- GdkPixmap *gdkpixmap = NULL;
+- GdkBitmap *mask = NULL;
++ GdkPixbuf *gdkpixbuf = NULL;
+ GtkWidget *gtkimage = NULL;
+- gdkpixmap = gdk_pixmap_create_from_xpm_d(widget->window, &mask, NULL, xpm);
+- g_assert ( gdkpixmap );
+- gtkimage = gtk_image_new_from_pixmap(gdkpixmap, mask);
++ gdkpixbuf = gdk_pixbuf_new_from_xpm_data(xpm);
++ g_assert ( gdkpixbuf );
++ gtkimage = gtk_image_new_from_pixbuf(gdkpixbuf);
+ g_assert ( gtkimage );
+- g_object_unref ( G_OBJECT(gdkpixmap) );
+- g_object_unref ( G_OBJECT(mask) );
++ g_object_unref ( G_OBJECT(gdkpixbuf) );
+ gtk_widget_show(gtkimage);
+ return gtkimage;
+ }
+--
+2.1.0
+
diff --git a/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch
new file mode 100644
index 0000000..c8388f8
--- /dev/null
+++ b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch
@@ -0,0 +1,28 @@
+From ff61205fc363473d8b029dd9e822a0bc0e6712b8 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 20 Sep 2014 20:10:42 +0200
+Subject: [PATCH] Add missing -lm to fix link error
+
+[..]/bin/ld: gnome_paint-cv_paintbrush_tool.o: undefined reference to symbol 'sqrt@@GLIBC_2.2.5'
+/lib64/libm.so.6: error adding symbols: DSO missing from command line
+collect2: error: ld returned 1 exit status
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2bea3b4..852ae55 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -87,7 +87,7 @@ gnome_paint_LDFLAGS = \
+ -Wl,--export-dynamic
+
+ gnome_paint_LDADD = \
+- $(GNOME_PAINT_LIBS) -lX11
++ $(GNOME_PAINT_LIBS) -lX11 -lm
+
+ SUBDIRS = \
+ pixmaps
+--
+2.1.0
+
diff --git a/gnome-extra/gnome-paint/gnome-paint-0.4.0.ebuild b/gnome-extra/gnome-paint/gnome-paint-0.4.0-r1.ebuild
index 17333f8..794ca78 100644
--- a/gnome-extra/gnome-paint/gnome-paint-0.4.0.ebuild
+++ b/gnome-extra/gnome-paint/gnome-paint-0.4.0-r1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI="5"
+
+inherit eutils autotools
DESCRIPTION="Simple paint program inspired by MS Paint"
HOMEPAGE="https://code.google.com/p/gnome-paint/"
@@ -17,6 +19,13 @@ RDEPEND=">=x11-libs/gtk+-2.16:2"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libm.patch
+ epatch "${FILESDIR}"/${P}-crash-get_gtk_image.patch
+
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die