summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-29 11:01:09 +0200
committerJustin Lecher <jlec@gentoo.org>2013-04-29 11:01:09 +0200
commit6fb6bae926d5020def20d28827c345094405286c (patch)
treeaa1ad6374126643920daef87a0854199e912f0b3 /dev-vcs
parentgames-arcade/ultrastardx: Fix SRC_URI (diff)
downloadbetagarden-6fb6bae926d5020def20d28827c345094405286c.tar.gz
betagarden-6fb6bae926d5020def20d28827c345094405286c.tar.bz2
betagarden-6fb6bae926d5020def20d28827c345094405286c.zip
dev-vcs/git-cola: Version BUmp and move to new python eclasses
Package-Manager: portage-2.2.0_alpha173
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog3
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild74
2 files changed, 38 insertions, 39 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index d4a36ea..4acdac3 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.8 2011/04/13 19:00:02 jlec Exp $
+ 29 Apr 2013; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild:
+ Version BUmp and move to new python eclasses
+
15 Jan 2013; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild,
metadata.xml:
Correct github owner
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
index b5f3fa5..ef647ba 100644
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ b/dev-vcs/git-cola/git-cola-9999.ebuild
@@ -2,17 +2,17 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/cola-1.4.3.2.ebuild,v 1.1 2011/04/13 19:00:02 jlec Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=true
-EGIT_REPO_URI="git://github.com/git-cola/git-cola.git"
-
-inherit distutils eutils git-2
+inherit distutils-r1 git-2
DESCRIPTION="The highly caffeinated git GUI"
HOMEPAGE="http://git-cola.github.com/"
SRC_URI=""
+EGIT_REPO_URI="git://github.com/git-cola/git-cola.git"
LICENSE="GPL-2"
SLOT="0"
@@ -20,27 +20,27 @@ KEYWORDS=""
IUSE="doc test"
RDEPEND="
- dev-python/jsonpickle
- dev-python/pyinotify
- dev-python/PyQt4
+ dev-python/jsonpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
dev-vcs/git"
DEPEND="${RDEPEND}
doc? (
app-text/asciidoc
- dev-python/sphinx
+ dev-python/sphinx[${PYTHON_USEDEP}]
app-text/xmlto )
sys-devel/gettext
- test? ( dev-python/nose )"
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
# tests currently broken due to unfinished translation framework
RESTRICT="test"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-disable-tests.patch
+ "${FILESDIR}"/${PV}-system-ssh-askpass.patch
+ )
-src_prepare() {
+python_prepare_all() {
# don't install docs into wrong location
sed -i \
-e '/doc/d' \
@@ -50,49 +50,45 @@ src_prepare() {
-e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
cola/resources.py || die "sed failed"
- epatch \
- "${FILESDIR}"/9999-disable-tests.patch \
- "${FILESDIR}"/9999-system-ssh-askpass.patch
-
- python_convert_shebangs 2 bin/git-cola bin/git-dag
+ distutils-r1_python_prepare_all
}
-src_compile() {
- distutils_src_compile
-
+python_compile_all() {
+ cd share/doc/${PN}/
if use doc ; then
- cd share/doc/git-cola/
emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -i Makefile || die
fi
}
-src_install() {
- distutils_src_install
-
- dodoc share/doc/git-cola/*.txt
+python_install_all() {
+ cd share/doc/${PN}/
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
if use doc ; then
- dohtml -r _build/html/*
- doman *.1
+ HTML_DOCS=( share/doc/${PN}/_build/html/. )
else
- dohtml "${FILESDIR}/index.html"
+ HTML_DOCS=( "${FILESDIR}"/index.html )
fi
+
+ distutils-r1_python_install_all
}
-src_test() {
+python_test() {
PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
--verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
|| die "running nosetests failed"
}
pkg_postinst() {
- python_mod_optimize /usr/share/git-cola/lib/cola
-
elog "Please make sure you have either a SSH key management installed and activated or"
elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH. "
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/git-cola/lib/cola
+ elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
}