summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBenedikt Böhm <bb@xnull.de>2010-11-24 14:14:03 +0100
committerBenedikt Böhm <bb@xnull.de>2010-11-24 14:14:03 +0100
commit094291af437a6b329f175b8bcc0231a4ff25e42a (patch)
tree33824a6d5ed02b27c7ce592d8b665f6d4681629d /dev-db
parentadd dev-db/xtrabackup-bin. should be converted to source ebuild, but the buil... (diff)
downloadbetagarden-094291af437a6b329f175b8bcc0231a4ff25e42a.tar.gz
betagarden-094291af437a6b329f175b8bcc0231a4ff25e42a.tar.bz2
betagarden-094291af437a6b329f175b8bcc0231a4ff25e42a.zip
add patch for perl 5.12 compatibility
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/xtrabackup-bin/Manifest3
-rw-r--r--dev-db/xtrabackup-bin/files/innobackupex-perl-5.12.patch15
-rw-r--r--dev-db/xtrabackup-bin/xtrabackup-bin-1.4.ebuild4
3 files changed, 21 insertions, 1 deletions
diff --git a/dev-db/xtrabackup-bin/Manifest b/dev-db/xtrabackup-bin/Manifest
index 1c41adf..4a9b366 100644
--- a/dev-db/xtrabackup-bin/Manifest
+++ b/dev-db/xtrabackup-bin/Manifest
@@ -1,2 +1,3 @@
+AUX innobackupex-perl-5.12.patch 711 RMD160 b12282ca6d383dfcfe4005c1e828b2fba25c16f9 SHA1 0d868bdd9275fbc414ddf9e7b2d5df83cc60f5f8 SHA256 694644dfd5f3d29a9bd8b0bd9b5937ca608ecacf1ea29866a132263f0d1d9e60
DIST xtrabackup-1.4.tar.gz 5286661 RMD160 d3e45228aaf9325b84fd18dae5f3a27aafae6d62 SHA1 aa9b2feebb769c83d09f9f99eb14068d8085976b SHA256 12065a7caf21dd9d5e435d89f4e756bfd9a634392c592c68c43967b479d8b990
-EBUILD xtrabackup-bin-1.4.ebuild 898 RMD160 0928768f77cd259134d4d35389321b376591ce81 SHA1 e772432ee41ed84512a5154efca0a63f5e52e14d SHA256 8e0d4830376a6225eccd95835feaf125b9c50d56fd71e0238d0b5970e810e0fa
+EBUILD xtrabackup-bin-1.4.ebuild 968 RMD160 310f502baa0802eb770563d80937beb4ec27a077 SHA1 be7158ddb466502a6fb0d1b5af2c33908671b2e4 SHA256 189d72d94f9e31c6635e83d5a48f52ca53a734fb726e01176cc03aa5b82feb40
diff --git a/dev-db/xtrabackup-bin/files/innobackupex-perl-5.12.patch b/dev-db/xtrabackup-bin/files/innobackupex-perl-5.12.patch
new file mode 100644
index 0000000..2946e36
--- /dev/null
+++ b/dev-db/xtrabackup-bin/files/innobackupex-perl-5.12.patch
@@ -0,0 +1,15 @@
+diff --git a/bin/innobackupex-1.5.1 b/bin/innobackupex-1.5.1
+index c974302..d8f644d 100755
+--- a/bin/innobackupex-1.5.1
++++ b/bin/innobackupex-1.5.1
+@@ -1702,9 +1702,7 @@ sub check_args {
+ print STDERR "$prefix Warning: perl $required_version or newer!\n";
+ }
+ } else {
+- $perl_version = chr($required_perl_version[0])
+- . chr($required_perl_version[1])
+- . chr($required_perl_version[2]);
++ $perl_version = "v$required_perl_version[0].$required_perl_version[1].$required_perl_version[2]";
+ if ($^V lt $perl_version) {
+ my $version = chr(48 + $required_perl_version[0])
+ . "." . chr(48 + $required_perl_version[1])
diff --git a/dev-db/xtrabackup-bin/xtrabackup-bin-1.4.ebuild b/dev-db/xtrabackup-bin/xtrabackup-bin-1.4.ebuild
index 6edd4fc..0a4789e 100644
--- a/dev-db/xtrabackup-bin/xtrabackup-bin-1.4.ebuild
+++ b/dev-db/xtrabackup-bin/xtrabackup-bin-1.4.ebuild
@@ -24,6 +24,10 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/xtrabackup-${PV}"
+src_prepare() {
+ epatch "${FILESDIR}"/innobackupex-perl-5.12.patch
+}
+
src_install() {
for i in innobackupex-1.5.1 xtrabackup_51 xtrabackup tar4ibd; do
dobin "${S}"/bin/$i