summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Böhm <bb@xnull.de>2010-10-10 06:45:40 +0200
committerBenedikt Böhm <bb@xnull.de>2010-10-10 06:45:40 +0200
commitf493b4d289b7b69970d8e71f8db4851a67239f67 (patch)
tree5c422296b0641111078b415fd0421fc70c3d2178 /app-admin
parentupdate systemd ebuild and dependencies (diff)
downloadbetagarden-f493b4d289b7b69970d8e71f8db4851a67239f67.tar.gz
betagarden-f493b4d289b7b69970d8e71f8db4851a67239f67.tar.bz2
betagarden-f493b4d289b7b69970d8e71f8db4851a67239f67.zip
collectd is in main portage tree now
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/collectd/Manifest4
-rw-r--r--app-admin/collectd/collectd-4.10.1.ebuild332
-rw-r--r--app-admin/collectd/files/collectd.confd16
-rw-r--r--app-admin/collectd/files/collectd.initd27
4 files changed, 0 insertions, 379 deletions
diff --git a/app-admin/collectd/Manifest b/app-admin/collectd/Manifest
deleted file mode 100644
index 301cf82..0000000
--- a/app-admin/collectd/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX collectd.confd 529 RMD160 59ab4aa9eab3db05d025676a4c59d6bc4769cfdf SHA1 496c7b3aadcc1483d6cf1741f92c9a67d3f09ebc SHA256 f4200b094b8e5eaea2f9aba94cdf75cdc8731c346f590e6530917e0dd5f2f903
-AUX collectd.initd 659 RMD160 98d3ba6f160a928b9358ceb5a7759c335a459fcd SHA1 45bead8031f01f2a179c623b66ee63ee556d3c82 SHA256 3965a97e764d4459b7b1f6663fcb0287a7b262afcc93e4ce2158470b6f136aa9
-DIST collectd-4.10.1.tar.bz2 1415626 RMD160 f609f70bd7bb789ab54ca72edd34c3753692ff00 SHA1 bda5c918761b98e82fa18da056f60916703b5805 SHA256 607ea5d22164eaf434223dd39a1df453103e2f3c2f2b8c1dbfc1531eefb6df56
-EBUILD collectd-4.10.1.ebuild 10036 RMD160 1f80b4cbd461506c821a444eb4d1783177f3724a SHA1 6a73c791f3c0df8b4a801b801ec1d8fe7fed3b03 SHA256 df35ff8867bf99292d25a17d877b1668ce384ff475beaaad0710c3c63a3b2080
diff --git a/app-admin/collectd/collectd-4.10.1.ebuild b/app-admin/collectd/collectd-4.10.1.ebuild
deleted file mode 100644
index 9cfdb11..0000000
--- a/app-admin/collectd/collectd-4.10.1.ebuild
+++ /dev/null
@@ -1,332 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit linux-info perl-app
-
-DESCRIPTION="A small daemon which collects system performance statistics - with a near-infinite number of plugins"
-HOMEPAGE="http://collectd.org"
-SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="contrib debug kernel_linux kernel_FreeBSD kernel_Darwin"
-
-# hal is autodetected by configure, so there is no point in a hal useflag.
-# DEPENDing it for now for the UUID plugin, so we get a consistent state...
-# TODO: patch configure.in to provide with/without-hal
-
-# The plugin lists have to follow here since they extend IUSE
-
-COLLECTD_READ_PLUGINS="apache apcups apple_sensors ascent battery bind conntrack
-+contextswitch +cpu cpufreq curl curl_xml dbi +df +disk dns email +entropy exec
-filecount fscache gmond +hddtemp +interface ipmi iptables ipvs irq libvirt +load
-madwifi mbmon memcachec memcached +memory modbus multimeter mysql netlink
-network nfs nginx ntpd nut olsrd onewire openvpn oracle postgresql powerdns
-+processes protocols routeros rrdcached sensors serial snmp +swap table tail
-tape tcpconns teamspeak2 ted thermal tokyotyrant uptime users vmem vserver
-wireless zfs_arc"
-
-COLLECTD_BINDING_PLUGINS="java perl python"
-
-COLLECTD_WRITE_PLUGINS="csv rrdcached +rrdtool write_http"
-
-COLLECTD_NETWORK_PLUGINS="+network +unixsock"
-
-COLLECTD_NOTIFY_PLUGINS="notify_desktop notify_email"
-
-COLLECTD_LOGGING_PLUGINS="+logfile +syslog"
-
-COLLECTD_MATCH_PLUGINS="match_empty_counter match_hashed match_regex
-match_timediff match_value"
-
-COLLECTD_TARGET_PLUGINS="target_notification target_replace target_scale
-target_set"
-
-COLLECTD_MISC_PLUGINS="uuid"
-
-COLLECTD_PLUGINS="${COLLECTD_READ_PLUGINS}
- ${COLLECTD_BINDING_PLUGINS}
- ${COLLECTD_WRITE_PLUGINS}
- ${COLLECTD_NETWORK_PLUGINS}
- ${COLLECTD_NOTIFY_PLUGINS}
- ${COLLECTD_LOGGING_PLUGINS}
- ${COLLECTD_MATCH_PLUGINS}
- ${COLLECTD_TARGET_PLUGINS}
- ${COLLECTD_MISC_PLUGINS}"
-
-COLLECTD_DISABLED_PLUGINS="curl_json netapp pinba ping xmms"
-
-for plugin in ${COLLECTD_PLUGINS}; do
- IUSE="${IUSE} ${plugin%%[a-z]*}cd_${plugin#+}"
-done
-
-# Now come the dependencies.
-
-COMMON_DEPEND="
- cd_apache? ( net-misc/curl )
- cd_ascent? ( net-misc/curl dev-libs/libxml2 )
- cd_bind? ( dev-libs/libxml2 )
- cd_curl? ( net-misc/curl )
- cd_curl_xml? ( net-misc/curl dev-libs/libxml2 )
- cd_dbi? ( dev-db/libdbi )
- cd_dns? ( net-libs/libpcap )
- cd_gmond? ( sys-cluster/ganglia )
- cd_ipmi? ( >=sys-libs/openipmi-2.0.11 )
- cd_iptables? ( net-firewall/iptables )
- cd_java? ( virtual/jre dev-java/java-config-wrapper )
- cd_libvirt? ( app-emulation/libvirt dev-libs/libxml2 )
- cd_memcachec? ( dev-libs/libmemcached )
- cd_modbus? ( dev-libs/libmodbus )
- cd_mysql? ( >=virtual/mysql-5.0 )
- cd_netlink? ( sys-apps/iproute2 )
- cd_network? ( dev-libs/libgcrypt )
- cd_nginx? ( net-misc/curl )
- cd_notify_desktop? ( x11-libs/libnotify )
- cd_notify_email? ( >=net-libs/libesmtp-1.0.4 dev-libs/openssl )
- cd_nut? ( >=sys-power/nut-2.2.0 )
- cd_onewire? ( sys-fs/owfs )
- cd_oracle? ( >=dev-db/oracle-instantclient-basic-11.1.0.7.0 )
- cd_perl? ( dev-lang/perl[ithreads] sys-devel/libperl[ithreads] )
- cd_postgres? ( >=virtual/postgresql-base-8.2 )
- cd_python? ( || ( dev-lang/python:2.4 dev-lang/python:2.5 dev-lang/python:2.6 ) )
- cd_rrdcached? ( >=net-analyzer/rrdtool-1.4 )
- cd_rrdtool? ( >=net-analyzer/rrdtool-1.2.27 )
- cd_sensors? ( sys-apps/lm_sensors )
- cd_snmp? ( net-analyzer/net-snmp )
- cd_tokyotyrant? ( net-misc/tokyotyrant )
- cd_uuid? ( sys-apps/hal )
- cd_write_http? ( net-misc/curl )
-
- kernel_FreeBSD? (
- cd_disk? ( >=sys-libs/libstatgrab-0.16 )
- cd_interface? ( >=sys-libs/libstatgrab-0.16 )
- cd_load? ( >=sys-libs/libstatgrab-0.16 )
- cd_memory? ( >=sys-libs/libstatgrab-0.16 )
- cd_swap? ( >=sys-libs/libstatgrab-0.16 )
- cd_users? ( >=sys-libs/libstatgrab-0.16 )
- )"
-
-DEPEND="${COMMON_DEPEND}
- dev-util/pkgconfig
- kernel_linux? (
- cd_vserver? ( sys-kernel/vserver-sources )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- cd_syslog? ( virtual/logger )"
-
-collectd_plugin_kernel_linux() {
- if use cd_${1} && ! has ~$2 $CONFIG_CHECK; then
- CONFIG_CHECK+=" ~$2"
- fi
-}
-
-collectd_linux_kernel_checks() {
- CONFIG_CHECK=""
-
- # battery.c:/proc/pmu/battery_%i
- # battery.c:/proc/acpi/battery
- collectd_plugin_kernel_linux battery PROC_FS
- collectd_plugin_kernel_linux battery ACPI_BATTERY
-
- # cpu.c:/proc/stat
- collectd_plugin_kernel_linux cpu PROC_FS
-
- # cpufreq.c:/sys/devices/system/cpu/cpu%d/cpufreq/
- collectd_plugin_kernel_linux cpufreq SYSFS
- collectd_plugin_kernel_linux cpufreq CPU_FREQ_STAT
-
- # utils_mount.c:/proc/partitions
- collectd_plugin_kernel_linux df PROC_FS
-
- # disk.c:/proc/diskstats
- # disk.c:/proc/partitions
- collectd_plugin_kernel_linux disk PROC_FS
-
- # entropy.c:/proc/sys/kernel/random/entropy_avail
- collectd_plugin_kernel_linux entropy PROC_FS
-
- # hddtemp.c:/proc/partitions
- collectd_plugin_kernel_linux hddtemp PROC_FS
-
- # interface.c:/proc/net/dev
- collectd_plugin_kernel_linux interface PROC_FS
- collectd_plugin_kernel_linux ipmi IPMI_HANDLER
- collectd_plugin_kernel_linux ipvs IP_VS
-
- # irq.c:/proc/interrupts
- collectd_plugin_kernel_linux irq PROC_FS
-
- # load.c:/proc/loadavg
- collectd_plugin_kernel_linux load PROC_FS
-
- # memory.c:/proc/meminfo
- collectd_plugin_kernel_linux memory PROC_FS
-
- # nfs.c:/proc/net/rpc/nfs
- # nfs.c:/proc/net/rpc/nfsd
- collectd_plugin_kernel_linux nfs PROC_FS
- collectd_plugin_kernel_linux nfs NFS_COMMON
-
- # processes.c:/proc/%i/task
- # processes.c:/proc/%i/stat
- collectd_plugin_kernel_linux processes PROC_FS
-
- # serial.c:/proc/tty/driver/serial
- # serial.c:/proc/tty/driver/ttyS
- collectd_plugin_kernel_linux serial PROC_FS
- collectd_plugin_kernel_linux serial SERIAL_CORE
-
- # swap.c:/proc/meminfo
- collectd_plugin_kernel_linux swap PROC_FS
- collectd_plugin_kernel_linux swap SWAP
-
- # tcpconns.c:/proc/net/tcp
- # tcpconns.c:/proc/net/tcp6
- collectd_plugin_kernel_linux tcpconns PROC_FS
-
- # thermal.c:/proc/acpi/thermal_zone
- # thermal.c:/sys/class/thermal
- collectd_plugin_kernel_linux thermal PROC_FS
- collectd_plugin_kernel_linux thermal SYSFS
- collectd_plugin_kernel_linux thermal ACPI_THERMAL
-
- # vmem.c:/proc/vmstat
- collectd_plugin_kernel_linux vmem PROC_FS
- collectd_plugin_kernel_linux vmem VM_EVENT_COUNTERS
-
- # vserver.c:/proc/virtual
- collectd_plugin_kernel_linux vserver PROC_FS
-
- # uuid.c:/sys/hypervisor/uuid
- collectd_plugin_kernel_linux uuid SYSFS
-
- # wireless.c:/proc/net/wireless
- collectd_plugin_kernel_linux wireless PROC_FS
- collectd_plugin_kernel_linux wireless MAC80211
-
- linux-info_pkg_setup
-}
-
-pkg_setup() {
- elog
- elog "The following plug-ins are in general not supported by this ebuild (e.g. because"
- elog "Gentoo does not provide required dependencies):"
- for plugin in ${COLLECTD_DISABLED_PLUGINS}; do
- elog "\t${plugin}"
- done
- elog
-
- if use kernel_linux; then
- collectd_linux_kernel_checks
- fi
-}
-
-src_prepare() {
- # There's some strange prefix handling in the default config file, resulting in
- # paths like "/usr/var/..."
- sed -i -e "s:@prefix@/var:/var:g" src/collectd.conf.in
-
- # xtables.h:193:1: error: "aligned_u64" redefined
- sed -i -e "/define aligned_u64/d" src/owniptc/xtables.h
-}
-
-src_configure() {
- # Now come the lists of os-dependent plugins. Any plugin that is not listed anywhere here
- # should work independent of the operating system.
-
- local linux_plugins="battery cpu cpufreq disk entropy interface iptables ipvs irq load
- memory netlink nfs processes serial swap tcpconns thermal users vmem vserver
- wireless"
-
- local libstatgrab_plugins="cpu disk interface load memory swap users"
- local bsd_plugins="cpu tcpconns ${libstatgrab_plugins}"
-
- local darwin_plugins="apple_sensors battery cpu disk interface memory processes tcpconns"
-
- local osdependent_plugins="${linux_plugins} ${bsd_plugins} ${darwin_plugins}"
- local myos_plugins=""
- if use kernel_linux; then
- einfo "Enabling Linux plugins."
- myos_plugins=${linux_plugins}
- elif use kernel_FreeBSD; then
- einfo "Enabling FreeBSD plugins."
- myos_plugins=${bsd_plugins}
- elif use kernel_Darwin; then
- einfo "Enabling Darwin plugins."
- myos_plugins=${darwin_plugins}
- fi
-
- # Do we debug?
- local myconf="$(use_enable debug)"
-
- # Disable what needs to be disabled.
- for plugin in ${COLLECTD_DISABLED_PLUGINS}; do
- myconf="${myconf} --disable-${plugin}"
- done
-
- # Set enable/disable for each single plugin.
- for plugin in ${COLLECTD_PLUGINS}; do
- plugin=${plugin#+}
- if has ${plugin} ${osdependent_plugins}; then
- # plugin is os-dependent ...
- if has ${plugin} ${myos_plugins}; then
- # ... and available in this os
- myconf="${myconf} $(use_enable cd_${plugin} ${plugin})"
- else
- # ... and NOT available in this os
- if use cd_${plugin}; then
- ewarn "You try to enable the ${plugin} plugin, but it is not available for this"
- ewarn "kernel. Disabling it automatically."
- fi
- myconf="${myconf} --disable-${plugin}"
- fi
- else
- myconf="${myconf} $(use_enable cd_${plugin} ${plugin})"
- fi
- done
-
- # Need JAVA_HOME for java.
- if use cd_java; then
- myconf="${myconf} --with-java=$(java-config -g JAVA_HOME)"
- fi
-
- # Finally, run econf.
- KERNEL_DIR="${KERNEL_DIR}" econf --config-cache --without-included-ltdl --localstatedir=/var ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- fixlocalpod
-
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- if use contrib ; then
- insinto /usr/share/doc/${PF}
- doins -r contrib || die
- fi
-
- keepdir /var/lib/${PN} || die
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
- newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
-}
-
-collectd_rdeps() {
- use cd_${1} \
- && elog "The ${1} plug-in needs ${2} to be installed localy or remotely to work."
-}
-
-pkg_postinst() {
- collectd_rdeps apcups sys-power/apcupsd
- collectd_rdeps hddtemp app-admin/hddtemp
- collectd_rdeps mbmon sys-apps/xmbmon
- collectd_rdeps memcached ">=net-misc/memcached-1.2.2-r2"
- collectd_rdeps ntpd net-misc/ntp
- collectd_rdeps openvpn ">=net-misc/openvpn-2.0.9"
-}
diff --git a/app-admin/collectd/files/collectd.confd b/app-admin/collectd/files/collectd.confd
deleted file mode 100644
index 1125174..0000000
--- a/app-admin/collectd/files/collectd.confd
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-# Nice value used to launch collectd, to change priority of the process. As
-# you usually will want to run it in background, a default of 5 is used.
-#
-#COLLECTD_NICELVL='5'
-
-# Location of configuration file. Modify if you don't like the standard one.
-#
-#COLLECTD_CFGFILE='/etc/collectd.conf'
-
-# File used to store the PID file. Usually you won't need to touch it.
-#
-#COLLECTD_PIDFILE='/var/run/collectd.pid'
diff --git a/app-admin/collectd/files/collectd.initd b/app-admin/collectd/files/collectd.initd
deleted file mode 100644
index 9291101..0000000
--- a/app-admin/collectd/files/collectd.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-: ${COLLECTD_PIDFILE:='/var/run/collectd.pid'}
-: ${COLLECTD_CFGFILE:='/etc/collectd.conf'}
-: ${COLLECTD_NICELVL:='5'}
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting collectd"
- start-stop-daemon --start --quiet \
- --nicelevel "${COLLECTD_NICELVL}" --exec /usr/sbin/collectd -- \
- -P "${COLLECTD_PIDFILE}" -C "${COLLECTD_CFGFILE}"
- eend $? "Failed to start collectd"
-}
-
-stop() {
- ebegin "Stopping collectd"
- start-stop-daemon --stop --quiet \
- --pidfile "${COLLECTD_PIDFILE}"
- eend $? "Failed to stop collectd"
-}