aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'bootdisk/s390x')
-rw-r--r--bootdisk/s390x/Makefile.am25
-rw-r--r--bootdisk/s390x/generic.ins5
-rw-r--r--bootdisk/s390x/generic.prm1
-rw-r--r--bootdisk/s390x/redhat.exec9
4 files changed, 40 insertions, 0 deletions
diff --git a/bootdisk/s390x/Makefile.am b/bootdisk/s390x/Makefile.am
new file mode 100644
index 0000000..c75ccbe
--- /dev/null
+++ b/bootdisk/s390x/Makefile.am
@@ -0,0 +1,25 @@
+# bootdisk/s390x/Makefile.am for anaconda
+#
+# Copyright (C) 2009 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Author: David Cantrell <dcantrell@redhat.com>
+
+if IS_S390
+bootdir = $(datadir)/$(PACKAGE_NAME)/boot
+dist_boot_DATA = generic.ins generic.prm redhat.exec
+endif
+
+MAINTAINERCLEANFILES = Makefile.in
diff --git a/bootdisk/s390x/generic.ins b/bootdisk/s390x/generic.ins
new file mode 100644
index 0000000..9f67e58
--- /dev/null
+++ b/bootdisk/s390x/generic.ins
@@ -0,0 +1,5 @@
+* minimal lpar ins file
+images/kernel.img 0x00000000
+images/initrd.img 0x02000000
+images/generic.prm 0x00010480
+images/initrd.size 0x00010410
diff --git a/bootdisk/s390x/generic.prm b/bootdisk/s390x/generic.prm
new file mode 100644
index 0000000..e953ce2
--- /dev/null
+++ b/bootdisk/s390x/generic.prm
@@ -0,0 +1 @@
+root=/dev/ram0 ro ip=off ramdisk_size=40000 cio_ignore=all,!0.0.0009
diff --git a/bootdisk/s390x/redhat.exec b/bootdisk/s390x/redhat.exec
new file mode 100644
index 0000000..f1e5931
--- /dev/null
+++ b/bootdisk/s390x/redhat.exec
@@ -0,0 +1,9 @@
+/* */
+'CL RDR'
+'PURGE RDR ALL'
+'SPOOL PUNCH * RDR'
+'PUNCH KERNEL IMG A (NOH'
+'PUNCH GENERIC PRM A (NOH'
+'PUNCH INITRD IMG A (NOH'
+'CH RDR ALL KEEP NOHOLD'
+'I 00C'