aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-07-01 12:01:30 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-07-18 10:05:06 -0400
commit209f4b9e33a79e648d46a53c05ea94f8c1676c5f (patch)
treea2d462595ae4f7bcf23b6af997e60bb18dafda0d /test/TEST-01-BASIC
parentbuild-sys: drop gitignore patterns for in-tree builds (diff)
downloadsystemd-209f4b9e33a79e648d46a53c05ea94f8c1676c5f.tar.gz
systemd-209f4b9e33a79e648d46a53c05ea94f8c1676c5f.tar.bz2
systemd-209f4b9e33a79e648d46a53c05ea94f8c1676c5f.zip
test: convert test/ to use meson install
Automatic rebuilding is removed: it doesn't play well with ninja, because ninja always writes logs, and even if nothing needs to be built, it will make the log file owned by root. So let's just remove this, and say that the user must always do the build first. I'm also keeping make for the tests, because ninja doesn't play well with sudo. Since the build directory is arbitrary, it needs to be specified, e.g. sudo make BUILD_DIR=/home/zbyszek/src/systemd/build1 -C test/TEST-01-BASIC/
Diffstat (limited to 'test/TEST-01-BASIC')
-rw-r--r--test/TEST-01-BASIC/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/test/TEST-01-BASIC/Makefile b/test/TEST-01-BASIC/Makefile
index 5e89a29ef..c29fd0676 100644
--- a/test/TEST-01-BASIC/Makefile
+++ b/test/TEST-01-BASIC/Makefile
@@ -1,10 +1,2 @@
-all:
- @make -s --no-print-directory -C ../.. all
- @basedir=../.. TEST_BASE_DIR=../ ./test.sh --all
-setup:
- @make --no-print-directory -C ../.. all
- @basedir=../.. TEST_BASE_DIR=../ ./test.sh --setup
-clean:
- @basedir=../.. TEST_BASE_DIR=../ ./test.sh --clean
-run:
- @basedir=../.. TEST_BASE_DIR=../ ./test.sh --run
+all setup clean run:
+ @basedir=../.. TEST_BASE_DIR=../ ./test.sh --$@