aboutsummaryrefslogtreecommitdiff
path: root/nptl
diff options
context:
space:
mode:
authorAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-11-13 11:05:02 -0300
committerAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-12-19 16:11:09 -0300
commitb633cdff2cd7259baea4d115cce0a818542f6f98 (patch)
treede27ee4f67fd524afcc2eab914630104b5a2f6ca /nptl
parentnptl: Move wait implementation to libc (diff)
downloadglibc-b633cdff2cd7259baea4d115cce0a818542f6f98.tar.gz
glibc-b633cdff2cd7259baea4d115cce0a818542f6f98.tar.bz2
glibc-b633cdff2cd7259baea4d115cce0a818542f6f98.zip
nptl: Move waitpid implementation to libc
Checked on x86_64-linux-gnu and powerpc64le-linux-gnu.
Diffstat (limited to 'nptl')
-rw-r--r--nptl/Makefile3
-rw-r--r--nptl/Versions2
2 files changed, 2 insertions, 3 deletions
diff --git a/nptl/Makefile b/nptl/Makefile
index 721030cd30..4a57213ddb 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -47,7 +47,7 @@ pthread-compat-wrappers = \
sendto fsync lseek lseek64 \
msync open open64 pause \
pread pread64 pwrite pwrite64 \
- tcdrain waitpid msgrcv msgsnd \
+ tcdrain msgrcv msgsnd \
sigwait sigsuspend \
recvmsg sendmsg
@@ -206,7 +206,6 @@ CFLAGS-pread.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pread64.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pwrite.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pwrite64.c += -fexceptions -fasynchronous-unwind-tables
-CFLAGS-waitpid.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-sigwait.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-msgrcv.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-msgsnd.c += -fexceptions -fasynchronous-unwind-tables
diff --git a/nptl/Versions b/nptl/Versions
index 1dda4b9064..ff6fc06002 100644
--- a/nptl/Versions
+++ b/nptl/Versions
@@ -99,7 +99,7 @@ libpthread {
close; __close; fcntl; __fcntl; read; __read; write; __write; accept;
connect; __connect; recv; recvfrom; recvmsg; send; __send; sendmsg; sendto;
fsync; lseek; __lseek; msync; open; __open; pause; tcdrain;
- system; waitpid;
+ system;
# Hidden entry point (through macros).
_pthread_cleanup_push; _pthread_cleanup_pop;