aboutsummaryrefslogtreecommitdiff
path: root/nptl
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2020-02-10 11:17:11 +0100
committerFlorian Weimer <fweimer@redhat.com>2020-02-20 08:57:01 +0100
commit8923b9962c817096eb0afd7c2e9cf5e9e758f057 (patch)
tree3b71027e16fbecc463134aa919b1e9673f6fb8fe /nptl
parentnptl: Use .NOTPARALLEL in Makefile only if actually running tests (diff)
downloadglibc-8923b9962c817096eb0afd7c2e9cf5e9e758f057.tar.gz
glibc-8923b9962c817096eb0afd7c2e9cf5e9e758f057.tar.bz2
glibc-8923b9962c817096eb0afd7c2e9cf5e9e758f057.zip
nptl: Sort routines list in Makefile alphabetically
This will make it easier to review changes which move implementations from libpthread to libc. Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Diffstat (limited to 'nptl')
-rw-r--r--nptl/Makefile28
1 files changed, 21 insertions, 7 deletions
diff --git a/nptl/Makefile b/nptl/Makefile
index e4250fd522..e5f848bdba 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -28,13 +28,27 @@ headers := pthread.h semaphore.h bits/semaphore.h \
extra-libs := libpthread
extra-libs-others := $(extra-libs)
-routines = alloca_cutoff forward libc-lowlevellock libc-cancellation \
- libc-cleanup libc_pthread_init libc_multiple_threads \
- register-atfork pthread_atfork pthread_self pthread_equal \
- pthread_attr_destroy pthread_attr_init pthread_attr_getdetachstate \
- pthread_attr_setdetachstate pthread_attr_getinheritsched \
- pthread_attr_setinheritsched pthread_attr_getschedparam \
- pthread_attr_setschedparam
+routines = \
+ alloca_cutoff \
+ forward \
+ libc-cancellation \
+ libc-cleanup \
+ libc-lowlevellock \
+ libc_multiple_threads \
+ libc_pthread_init \
+ pthread_atfork \
+ pthread_attr_destroy \
+ pthread_attr_getdetachstate \
+ pthread_attr_getinheritsched \
+ pthread_attr_getschedparam \
+ pthread_attr_init \
+ pthread_attr_setdetachstate \
+ pthread_attr_setinheritsched \
+ pthread_attr_setschedparam \
+ pthread_equal \
+ pthread_self \
+ register-atfork \
+
shared-only-routines = forward
static-only-routines = pthread_atfork