aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@google.com>2012-10-24 02:32:15 +0000
committerCary Coutant <ccoutant@google.com>2012-10-24 02:32:15 +0000
commit35c813e2242319efee1bad5c7cdd6e7e224ce94e (patch)
tree47d7aa8f7132c1d2d5387fdaedfe27817c92d050 /gold/testsuite/dwp_test_1b.cc
parentgold/ (diff)
downloadbinutils-gdb-35c813e2242319efee1bad5c7cdd6e7e224ce94e.tar.gz
binutils-gdb-35c813e2242319efee1bad5c7cdd6e7e224ce94e.tar.bz2
binutils-gdb-35c813e2242319efee1bad5c7cdd6e7e224ce94e.zip
gold/
* testsuite/Makefile.am (TEST_OBJCOPY): New macro. * testsuite/Makefile.in: Regenerate. * testsuite/dwp_test.h: New source file. * testsuite/dwp_test_1.cc: New source file. * testsuite/dwp_test_1.s: New source file. * testsuite/dwp_test_1.sh: New source file. * testsuite/dwp_test_1b.cc: New source file. * testsuite/dwp_test_1b.s: New source file. * testsuite/dwp_test_2.cc: New source file. * testsuite/dwp_test_2.s: New source file. * testsuite/dwp_test_2.sh: New source file. * testsuite/dwp_test_main.cc: New source file. * testsuite/dwp_test_main.s: New source file.
Diffstat (limited to 'gold/testsuite/dwp_test_1b.cc')
-rw-r--r--gold/testsuite/dwp_test_1b.cc35
1 files changed, 35 insertions, 0 deletions
diff --git a/gold/testsuite/dwp_test_1b.cc b/gold/testsuite/dwp_test_1b.cc
new file mode 100644
index 00000000000..c75376b5b1a
--- /dev/null
+++ b/gold/testsuite/dwp_test_1b.cc
@@ -0,0 +1,35 @@
+// dwp_test_1b.cc -- a test case for dwp
+
+// Copyright 2012 Free Software Foundation, Inc.
+// Written by Cary Coutant <ccoutant@google.com>.
+
+// This file is part of gold.
+
+// This program is free software; you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation; either version 3 of the License, or
+// (at your option) any later version.
+
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+
+// You should have received a copy of the GNU General Public License
+// along with this program; if not, write to the Free Software
+// Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston,
+// MA 02110-1301, USA.
+
+// Adapted from two_file_test_1b.cc.
+
+#include "dwp_test.h"
+
+// 16 Call a function directly after its address has been taken.
+
+C3 c3;
+
+bool
+t16a()
+{
+ return f10() == 135;
+}