aboutsummaryrefslogtreecommitdiff
path: root/bfd/som.c
diff options
context:
space:
mode:
authornobody <>1999-06-02 12:39:45 +0000
committernobody <>1999-06-02 12:39:45 +0000
commit94a3815c4d8518a470dd038d15d33e699ad30e2f (patch)
tree0d6858f8514ff609603051f8fc682ef5b153e207 /bfd/som.c
parent19990502 sourceware import (diff)
downloadbinutils-gdb-binu_ss_19990602.tar.gz
binutils-gdb-binu_ss_19990602.tar.bz2
binutils-gdb-binu_ss_19990602.zip
This commit was manufactured by cvs2svn to create tag 'binu_ss_19990602'.binu_ss_19990602
Sprout from cygnus 1999-05-03 07:29:11 UTC Richard Henderson <rth@redhat.com> '19990502 sourceware import' Cherrypick from master 1999-06-02 12:39:44 UTC Richard Henderson <rth@redhat.com> '* hosts/alphalinux.h (TRAD_CORE_EXTRA_SIZE_ALLOWED): Expand to 4096.': ChangeLog bfd/ChangeLog bfd/Makefile.am bfd/Makefile.in bfd/aclocal.m4 bfd/archive.c bfd/bfd-in.h bfd/bfd-in2.h bfd/coff-arm.c bfd/coff-mcore.c bfd/coffcode.h bfd/coffgen.c bfd/coffswap.h bfd/config.bfd bfd/config.in bfd/configure bfd/configure.host bfd/configure.in bfd/dwarf2.c bfd/ecoff.c bfd/elf-bfd.h bfd/elf.c bfd/elf32-arm.h bfd/elf32-i960.c bfd/elf32-m68k.c bfd/elf32-mcore.c bfd/elf32-mips.c bfd/elf32-v850.c bfd/elf64-mips.c bfd/elfarm-nabi.c bfd/elfarm-oabi.c bfd/elfxx-target.h bfd/hosts/alphalinux.h bfd/libbfd-in.h bfd/libbfd.h bfd/peicode.h bfd/reloc.c bfd/som.c bfd/targets.c bfd/vms-misc.c binutils/ChangeLog binutils/Makefile.am binutils/Makefile.in binutils/NEWS binutils/binutils.texi binutils/configure binutils/configure.in binutils/dlltool.c binutils/objcopy.c binutils/objdump.c binutils/rclex.l binutils/rcparse.y binutils/readelf.c binutils/rename.c binutils/rescoff.c binutils/resrc.c binutils/testsuite/ChangeLog binutils/testsuite/binutils-all/readelf.h binutils/windres.c binutils/windres.h config.guess config.sub gas/ChangeLog gas/Makefile.am gas/Makefile.in gas/NEWS gas/aclocal.m4 gas/atof-generic.c gas/config/atof-ieee.c gas/config/m68k-parse.h gas/config/obj-coff.c gas/config/obj-elf.c gas/config/tc-arm.c gas/config/tc-hppa.c gas/config/tc-i386.c gas/config/tc-i386.h gas/config/tc-i960.c gas/config/tc-i960.h gas/config/tc-m68k.c gas/config/tc-m68k.h gas/config/tc-mcore.c gas/config/tc-mips.c gas/config/tc-ppc.c gas/configure gas/configure.in gas/doc/internals.texi gas/ecoff.c gas/expr.c gas/hash.h gas/listing.c gas/read.c gas/symbols.c gas/testsuite/ChangeLog gas/testsuite/gas/i386/amd.d gas/testsuite/gas/i386/amd.s gas/testsuite/gas/i386/i386.exp gas/testsuite/gas/i386/katmai.d gas/testsuite/gas/i386/katmai.s gas/testsuite/gas/i386/opcode.d gas/testsuite/gas/i386/prefix.d gas/testsuite/gas/i386/prefix.s gas/testsuite/gas/i386/reloc.d gas/testsuite/gas/i386/reloc.s gas/testsuite/gas/mcore/allinsn.d gas/testsuite/gas/vtable/vtable.exp gas/write.c include/coff/ChangeLog include/coff/arm.h include/coff/mcore.h include/elf/ChangeLog include/elf/common.h include/elf/i960.h include/elf/m68k.h include/elf/mcore.h include/elf/reloc-macros.h include/opcode/ChangeLog include/opcode/hppa.h include/opcode/i386.h include/opcode/m68k.h include/opcode/ppc.h ld/ChangeLog ld/Makefile.am ld/Makefile.in ld/configure.tgt ld/emulparams/armelf.sh ld/emulparams/armelf_linux.sh ld/emulparams/armelf_oabi.sh ld/emulparams/elf32_i960.sh ld/emulparams/elf32mcore.sh ld/emulparams/elf32ppclinux.sh ld/emulparams/mcorepe.sh ld/emultempl/armcoff.em ld/emultempl/armelf.em ld/emultempl/armelf_oabi.em ld/emultempl/pe.em ld/ld.texinfo ld/ldlang.c ld/lexsup.c ld/pe-dll.c ld/scripttempl/mcorepe.sc ld/scripttempl/pe.sc ld/testsuite/ChangeLog ld/testsuite/ld-srec/srec.exp ld/testsuite/ld-undefined/undefined.exp libiberty/ChangeLog libiberty/configure libiberty/configure.in libiberty/cplus-dem.c libiberty/getruntime.c opcodes/ChangeLog opcodes/i386-dis.c opcodes/m68k-dis.c opcodes/m68k-opc.c opcodes/mcore-dis.c opcodes/mcore-opc.h
Diffstat (limited to 'bfd/som.c')
-rw-r--r--bfd/som.c5
1 files changed, 2 insertions, 3 deletions
diff --git a/bfd/som.c b/bfd/som.c
index b5786b51ed7..ee1fac09205 100644
--- a/bfd/som.c
+++ b/bfd/som.c
@@ -440,9 +440,7 @@ static const struct fixup_format som_fixup_formats[256] =
1, "Lb4*=Mb1+L*=", /* 0x2b */
2, "Lb4*=Md1+4*=", /* 0x2c */
3, "Ld1+=Me1+=", /* 0x2d */
- /* R_SHORT_PCREL_MODE */
0, "", /* 0x2e */
- /* R_LONG_PCREL_MODE */
0, "", /* 0x2f */
/* R_PCREL_CALL */
0, "L4=RD=Sb=", /* 0x30 */
@@ -459,8 +457,9 @@ static const struct fixup_format som_fixup_formats[256] =
1, "L4=RD8<b+=Sb=",/* 0x3b */
0, "L4=RD8<b+=Sd=",/* 0x3c */
1, "L4=RD8<b+=Sd=",/* 0x3d */
- /* R_RESERVED */
+ /* R_SHORT_PCREL_MODE */
0, "", /* 0x3e */
+ /* R_LONG_PCREL_MODE */
0, "", /* 0x3f */
/* R_ABS_CALL */
0, "L4=RD=Sb=", /* 0x40 */