aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTulio Magno Quites Machado Filho <tuliom@linux.ibm.com>2018-05-02 19:18:44 -0300
committerAlan Modra <amodra@gmail.com>2018-05-04 18:58:03 +0930
commita27ca19c95ad3ebc5bd73f072facdd71b5a976ad (patch)
tree1de9b54cfe41a521f86e67e96ce2e7f6755842dc /bfd/elf32-ppc.c
parentFix typo in Makefile.am to make it agree with Makefile.in. (diff)
downloadbinutils-gdb-a27ca19c95ad3ebc5bd73f072facdd71b5a976ad.tar.gz
binutils-gdb-a27ca19c95ad3ebc5bd73f072facdd71b5a976ad.tar.bz2
binutils-gdb-a27ca19c95ad3ebc5bd73f072facdd71b5a976ad.zip
ppc: Fix warning messages when IBM and IEEE long double are mixed
When IBM long double is used, the .gnu_attribute 4 is set to 1 | (1 * 4). IEEE long double sets the same .gnu_attribute to 1 | (3 * 4). * elf32-ppc.c (_bfd_elf_ppc_merge_fp_attributes): Fix the order of arguments when warning about different long double types.
Diffstat (limited to 'bfd/elf32-ppc.c')
-rw-r--r--bfd/elf32-ppc.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/bfd/elf32-ppc.c b/bfd/elf32-ppc.c
index 1200de84582..7f4ed01f20a 100644
--- a/bfd/elf32-ppc.c
+++ b/bfd/elf32-ppc.c
@@ -4776,12 +4776,12 @@ _bfd_elf_ppc_merge_fp_attributes (bfd *ibfd, struct bfd_link_info *info)
_bfd_error_handler
/* xgettext:c-format */
(_("warning: %pB uses IBM long double, "
- "%pB uses IEEE long double"), ibfd, obfd);
+ "%pB uses IEEE long double"), obfd, ibfd);
else if (out_fp == 3 * 4 && in_fp == 1 * 4)
_bfd_error_handler
/* xgettext:c-format */
(_("warning: %pB uses IBM long double, "
- "%pB uses IEEE long double"), obfd, ibfd);
+ "%pB uses IEEE long double"), ibfd, obfd);
}
}