summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-03-22 20:48:14 +0800
committerBen de Groot <yngwin@gentoo.org>2015-03-22 20:48:14 +0800
commit4d85a3ebb47016cd2702f81aa6538c11e8e16f0d (patch)
treeb6504bb74968d72d1ea67d42fae50f29315473ed
parentcleanup now that neovim and deps are in the official tree (diff)
downloadyngwin-4d85a3ebb47016cd2702f81aa6538c11e8e16f0d.tar.gz
yngwin-4d85a3ebb47016cd2702f81aa6538c11e8e16f0d.tar.bz2
yngwin-4d85a3ebb47016cd2702f81aa6538c11e8e16f0d.zip
Update neovim with new dep and proper options to turn off static deps
-rw-r--r--app-editors/neovim/neovim-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 17723f0..cce4e62 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -22,6 +22,7 @@ IUSE="perl python"
CDEPEND="dev-lang/luajit:2
>=dev-libs/libtermkey-0.17
+ dev-libs/libvterm-neovim
>=dev-libs/unibilium-1.1.1
>=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-0.6.0_pre20150220
@@ -35,9 +36,6 @@ RDEPEND="${CDEPEND}
python? ( dev-python/neovim-python-client )"
src_prepare() {
- # do not link statically
- sed -e '/^set(LIBUNIBILIUM/s|ON|OFF|' -e '/^set(LIBTERMKEY/s|ON|OFF|' \
- -i CMakeLists.txt
# use our system vim dir
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
-i src/nvim/os_unix_defs.h || die
@@ -48,7 +46,12 @@ src_configure() {
export USE_BUNDLED_DEPS=OFF
append-cflags "-Wno-error"
append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
- local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DLIBUNIBILIUM_USE_STATIC=OFF
+ -DLIBTERMKEY_USE_STATIC=OFF
+ -DLIBVTERM_USE_STATIC=OFF
+ )
cmake-utils_src_configure
}