summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bacula/files')
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-dir.confd17
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-dir.initd25
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-fd.confd8
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-fd.initd22
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-sd.confd11
-rw-r--r--app-backup/bacula/files/5.0.0/bacula-sd.initd22
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-5.0.1-as-needed.patch33
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-5.0.1-ncurses.patch39
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-dir.confd17
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-dir.initd25
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-fd.confd8
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-fd.initd22
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-sd.confd11
-rw-r--r--app-backup/bacula/files/5.0.1/bacula-sd.initd22
14 files changed, 282 insertions, 0 deletions
diff --git a/app-backup/bacula/files/5.0.0/bacula-dir.confd b/app-backup/bacula/files/5.0.0/bacula-dir.confd
new file mode 100644
index 0000000..d24a66c
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-dir.confd
@@ -0,0 +1,17 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-dir
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+# Setting it to 1 makes bacula-dir depend on the corresponding
+# database service selected at package compile time.
+LOCAL_DB=1
+
+# Options for the director daemon.
+# The director can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/5.0.0/bacula-dir.initd b/app-backup/bacula/files/5.0.0/bacula-dir.initd
new file mode 100644
index 0000000..bef5003
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-dir.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ if [ "${LOCAL_DB}" -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns bacula-fd bacula-sd
+}
+
+start() {
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/5.0.0/bacula-fd.confd b/app-backup/bacula/files/5.0.0/bacula-fd.confd
new file mode 100644
index 0000000..7541946
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-fd.confd
@@ -0,0 +1,8 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file daemon.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/app-backup/bacula/files/5.0.0/bacula-fd.initd b/app-backup/bacula/files/5.0.0/bacula-fd.initd
new file mode 100644
index 0000000..7b158bc
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-fd.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/5.0.0/bacula-sd.confd b/app-backup/bacula/files/5.0.0/bacula-sd.confd
new file mode 100644
index 0000000..754de76
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-sd.confd
@@ -0,0 +1,11 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The storage daemon can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/app-backup/bacula/files/5.0.0/bacula-sd.initd b/app-backup/bacula/files/5.0.0/bacula-sd.initd
new file mode 100644
index 0000000..e303b57
--- /dev/null
+++ b/app-backup/bacula/files/5.0.0/bacula-sd.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/5.0.1/bacula-5.0.1-as-needed.patch b/app-backup/bacula/files/5.0.1/bacula-5.0.1-as-needed.patch
new file mode 100644
index 0000000..7ad3613
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-5.0.1-as-needed.patch
@@ -0,0 +1,33 @@
+diff -urN bacula-5.0.1.orig/src/findlib/Makefile.in bacula-5.0.1/src/findlib/Makefile.in
+--- bacula-5.0.1.orig/src/findlib/Makefile.in 2010-02-24 16:33:48.000000000 +0100
++++ bacula-5.0.1/src/findlib/Makefile.in 2010-03-22 17:37:43.772805754 +0100
+@@ -59,7 +59,7 @@
+
+ libbacfind.la: Makefile $(LIBBACFIND_LOBJS)
+ @echo "Making $@ ..."
+- $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBACFIND_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBACFIND_LT_CURRENT).$(LIBBACFIND_LT_REVISION).$(LIBBACFIND_LT_AGE)
++ $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBACFIND_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBACFIND_LT_CURRENT).$(LIBBACFIND_LT_REVISION).$(LIBBACFIND_LT_AGE) -L../lib -lbac $(LIBS) $(OPENSSL_LIBS)
+
+ Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
+ cd $(topdir) \
+diff -urN bacula-5.0.1.orig/src/lib/Makefile.in bacula-5.0.1/src/lib/Makefile.in
+--- bacula-5.0.1.orig/src/lib/Makefile.in 2010-02-24 16:33:48.000000000 +0100
++++ bacula-5.0.1/src/lib/Makefile.in 2010-03-22 17:37:05.352226188 +0100
+@@ -126,7 +126,7 @@
+
+ libbac.la: Makefile $(LIBBAC_LOBJS)
+ @echo "Making $@ ..."
+- $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBAC_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBAC_LT_CURRENT).$(LIBBAC_LT_REVISION).$(LIBBAC_LT_AGE) $(WRAPLIBS) $(CAP_LIBS)
++ $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBAC_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBAC_LT_CURRENT).$(LIBBAC_LT_REVISION).$(LIBBAC_LT_AGE) $(WRAPLIBS) $(CAP_LIBS) $(LIBS) $(OPENSSL_LIBS)
+
+ libbaccfg.a: $(LIBBACCFG_OBJS)
+ @echo "Making $@ ..."
+@@ -135,7 +135,7 @@
+
+ libbaccfg.la: Makefile $(LIBBACCFG_LOBJS)
+ @echo "Making $@ ..."
+- $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBACCFG_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBACCFG_LT_CURRENT).$(LIBBACCFG_LT_REVISION).$(LIBBACCFG_LT_AGE)
++ $(LIBTOOL_LINK) $(CXX) $(DEFS) $(DEBUG) $(LDFLAGS) -o $@ $(LIBBACCFG_LOBJS) -export-dynamic -rpath $(libdir) -release $(LIBBACCFG_LT_CURRENT).$(LIBBACCFG_LT_REVISION).$(LIBBACCFG_LT_AGE) $(LIBS) $(OPENSSL_LIBS)
+
+ libbacpy.a: $(LIBBACPY_OBJS)
+ @echo "Making $@ ..."
diff --git a/app-backup/bacula/files/5.0.1/bacula-5.0.1-ncurses.patch b/app-backup/bacula/files/5.0.1/bacula-5.0.1-ncurses.patch
new file mode 100644
index 0000000..6608e0e
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-5.0.1-ncurses.patch
@@ -0,0 +1,39 @@
+diff -urN bacula-5.0.1.orig/autoconf/configure.in bacula-5.0.1/autoconf/configure.in
+--- bacula-5.0.1.orig/autoconf/configure.in 2010-02-24 16:33:48.000000000 +0100
++++ bacula-5.0.1/autoconf/configure.in 2010-03-22 16:51:57.282119344 +0100
+@@ -823,7 +823,7 @@
+ if test x$support_conio = xyes; then
+ AC_CHECK_HEADER(termcap.h,
+ [ AC_CHECK_LIB(termcap, tgetent,
+- [ CONS_LIBS="-ltermcap"
++ [ CONS_LIBS="-lncurses"
+ CONS_OBJ="conio.o"
+ CONS_SRC="conio.c"
+ got_conio="yes"
+@@ -899,7 +899,7 @@
+ AC_CHECK_HEADER(${with_readline}/readline.h,
+ [
+ AC_DEFINE(HAVE_READLINE, 1, [Set to enable readline support])
+- CONS_LIBS="-lreadline -lhistory -ltermcap"
++ CONS_LIBS="-lreadline -lhistory -lncurses"
+ got_readline="yes"
+ ], [
+ echo " "
+@@ -916,7 +916,7 @@
+ AC_DEFINE(HAVE_READLINE, 1, [Set to enable readline support])
+ got_readline="yes"
+ CONS_INC="-I/usr/include/readline"
+- CONS_LIBS="-lreadline -ltermcap"
++ CONS_LIBS="-lreadline -lncurses"
+ ], [
+ dnl Did not find standard library, so try Bacula's default
+ AC_CHECK_HEADER(${TOP_DIR}/depkgs/readline/readline.h,
+@@ -924,7 +924,7 @@
+ AC_DEFINE(HAVE_READLINE, 1, [Set to enable readline support])
+ got_readline="yes"
+ CONS_INC="-I${TOP_DIR}/depkgs/readline"
+- CONS_LIBS="-lreadline -lhistory -ltermcap"
++ CONS_LIBS="-lreadline -lhistory -lncurses"
+ CONS_LDFLAGS="-L${TOP_DIR}/depkgs/readline"
+ PRTREADLINE_SRC="${TOP_DIR}/depkgs/readline"
+ ], [
diff --git a/app-backup/bacula/files/5.0.1/bacula-dir.confd b/app-backup/bacula/files/5.0.1/bacula-dir.confd
new file mode 100644
index 0000000..d24a66c
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-dir.confd
@@ -0,0 +1,17 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-dir
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+# Setting it to 1 makes bacula-dir depend on the corresponding
+# database service selected at package compile time.
+LOCAL_DB=1
+
+# Options for the director daemon.
+# The director can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/5.0.1/bacula-dir.initd b/app-backup/bacula/files/5.0.1/bacula-dir.initd
new file mode 100644
index 0000000..bef5003
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-dir.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ if [ "${LOCAL_DB}" -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns bacula-fd bacula-sd
+}
+
+start() {
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/5.0.1/bacula-fd.confd b/app-backup/bacula/files/5.0.1/bacula-fd.confd
new file mode 100644
index 0000000..7541946
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-fd.confd
@@ -0,0 +1,8 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file daemon.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/app-backup/bacula/files/5.0.1/bacula-fd.initd b/app-backup/bacula/files/5.0.1/bacula-fd.initd
new file mode 100644
index 0000000..7b158bc
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-fd.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/5.0.1/bacula-sd.confd b/app-backup/bacula/files/5.0.1/bacula-sd.confd
new file mode 100644
index 0000000..754de76
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-sd.confd
@@ -0,0 +1,11 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The storage daemon can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/app-backup/bacula/files/5.0.1/bacula-sd.initd b/app-backup/bacula/files/5.0.1/bacula-sd.initd
new file mode 100644
index 0000000..e303b57
--- /dev/null
+++ b/app-backup/bacula/files/5.0.1/bacula-sd.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ eend $?
+}