summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/skyldav/files')
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3-conf.patch20
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3-examples.patch12
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3-openlog.patch12
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3-sbin.patch19
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130816-syslog.patch24
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130817-disable-skyldavnotify.patch362
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130821-examples.patch11
-rw-r--r--app-antivirus/skyldav/files/skyldav.confd11
-rwxr-xr-xapp-antivirus/skyldav/files/skyldav.initd26
9 files changed, 497 insertions, 0 deletions
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3-conf.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3-conf.patch
new file mode 100644
index 0000000..3485bb4
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3-conf.patch
@@ -0,0 +1,20 @@
+diff -urN skyldav-0.2rc3.orig/examples/etc/skyldav.conf skyldav-0.2rc3/examples/etc/skyldav.conf
+--- skyldav-0.2rc3.orig/examples/etc/skyldav.conf 2013-07-20 14:36:43.000000000 +0200
++++ skyldav-0.2rc3/examples/etc/skyldav.conf 2013-08-17 11:41:17.016278000 +0200
+@@ -19,14 +19,14 @@
+
+ # File systems that shall not be marked for virus scan.
+ # NOMARK_FS = proc, sysfs
+-NOMARK_FS = proc, sysfs
++NOMARK_FS = proc, sysfs, devtmpfs, devpts, configfs, securityfs, cgroup, rpc_pipefs
+
+ # Mounts that shall not be marked for virus scan.
+ # NOMARK_MNT = /mnt/noscan
+
+ # File systems that are local, virus scan results may be cached.
+ # LOCAL_FS = ext3, ext4, iso9660, tmpfs, vfat
+-LOCAL_FS = ext3, ext4, iso9660, tmpfs, vfat
++LOCAL_FS = ext2, ext3, ext4, xfs, zfs, btrfs, reiserfs, vfat, ntfs, iso9660, tmpfs
+
+ # Number of threads for file scanning,
+ # defaults to the number of available CPUs.
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3-examples.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3-examples.patch
new file mode 100644
index 0000000..d331dd3
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3-examples.patch
@@ -0,0 +1,12 @@
+diff -urN skyldav-0.2rc3.orig/Makefile.am skyldav-0.2rc3/Makefile.am
+--- skyldav-0.2rc3.orig/Makefile.am 2013-07-20 14:36:43.000000000 +0200
++++ skyldav-0.2rc3/Makefile.am 2013-08-16 22:16:35.255347000 +0200
+@@ -9,8 +9,6 @@
+ rm -rf doc/doxygen
+
+ install-data-local:
+- mkdir -p $(DESTDIR)$(docdir)/examples/
+- cp -rf $(srcdir)/examples/* $(DESTDIR)$(docdir)/examples/
+ mkdir -p $(DESTDIR)$(sysconfdir)
+ test -e $(DESTDIR)$(sysconfdir)/skyldav.conf || \
+ cp examples/etc/skyldav.conf $(DESTDIR)$(sysconfdir)
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3-openlog.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3-openlog.patch
new file mode 100644
index 0000000..bd790ec
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3-openlog.patch
@@ -0,0 +1,12 @@
+diff -urN skyldav-0.2rc3.orig/src/skyldav/Messaging.cc skyldav-0.2rc3/src/skyldav/Messaging.cc
+--- skyldav-0.2rc3.orig/src/skyldav/Messaging.cc 2013-07-20 14:36:43.000000000 +0200
++++ skyldav-0.2rc3/src/skyldav/Messaging.cc 2013-08-16 16:42:56.319762000 +0200
+@@ -47,7 +47,7 @@
+
+ // Open syslog.
+ setlogmask(LOG_UPTO(LOG_NOTICE));
+- openlog("Skyld AV", 0, LOG_USER);
++ openlog("skyldav", LOG_PID, LOG_DAEMON);
+
+ // Set umask = 022;
+ mask = umask(S_IWGRP | S_IWOTH);
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3-sbin.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3-sbin.patch
new file mode 100644
index 0000000..e984252
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3-sbin.patch
@@ -0,0 +1,19 @@
+diff -urN skyldav-0.2rc3.orig/src/skyldav/Makefile.am skyldav-0.2rc3/src/skyldav/Makefile.am
+--- skyldav-0.2rc3.orig/src/skyldav/Makefile.am 2013-07-20 14:36:43.000000000 +0200
++++ skyldav-0.2rc3/src/skyldav/Makefile.am 2013-08-16 11:17:41.489230000 +0200
+@@ -32,7 +32,7 @@
+ ThreadPool.cc \
+ VirusScan.cc
+
+-bin_PROGRAMS = \
++sbin_PROGRAMS = \
+ skyldav
+
+ skyldav_LDFLAGS = \
+@@ -41,4 +41,4 @@
+ skyldav_SOURCES = skyldav.h main.cc
+
+ check:
+- ./skyldav --version
+\ No newline at end of file
++ ./skyldav --version
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130816-syslog.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130816-syslog.patch
new file mode 100644
index 0000000..d746747
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130816-syslog.patch
@@ -0,0 +1,24 @@
+diff -urN skyldav-0.2rc3_p20130816.orig/src/skyldav/Messaging.cc skyldav-0.2rc3_p20130816/src/skyldav/Messaging.cc
+--- skyldav-0.2rc3_p20130816.orig/src/skyldav/Messaging.cc 2013-08-16 19:58:10.000000000 +0200
++++ skyldav-0.2rc3_p20130816/src/skyldav/Messaging.cc 2013-08-16 22:07:37.743908000 +0200
+@@ -48,7 +48,7 @@
+
+ // Open syslog.
+ setlogmask(LOG_UPTO(LOG_NOTICE));
+- openlog(SYSLOG_ID , 0, LOG_USER);
++ openlog(SYSLOG_ID , LOG_PID, LOG_USER);
+
+ // Set umask = 022;
+ mask = umask(S_IWGRP | S_IWOTH);
+diff -urN skyldav-0.2rc3_p20130816.orig/src/skyldav/skyldav.h skyldav-0.2rc3_p20130816/src/skyldav/skyldav.h
+--- skyldav-0.2rc3_p20130816.orig/src/skyldav/skyldav.h 2013-08-16 19:58:10.000000000 +0200
++++ skyldav-0.2rc3_p20130816/src/skyldav/skyldav.h 2013-08-16 22:07:10.715968000 +0200
+@@ -63,7 +63,7 @@
+
+ const char *PID_FILE = "/var/run/skyldav/skyldav.pid";
+
+- const char *SYSLOG_ID = "SkyldAV";
++ const char *SYSLOG_ID = "skyldav";
+
+ #ifdef __cplusplus
+ }
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130817-disable-skyldavnotify.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130817-disable-skyldavnotify.patch
new file mode 100644
index 0000000..9f4a547
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130817-disable-skyldavnotify.patch
@@ -0,0 +1,362 @@
+diff -urN skyldav-0.2rc3_p20130817.orig/configure.ac skyldav-0.2rc3_p20130817/configure.ac
+--- skyldav-0.2rc3_p20130817.orig/configure.ac 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/configure.ac 2013-08-17 13:20:37.887072000 +0200
+@@ -51,10 +51,6 @@
+ dnl set linker flags
+ LDFLAGS="-g $LDFLAGS"
+
+-PKG_CHECK_MODULES([NOTIFY], [gtk+-2.0 >= 2.20.1 libnotify >= 0.5.0])
+-AC_CHECK_HEADER([canberra.h], [],
+- [AC_MSG_ERROR([canberra.h header not found])])
+-NOTIFY_LIBS="-lcanberra $NOTIFY_LIBS"
+ AC_CHECK_HEADER([libmount/libmount.h], [],
+ [AC_MSG_ERROR([libmount/libmount.h header not found])])
+ AC_CHECK_HEADER([sys/capability.h], [],
+@@ -73,7 +69,6 @@
+
+ AC_MSG_NOTICE([CPPFLAGS = $CPPFLAGS])
+ AC_MSG_NOTICE([LDFLAGS = $LDFLAGS])
+-AC_MSG_NOTICE([NOTIFY_LIBS = $NOTIFY_LIBS])
+ AC_MSG_NOTICE([SKYLDAV_LIBS = $SKYLDAV_LIBS])
+
+ dnl Check includes
+@@ -90,7 +85,6 @@
+ Makefile
+ man/Makefile
+ src/Makefile
+- src/notify/Makefile
+ src/skyldav/Makefile
+ test/Makefile
+ ])
+diff -urN skyldav-0.2rc3_p20130817.orig/Makefile.am skyldav-0.2rc3_p20130817/Makefile.am
+--- skyldav-0.2rc3_p20130817.orig/Makefile.am 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/Makefile.am 2013-08-17 13:21:30.566228000 +0200
+@@ -14,10 +14,6 @@
+ mkdir -p $(DESTDIR)$(sysconfdir)
+ test -e $(DESTDIR)$(sysconfdir)/skyldav.conf || \
+ cp examples/etc/skyldav.conf $(DESTDIR)$(sysconfdir)
+- mkdir -p $(DESTDIR)$(datadir)/autostart/
+- test -e $(DESTDIR)$(datadir)/autostart/skyldavnotify.desktop || \
+- cp examples/usr/share/autostart/skyldavnotify.desktop \
+- $(DESTDIR)$(datadir)/autostart/
+
+ dist-hook:
+ rm -rf $(distdir)/doc/doxygen
+diff -urN skyldav-0.2rc3_p20130817.orig/man/Makefile.am skyldav-0.2rc3_p20130817/man/Makefile.am
+--- skyldav-0.2rc3_p20130817.orig/man/Makefile.am 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/man/Makefile.am 2013-08-17 13:22:04.636393000 +0200
+@@ -1,6 +1,6 @@
+ SECONDARY:
+-dist_man_MANS = skyldav.1 skyldavnotify.1
++dist_man_MANS = skyldav.1
+
+ EXTRA_DIST = \
+-skyldav.1 skyldavnotify.1
++skyldav.1
+
+diff -urN skyldav-0.2rc3_p20130817.orig/man/skyldavnotify.1 skyldav-0.2rc3_p20130817/man/skyldavnotify.1
+--- skyldav-0.2rc3_p20130817.orig/man/skyldavnotify.1 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/man/skyldavnotify.1 1970-01-01 01:00:00.000000000 +0100
+@@ -1,28 +0,0 @@
+-.TH SKYLDAVNOTIFY 1 "June 23th, 2013" "version 0.1" "Skyld AV notification"
+-.SH NAME
+-skyldavnotify \- Desktop notification for Skyld AV
+-.SH SYNOPSIS
+-.B skyldavnotify
+-.RB [ \-h ]
+-.RB [ \-v ]
+-.SH DESCRIPTION
+-.PP
+-This program notifies the user of a windows manager like KDE or GNOME if
+-Skyld AV detected malware. Typical usage is to start this file using a
+-desktop link
+-.IR /usr/share/autostart/skyldavnotify.desktop .
+-.PP
+-.TP
+-.B \-h
+-Print usage information.
+-.TP
+-.B \-v
+-Print the program version and licensing information.
+-.SH AUTHOR
+-Heinrich Schuchardt <xypron.glpk@gmx.de>
+-.SH SEE ALSO
+-.BR sykldav (1)
+-.PP
+-Further documentation and examples can be found in the documentation
+-path, which defaults to
+-.IR /usr/local/share/doc/skyldav .
+diff -urN skyldav-0.2rc3_p20130817.orig/src/Makefile.am skyldav-0.2rc3_p20130817/src/Makefile.am
+--- skyldav-0.2rc3_p20130817.orig/src/Makefile.am 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/src/Makefile.am 2013-08-17 13:21:52.285856000 +0200
+@@ -1 +1 @@
+-SUBDIRS = notify skyldav
++SUBDIRS = skyldav
+diff -urN skyldav-0.2rc3_p20130817.orig/src/notify/Makefile.am skyldav-0.2rc3_p20130817/src/notify/Makefile.am
+--- skyldav-0.2rc3_p20130817.orig/src/notify/Makefile.am 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/src/notify/Makefile.am 1970-01-01 01:00:00.000000000 +0100
+@@ -1,10 +0,0 @@
+-AM_CPPFLAGS = $(NOTIFY_CFLAGS)
+-skyldavnotify_LDADD = $(NOTIFY_LIBS)
+-
+-bin_PROGRAMS = \
+- skyldavnotify
+-
+-skyldavnotify_SOURCES = notify.h notify.cc
+-
+-check:
+- ./skyldavnotify --version
+\ No newline at end of file
+diff -urN skyldav-0.2rc3_p20130817.orig/src/notify/notify.cc skyldav-0.2rc3_p20130817/src/notify/notify.cc
+--- skyldav-0.2rc3_p20130817.orig/src/notify/notify.cc 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/src/notify/notify.cc 1970-01-01 01:00:00.000000000 +0100
+@@ -1,185 +0,0 @@
+-/*
+- * File: notify.c
+- *
+- * Copyright 2013 Heinrich Schuchardt <xypron.glpk@gmx.de>
+- *
+- * Licensed under the Apache License, Version 2.0 (the "License");
+- * you may not use this file except in compliance with the License.
+- * You may obtain a copy of the License at
+- *
+- * http://www.apache.org/licenses/LICENSE-2.0
+- *
+- * Unless required by applicable law or agreed to in writing, software
+- * distributed under the License is distributed on an "AS IS" BASIS,
+- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+- * See the License for the specific language governing permissions and
+- * limitations under the License.
+- *
+- */
+-
+-/**
+- * @file notify.cc
+- * @brief Notify Skyld AV events.
+- *
+- * Sound depends on freedesktop-sound-theme
+- */
+-
+-#include <gtk/gtk.h>
+-#include <libnotify/notify.h>
+-#include <glib.h>
+-#include <canberra.h>
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <signal.h>
+-#include "config.h"
+-#include "notify.h"
+-
+-#define RUNNING 1
+-#define STOPPING 2
+-
+-volatile sig_atomic_t status;
+-
+-static void sigint_handler(int sig) {
+- write(0, "\nSTOPPING\n", 10);
+- status = STOPPING;
+- }
+-
+-/**
+- * @brief Prints help message and exits.
+- */
+-static void help() {
+- printf("%s", HELP_TEXT);
+- exit(EXIT_FAILURE);
+-}
+-
+-/**
+- * @brief Shows version information and exits.
+- */
+-static void version() {
+- printf("Skyld AV, version %s\n", VERSION);
+- printf("%s", VERSION_TEXT);
+- exit(EXIT_SUCCESS);
+-}
+-
+-int main(int argc, char **argv)
+-{
+- int i;
+- char *opt;
+- NotifyNotification *n;
+- char filename[] = "/run/skyldav/log";
+- char application[] = "Skyld AV";
+- char title[] = "Skyld AV";
+- char body[2048];
+- char *msg;
+- FILE *file;
+- struct sigaction sa;
+-
+- // Analyze command line options.
+- for (i = 1; i < argc; i++) {
+- opt = argv[i];
+- if (*opt == '-') {
+- opt++;
+- } else {
+- help();
+- }
+- if (*opt == '-') {
+- opt++;
+- }
+- switch (*opt) {
+- case 'v':
+- version();
+- break;
+- default:
+- help();
+- }
+- }
+-
+- printf("Skyld AV notifier %s\n", VERSION);
+- printf("Exit with CTRL+C\n");
+-
+- file = fopen(filename, "r");
+- if (file == NULL) {
+- fprintf(stderr, "File '%s' not found\n", filename);
+- return EXIT_FAILURE;
+- }
+- // position to end of file
+- fseek(file, 0, SEEK_END);
+-
+- sa.sa_handler = sigint_handler;
+- sa.sa_flags = 0; // or SA_RESTART
+- sigemptyset(&sa.sa_mask);
+- if (sigaction(SIGINT, &sa, NULL) == -1) {
+- perror("sigaction");
+- return EXIT_FAILURE;
+- }
+-
+- ca_context *c;
+-
+- // initialize gtk
+- gtk_init(&argc,&argv);
+-
+- // initialize notify
+- notify_init(application);
+-
+- status = RUNNING;
+-
+- for (;;) {
+-
+- msg = fgets(body, 2047, file);
+-
+- if (msg == NULL) {
+- if (status != RUNNING) {
+- break;
+- }
+- if (feof(file)) {
+- usleep(500000);
+- }
+- if (ferror(file)) {
+- perror("fgets");
+- }
+- continue;
+- }
+-
+- // create a new notification
+- switch(body[0]) {
+- case '\0':
+- case '\n':
+- n = notify_notification_new(title, "<Empty message>",
+- "dialog-information");
+- break;
+- case 'E':
+- n = notify_notification_new(title, body + 1, "dialog-error");
+- break;
+- case 'W':
+- n = notify_notification_new(title, body + 1, "dialog-warning");
+- break;
+- case 'I':
+- n = notify_notification_new(title, body + 1, "dialog-information");
+- break;
+- default:
+- n = notify_notification_new(title, body + 1, "dialog-information");
+- }
+-
+- // set the timeout to 9000 ms
+- notify_notification_set_timeout(n, 9000);
+-
+- // set the urgency level to critical
+- notify_notification_set_urgency (n, NOTIFY_URGENCY_CRITICAL);
+-
+- // show the notification
+- GError *error = NULL;
+- notify_notification_show(n, &error);
+-
+- ca_context_create(&c);
+- ca_context_play(c, 0,
+- CA_PROP_EVENT_ID, "dialog-warning",
+- CA_PROP_EVENT_DESCRIPTION, title,
+- NULL);
+- usleep(500000);
+- }
+-
+- fclose(file);
+-
+- return EXIT_SUCCESS;
+-}
+-
+diff -urN skyldav-0.2rc3_p20130817.orig/src/notify/notify.h skyldav-0.2rc3_p20130817/src/notify/notify.h
+--- skyldav-0.2rc3_p20130817.orig/src/notify/notify.h 2013-08-17 00:08:41.000000000 +0200
++++ skyldav-0.2rc3_p20130817/src/notify/notify.h 1970-01-01 01:00:00.000000000 +0100
+@@ -1,60 +0,0 @@
+-/*
+- * File: notify.h
+- *
+- * Copyright 2013 Heinrich Schuchardt <xypron.glpk@gmx.de>
+- *
+- * Licensed under the Apache License, Version 2.0 (the "License");
+- * you may not use this file except in compliance with the License.
+- * You may obtain a copy of the License at
+- *
+- * http://www.apache.org/licenses/LICENSE-2.0
+- *
+- * Unless required by applicable law or agreed to in writing, software
+- * distributed under the License is distributed on an "AS IS" BASIS,
+- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+- * See the License for the specific language governing permissions and
+- * limitations under the License.
+- *
+- */
+-
+-/**
+- * @file notify.h
+- * @brief Notify Skyld AV events.
+- */
+-
+-#ifndef NOTIFY_H
+-#define NOTIFY_H
+-
+-#ifdef __cplusplus
+-extern "C" {
+-#endif
+-
+- const char *HELP_TEXT =
+- "Usage: skyldavnotify [OPTION]\n"
+- "Notification for Skyld AV on access virus scanner.\n\n"
+- " -h help\n"
+- " -v version\n\n"
+- "Licensed under the Apache License, Version 2.0.\n"
+- "Report errors to\n"
+- "Heinrich Schuchardt <xypron.glpk@gmx.de>\n";
+-
+- const char *VERSION_TEXT =
+- "Notification for Skyld AV on access virus scanner.\n\n"
+- "Copyright 2013 Heinrich Schuchardt <xypron.glpk@gmx.de>\n\n"
+- "Licensed under the Apache License, Version 2.0 (the\n"
+- "\"License\"); you may not use this file except in compliance\n"
+- "with the License. You may obtain a copy of the License at\n\n"
+- " http://www.apache.org/licenses/LICENSE-2.0\n\n"
+- "Unless required by applicable law or agreed to in writing,\n"
+- "software distributed under the License is distributed on an\n"
+- "\"AS IS\" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND,\n"
+- "either express or implied. See the License for the specific\n"
+- "language governing permissions and limitations under the\n"
+- "License.\n";
+-
+-#ifdef __cplusplus
+-}
+-#endif
+-
+-#endif /* NOTIFY_H */
+-
diff --git a/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130821-examples.patch b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130821-examples.patch
new file mode 100644
index 0000000..03bcb33
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.2_rc3_p20130821-examples.patch
@@ -0,0 +1,11 @@
+diff -urN skyldav-0.2rc3_p20130821.orig/Makefile.am skyldav-0.2rc3_p20130821/Makefile.am
+--- skyldav-0.2rc3_p20130821.orig/Makefile.am 2013-08-21 06:56:18.000000000 +0200
++++ skyldav-0.2rc3_p20130821/Makefile.am 2013-08-21 07:26:49.435950000 +0200
+@@ -9,7 +9,6 @@
+ rm -rf doc/doxygen
+
+ install-data-local: \
+- install-skyldav-examples \
+ install-skyldav-conf \
+ install-skyldavnotify-desktop
+
diff --git a/app-antivirus/skyldav/files/skyldav.confd b/app-antivirus/skyldav/files/skyldav.confd
new file mode 100644
index 0000000..aad4d23
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.confd
@@ -0,0 +1,11 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/skyldav
+
+# Options to pass to the skyldav daemon.
+# Option -d for daemonizing is always passed!
+# See the skyldav(1) man page for more info.
+
+#SKYLDAV_OPTS="-m 1"
diff --git a/app-antivirus/skyldav/files/skyldav.initd b/app-antivirus/skyldav/files/skyldav.initd
new file mode 100755
index 0000000..fd4bf09
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SKYLDAV_BIN="/usr/sbin/skyldav"
+SKYLDAV_OPTS="${SKYLDAV_OPTS:--m 2}"
+SKYLDAV_CONFIGFILE="/etc/skyldav.conf"
+SKYLDAV_PIDFILE_DIR="${SKYLDAV_PIDFILE_DIR:-/var/run/${RC_SVCNAME}}"
+SKYLDAV_PIDFILE="${SKYLDAV_PIDFILE:-${SKYLDAV_PIDFILE_DIR}/${RC_SVCNAME}.pid}"
+
+name="${SKYLDAV_BIN##*/}"
+command="${SKYLDAV_BIN}"
+command_args="-d ${SKYLDAV_OPTS}"
+pidfile="${SKYLDAV_PIDFILE}"
+description="Skyld AV is an anti-virus on-access scanner based upon Clam AV and fanotify"
+required_files="${SKYLDAV_CONFIG}"
+
+depend() {
+ use logger
+ need localmount
+}
+
+start_pre() {
+ checkpath -d -m 0755 -o root:root "${SKYLDAV_PIDFILE_DIR}"
+}