summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 00:08:39 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 00:08:39 +0000
commit141892665a8dee376e89bdb9cadc888b990955e6 (patch)
treece9142c5cf1af0dca59f875f15b71ca84c5a5cd0
parentVersion bump to 2.0.6_pre13 for testing. (diff)
downloadwolf31o2-141892665a8dee376e89bdb9cadc888b990955e6.tar.gz
wolf31o2-141892665a8dee376e89bdb9cadc888b990955e6.tar.bz2
wolf31o2-141892665a8dee376e89bdb9cadc888b990955e6.zip
Adding abuse_sdl to write up an ebuild for the 0.7.1 version, which was just released.
svn path=/; revision=142
-rw-r--r--games-action/abuse_sdl/Manifest6
-rw-r--r--games-action/abuse_sdl/abuse_sdl-0.7.1.ebuild78
2 files changed, 84 insertions, 0 deletions
diff --git a/games-action/abuse_sdl/Manifest b/games-action/abuse_sdl/Manifest
new file mode 100644
index 0000000..f33a2ff
--- /dev/null
+++ b/games-action/abuse_sdl/Manifest
@@ -0,0 +1,6 @@
+DIST abuse-0.7.1.tar.gz?format=raw 719285 RMD160 6602d77157064e0a728e55caa63b045f713be790 SHA1 07c22b306954eab1e0bf4a8a7441ae00fc107729 SHA256 1516a19efc1b89715a8549109a0d87b71502d94fd8b782942e335b6782a1dd57
+DIST abuse-data-2.00.tar.gz?format=raw 1997832 RMD160 3fe70dd5134f8ae77c630a44d38a1d37e7b5314d SHA1 c5e7582d577668b56d62792f0cec8201f2ff1f24 SHA256 89687ace7805a8d1b5a0179953ffb86d09fe57c26df4b55ec050c0414e535196
+DIST abuse-frabs-2.11.tar.gz?format=raw 4819133 RMD160 96ea6ef031d10ba02e070eb7d2acdbc85025024f SHA1 2699f2f4cefc5e529eec808e8208aad796de36de SHA256 6ccbdf4a754bbacd7c07b09f4f0c805bef39d3a537aadbb0cd4d06ad50acfdb8
+DIST abuse-lib-2.00.tar.gz?format=raw 2144433 RMD160 813a33cf1a6e25cffabc77907aee00307c2ca56b SHA1 9eb34ab24f01008da31f034dc46ade7de2f8ff82 SHA256 263997a5e4ea70ac3d187de824c09b9a6b4ce778bbec5d8cf8372c54b34b81df
+DIST abuse-sfx-2.00.tar.gz?format=raw 690291 RMD160 4eab7e003307205c2477a547c3824bf80ce73dda SHA1 2b396164ce3f70605d669511385a667bf2730c8b SHA256 042af3e5ae2b0d402593d375c31d643d91da9e83180e8971d563c0878f570c60
+EBUILD abuse_sdl-0.7.1.ebuild 2034 RMD160 81c5e89ed1e73ce9cb4bf69c1a05d78a52496d1e SHA1 44c50766957b1922ec00a68062cc48eb40606757 SHA256 1b0714895728192e729c3115e00370e5c8ef733e3f05a029e4f7b5cc84251a13
diff --git a/games-action/abuse_sdl/abuse_sdl-0.7.1.ebuild b/games-action/abuse_sdl/abuse_sdl-0.7.1.ebuild
new file mode 100644
index 0000000..f5b29d0
--- /dev/null
+++ b/games-action/abuse_sdl/abuse_sdl-0.7.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse_sdl/abuse_sdl-0.7.0-r3.ebuild,v 1.3 2008/02/25 23:04:10 mr_bones_ Exp $
+
+inherit eutils games
+
+ZOY="http://abuse.zoy.org/attachment/wiki/Downloads/"
+
+DESCRIPTION="port of Abuse by Crack Dot Com"
+HOMEPAGE="http://abuse.zoy.org/"
+SRC_URI="${ZOY}/abuse-${PV}.tar.gz?format=raw
+ !demo? ( ${ZOY}/abuse-data-2.00.tar.gz?format=raw )
+ demo? ( ${ZOY}/abuse-lib-2.00.tar.gz?format=raw )
+ sounds? ( ${ZOY}/abuse-sfx-2.00.tar.gz?format=raw )
+ levels? ( ${ZOY}/abuse-frabs-2.11.tar.gz?format=raw )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="demo levels sounds"
+
+RDEPEND=">=media-libs/libsdl-1.1.6"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ virtual/opengl"
+
+DATA=${WORKDIR}/datafiles
+
+src_unpack() {
+# cd "${WORKDIR}"
+# unpack ${P}.tar.bz2
+# unpack ${P}-patch_debian.tar.bz2
+
+# mkdir "${DATA}"
+# cd "${DATA}"
+# unpack abuse_datafiles.tar.gz
+
+ cd "${S}"
+ unpack ${A}
+ die "unpacked"
+# epatch ../${PN}-patch/*
+# sed -i -e "s:/var/games:${GAMES_DATADIR}:" \
+# src/sdlport/setup.cpp
+
+ # hard-coded path in the default config writer.
+# sed -i \
+# -e "s:/usr/local/share/games/abuse:${GAMES_DATADIR}/abuse:" \
+# src/sdlport/setup.cpp || die "sed src/sdlport/setup.cpp failed"
+}
+
+src_compile() {
+ egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ cd "${DATA}"
+ dodir "${GAMES_DATADIR}/abuse"
+ cp -R * "${D}/${GAMES_DATADIR}/abuse"
+
+ #fix for #10573 + #11475 ... stupid hippy bug
+ cd "${D}/${GAMES_DATADIR}/abuse"
+ epatch "${FILESDIR}"/stupid-fix.patch
+
+ newicon abuse.png ${PN}.png
+ make_desktop_entry abuse.sdl "Abuse SDL" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "NOTE: If you had previous version of abuse installed"
+ elog "you may need to remove ~/.abuse for the game to work correctly."
+}