summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2007-02-06 00:24:28 +0000
committerJason Wever <weeve@gentoo.org>2007-02-06 00:24:28 +0000
commitdcd816c16d57fb1e5d93f35e6980a3600750ec13 (patch)
tree1858126aea95b59f0ad84ef423540d9e54e7d966 /net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild
parentInitial commit of fl0p, a passive layer 7 flow fingerprinter. (diff)
downloadweeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.tar.gz
weeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.tar.bz2
weeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.zip
Add packages for most of the tools used in the Hacking VoIP Exposed book.HEADmaster
svn path=/; revision=3
Diffstat (limited to 'net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild')
-rw-r--r--net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild b/net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild
new file mode 100644
index 0000000..117ea10
--- /dev/null
+++ b/net-misc/rtpinsertsound/rtpinsertsound-2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="RTP sound inserter from the Hacking VoIP Exposed authors"
+HOMEPAGE="http://www.hackingvoip.com/sec_tools.html"
+SRC_URI="http://www.hackingvoip.com/tools/hack_library.tar.gz
+ http://www.hackingvoip.com/tools/g711conversions.tar.gz
+ http://www.hackingvoip.com/tools/${PN}_v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="virtual/libc
+ net-libs/libnet
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Make the library dependency
+ cd ${WORKDIR}/hack_library
+ emake || die "emake failed"
+
+ # Make the g711 library dependency
+ cd ${WORKDIR}/g711conversions
+ emake || die "emake failed"
+
+ # Make the package
+ cd ${WORKDIR}/${PN}_v${PV}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}_v${PV}
+ dobin rtpinsertsound
+ dodoc {LICENSE_DOCUMENTATION,LICENSE_SOFTWARE,Readme.txt}
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins helzart.wav stapler.wav g711RTPCaptureAllClearToBlow
+}