summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild24
1 files changed, 22 insertions, 2 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 9afaca6..afdea04 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -69,6 +69,15 @@ pkg_setup() {
}
src_compile() {
+ # catch people running `ebuild` w/out setup
+ if [ -z "${MAKE_ARGS}" ] ; then
+ die "Your MAKE_ARGS is empty ... are you running 'ebuild' but forgot to execute 'setup' ?"
+ fi
+
+ if [ "${PV}" = "9999" ] ; then
+ local ver="git-$(git --git-dir=${EGIT_STORE_DIR}/${EGIT_PROJECT} rev-parse --verify ${EGIT_BRANCH} | cut -c1-8)"
+ sed -i -e "/^VERSION[[:space:]]*=/s:=.*:=${ver}:" Makefile
+ fi
emake ${MAKE_ARGS} || die
}
@@ -88,6 +97,11 @@ src_install() {
sed -i -e '/^unicode=/s:NO:YES:' "${D}"/etc/rc.conf
fi
+ # Cater to the norm
+ if use x86 || use amd64; then
+ sed -i -e '/^windowkeys=/s:NO:YES:' "${D}"/etc/conf.d/keymaps
+ fi
+
# Fix portage bitching
gen_usr_ldscript libeinfo.so
gen_usr_ldscript librc.so
@@ -98,12 +112,17 @@ pkg_preinst() {
# so handle upgraders
if ! has_version sys-apps/openrc; then
local x= xtra=
- use kernel_linux && xtra="${xtra} mtab procfs sysctl"
- use kernel_FreeBSD && xtra="${xtra} dumpon savecore"
+ use kernel_linux && xtra="${xtra} hwclock mtab procfs sysctl"
+ use kernel_FreeBSD && xtra="${xtra} adjkerntz dumpon savecore"
for x in fsck root swap ${xtra}; do
[ -e "${ROOT}"etc/runlevels/boot/"${x}" ] && continue
ln -snf /etc/init.d/"${x}" "${ROOT}"etc/runlevels/boot/"${x}"
done
+ if [ -e "${ROOT}"etc/conf.d/clock ]; then
+ x=hwclock
+ use kernel_FreeBSD && x=adjkerntz
+ mv "${ROOT}"etc/conf.d/clock "${ROOT}"etc/conf.d/${x}
+ fi
fi
# Upgrade out state for baselayout-1 users
@@ -130,6 +149,7 @@ pkg_postinst() {
# Remove old baselayout links
rm -f "${ROOT}"etc/runlevels/boot/checkfs \
"${ROOT}"etc/runlevels/boot/checkroot \
+ "${ROOT}"etc/runlevels/boot/clock \
"${ROOT}"etc/runlevels/boot/rmnologin
# Make our runlevels if they don't exist