summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <roy@marples.name>2008-01-05 21:10:04 +0000
committerRoy Marples <roy@marples.name>2008-01-05 21:10:04 +0000
commit73f2e8511b534eb6eb2227371c6a422abf34411e (patch)
treea318bc26d76087f59f282df0548d5dcdb6c13f53 /sys-apps/openrc/openrc-9999.ebuild
parentFix ebuild for pam and static again (diff)
downloaduberlord-73f2e8511b534eb6eb2227371c6a422abf34411e.tar.gz
uberlord-73f2e8511b534eb6eb2227371c6a422abf34411e.tar.bz2
uberlord-73f2e8511b534eb6eb2227371c6a422abf34411e.zip
Work with the new git.
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 99011a8..58f664f 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -31,7 +31,7 @@ pkg_setup() {
LIBDIR="lib"
[ "${SYMLINK_LIB}" = "yes" ] && LIBDIR=$(get_abi_LIBDIR "${DEFAULT_ABI}")
- MAKE_ARGS="${MAKE_ARGS} LIB=${LIBDIR}"
+ MAKE_ARGS="${MAKE_ARGS} LIBNAME=${LIBDIR}"
local brand="Unknown"
if use kernel_linux; then
@@ -53,9 +53,9 @@ pkg_setup() {
fi
if use static && ! use pam; then
if use elibc_glibc; then
- MAKE_ARGS="${MAKE_ARGS} BIN_LDFLAGS=-Wl,-Bstatic"
+ MAKE_ARGS="${MAKE_ARG} PROGLDFLAGS=-Wl,-Bstatic"
else
- MAKE_ARGS="${MAKE_ARGS} BIN_LDFLAGS=-static"
+ MAKE_ARGS="${MAKE_ARGS} PROGLDFLAGS=-static"
fi
fi
@@ -70,28 +70,21 @@ src_unpack() {
# GIT has this rpath for testing, but we need to disable it as it's
# a potential security risk
- sed -i.bak -e '/LDFLAGS += -Wl,-rpath ./ s/^/#/' src/Makefile
+ #sed -i.bak -e '/LDFLAGS += -Wl,-rpath ./ s/^/#/' src/Makefile
# Ensure a .depend always exists as it should not be in GIT
- [ -e src/.depend ] || touch -r / src/.depend
+ #[ -e src/.depend ] || touch -r / src/.depend
}
fi
src_compile() {
- emake ${MAKE_ARGS} depend || die
+ #emake ${MAKE_ARGS} depend || die
emake ${MAKE_ARGS} || die
}
src_install() {
emake ${MAKE_ARGS} DESTDIR="${D}" install || die
- # Fix portage bitching about libs and symlinks
- rm "${D}"/usr/"${LIBDIR}"/libeinfo.so "${D}"/usr/"${LIBDIR}"/librc.so
- ln -s libeinfo.so.1 "${D}"/"${LIBDIR}"/libeinfo.so
- gen_usr_ldscript libeinfo.so
- ln -s librc.so.1 "${D}"/"${LIBDIR}"/librc.so
- gen_usr_ldscript librc.so
-
# Backup our default runlevels
dodir /usr/share/"${PN}"
mv "${D}/etc/runlevels" "${D}/usr/share/${PN}"