summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/openfetion/openfetion-2.0.7.ebuild')
-rw-r--r--net-im/openfetion/openfetion-2.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-im/openfetion/openfetion-2.0.7.ebuild b/net-im/openfetion/openfetion-2.0.7.ebuild
new file mode 100644
index 0000000..ee255fa
--- /dev/null
+++ b/net-im/openfetion/openfetion-2.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A GTK IM client using CHINA MOBILE's Fetion Protocol 4"
+HOMEPAGE="http://ofetion.googlecode.com"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gstreamer libnotify networkmanager xscreensaver"
+RESTRICT="mirror"
+
+DEPEND="dev-libs/openssl
+ x11-libs/gtk+:2
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}
+ gstreamer? ( media-libs/gstreamer )
+ libnotify? ( x11-libs/libnotify )
+ networkmanager? ( net-misc/networkmanager )
+ xscreensaver? ( x11-misc/xscreensaver )"
+
+src_configure() {
+ econf $(use_enable gstreamer gst)\
+ $(use_enable libnotify)\
+ $(use_enable networkmanager nm)\
+ $(use_enable xscreensaver screensaver)\
+ $(use_enable debug)
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}