summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild')
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild
index c809985..de6bd64 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3.ebuild
@@ -25,9 +25,16 @@ pkg_setup() {
ewarn
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-asm-fixes.patch
+}
+
src_compile() {
gcc-specs-pie && append-flags -nopie
- filter-flags -pie
+ filter-flags -pie -fstack-protector
replace-flags "-O?" -O2
local myconf