summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemulator/files/qemulator-0.5-basedir-new.patch')
-rw-r--r--app-emulation/qemulator/files/qemulator-0.5-basedir-new.patch267
1 files changed, 0 insertions, 267 deletions
diff --git a/app-emulation/qemulator/files/qemulator-0.5-basedir-new.patch b/app-emulation/qemulator/files/qemulator-0.5-basedir-new.patch
deleted file mode 100644
index b7e7f6e..0000000
--- a/app-emulation/qemulator/files/qemulator-0.5-basedir-new.patch
+++ /dev/null
@@ -1,267 +0,0 @@
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_audioenviron.py Qemulator-0.5/usr/local/lib/qemulator/qml_audioenviron.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_audioenviron.py 2007-05-20 09:12:02.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_audioenviron.py 2007-07-26 15:10:06.000000000 +0200
-@@ -44,21 +44,15 @@
-
- #for param in os.environ.keys():
- # print "%20s %s" % (param,os.environ[param])
--
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
--os.chdir(basedir)
-+
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-+
- #print "basedir: " + basedir
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
- sys.path.append(basedir)
- bindir = basedir + "/bin"
- #print "bindir: " + bindir
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
- #print "libdir: " + libdir
- sharedir = basedir + "/share/qemulator"
- #print "sharedir: " + sharedir
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_configuration.py Qemulator-0.5/usr/local/lib/qemulator/qml_configuration.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_configuration.py 2007-05-17 03:53:39.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_configuration.py 2007-07-26 15:09:12.000000000 +0200
-@@ -45,17 +45,10 @@
- except:
- print "locale and/or gettext for language support not installed"
- sys.exit(1)
--
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
--
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
-
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-+
- APP = 'Qemulator'
- #DIR = 'locale'
- DIR = basedir + '/share/locale'
-@@ -71,7 +64,7 @@
-
- homedir = os.path.expanduser('~/.qemulator')
- configdir = homedir + "/config"
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
- class Configuration:
- def __init__(self, callback_func=None):
- self.settings_autoshow = True
-@@ -604,4 +597,4 @@
- except:
- outdata = { }
- print "no config file"
-- return outdata
-\ No newline at end of file
-+ return outdata
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_controlmon.py Qemulator-0.5/usr/local/lib/qemulator/qml_controlmon.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_controlmon.py 2007-05-30 11:14:48.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_controlmon.py 2007-07-26 15:11:23.000000000 +0200
-@@ -55,19 +55,13 @@
- print "locale and/or gettext for language support not installed"
- sys.exit(1)
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
- sys.path.append(basedir)
- bindir = basedir + "/bin"
- #print "bindir: " + bindir
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
- #print "libdir: " + libdir
- sharedir = basedir + "/share/qemulator"
- #print "sharedir: " + sharedir
-@@ -1682,4 +1676,4 @@
- else:
- return data
-
--
-\ No newline at end of file
-+
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_filehandlers.py Qemulator-0.5/usr/local/lib/qemulator/qml_filehandlers.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_filehandlers.py 2007-05-16 23:13:01.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_filehandlers.py 2007-07-26 15:14:21.000000000 +0200
-@@ -36,18 +36,12 @@
- encoding = locale.getpreferredencoding()
- utf8conv = lambda x : unicode(x, encoding).encode('utf8')
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
- sys.path.append(basedir)
- bindir = basedir + "/bin"
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
- sharedir = basedir + "/share/qemulator"
- pixmapdir = basedir + "/share/pixmaps/qemulator"
- homedir = os.path.expanduser('~/.qemulator')
-@@ -244,4 +238,4 @@
- returnmesg = "no command given!"
- return returnmesg
-
--
-\ No newline at end of file
-+
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_imagecreation.py Qemulator-0.5/usr/local/lib/qemulator/qml_imagecreation.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_imagecreation.py 2007-05-31 06:30:35.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_imagecreation.py 2007-07-26 15:15:42.000000000 +0200
-@@ -47,15 +47,8 @@
- print "locale and/or gettext for language support not installed"
- sys.exit(1)
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
--
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-
- APP = 'Qemulator'
- #DIR = 'locale'
-@@ -72,7 +65,7 @@
-
- homedir = os.path.expanduser('~/.qemulator')
- configdir = homedir + "/config"
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
-
- class CreateImage:
- def __init__(self, imagespath, callback_func=None):
-@@ -258,4 +251,4 @@
- pass
-
- def return_newimage(self):
-- return self.newimage
-\ No newline at end of file
-+ return self.newimage
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_installwizzard.py Qemulator-0.5/usr/local/lib/qemulator/qml_installwizzard.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_installwizzard.py 2007-05-31 07:55:33.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_installwizzard.py 2007-07-26 15:16:40.000000000 +0200
-@@ -49,15 +49,9 @@
- print "locale and/or gettext for language support not installed"
- sys.exit(1)
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
- pixmapdir = basedir + "/share/pixmaps/qemulator"
-
- APP = 'Qemulator'
-@@ -75,7 +69,7 @@
-
- homedir = os.path.expanduser('~/.qemulator')
- configdir = homedir + "/config"
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
-
- class Installwizzard:
- def __init__(self, qemulator_instance, callback_func=None):
-@@ -756,4 +750,4 @@
- isset = True
- else:
- isset = False
-- return isset
-\ No newline at end of file
-+ return isset
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_machinesetup.py Qemulator-0.5/usr/local/lib/qemulator/qml_machinesetup.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_machinesetup.py 2007-06-04 22:24:04.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_machinesetup.py 2007-07-26 15:17:42.000000000 +0200
-@@ -50,15 +50,9 @@
- print "locale and/or gettext for language support not installed"
- sys.exit(1)
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
- pixmapdir = basedir + "/share/pixmaps/qemulator"
-
- APP = 'Qemulator'
-@@ -76,7 +70,7 @@
-
- homedir = os.path.expanduser('~/.qemulator')
- configdir = homedir + "/config"
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
-
- class Machinesetup:
- def __init__(self, qemulator_instance, init_image=None, callback_func=None):
-diff -Naur Qemulator-0.5.orig/usr/local/lib/qemulator/qml_tools.py Qemulator-0.5/usr/local/lib/qemulator/qml_tools.py
---- Qemulator-0.5.orig/usr/local/lib/qemulator/qml_tools.py 2007-05-31 07:09:19.000000000 +0200
-+++ Qemulator-0.5/usr/local/lib/qemulator/qml_tools.py 2007-07-26 15:18:46.000000000 +0200
-@@ -73,20 +73,13 @@
- #for param in os.environ.keys():
- # print "%20s %s" % (param,os.environ[param])
-
--current_path = os.path.realpath(__file__)
--basedir = os.path.dirname(os.path.realpath(__file__))
--if not os.path.exists(os.path.join(basedir, "main.py")):
-- if os.path.exists(os.path.join(os.getcwd(), "main.py")):
-- basedir = os.getcwd()
--sys.path.insert(0, basedir)
--os.chdir(basedir)
--#print "basedir: " + basedir
--basedir = basedir.replace ( '/bin', '' )
--basedir = basedir.replace ( '/lib/qemulator', '' )
-+_libdir = "@GENTOO_LIBDIR@"
-+basedir = "/usr"
-+
- sys.path.append(basedir)
- bindir = basedir + "/bin"
- #print "bindir: " + bindir
--libdir = basedir + "/lib/qemulator"
-+libdir = basedir + "/" + _libdir + "/qemulator"
- #print "libdir: " + libdir
- sharedir = basedir + "/share/qemulator"
- #print "sharedir: " + sharedir