summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virtualbox-ose/files')
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-1-config1
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-1-wrapper139
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-1.6.6-remove-unused.patch96
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-2-wrapper103
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-3-config (renamed from app-emulation/virtualbox-ose/files/virtualbox-ose-2-config)0
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-3-localconfig (renamed from app-emulation/virtualbox-ose/files/virtualbox-ose-2-localconfig)0
-rwxr-xr-xapp-emulation/virtualbox-ose/files/virtualbox-ose-3-wrapper6
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-fix-insecure-lockfiles.patch94
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-fix-nodbus-build.patch17
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-interfaces4
10 files changed, 3 insertions, 457 deletions
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-1-config b/app-emulation/virtualbox-ose/files/virtualbox-ose-1-config
deleted file mode 100644
index f69e73e..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-1-config
+++ /dev/null
@@ -1 +0,0 @@
-INSTALL_DIR=/opt/VirtualBox
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-1-wrapper b/app-emulation/virtualbox-ose/files/virtualbox-ose-1-wrapper
deleted file mode 100644
index a560713..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-1-wrapper
+++ /dev/null
@@ -1,139 +0,0 @@
-#!/bin/sh
-#
-# Sun xVM VirtualBox
-#
-# Copyright (C) 2006-2007 Sun Microsystems, Inc.
-#
-# This file is part of VirtualBox Open Source Edition (OSE), as
-# available from http://www.virtualbox.org. This file is free software;
-# you can redistribute it and/or modify it under the terms of the GNU
-# General Public License (GPL) as published by the Free Software
-# Foundation, in version 2 as it comes in the "COPYING" file of the
-# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
-# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa
-# Clara, CA 95054 USA or visit http://www.sun.com if you need
-# additional information or have any questions.
-#
-
-PATH="/usr/bin:/bin:/usr/sbin:/sbin"
-CONFIG="/etc/vbox/vbox.cfg"
-
-if [ ! -r "$CONFIG" ]; then
- echo "Could not find VirtualBox installation. Please reinstall."
- exit 1
-fi
-
-. "$CONFIG"
-
-# Note: This script must not fail if the module was not successfully installed
-# because the user might not want to run a VM but only change VM params!
-
-if [ "$1" = "shutdown" ]; then
- SHUTDOWN="true"
-elif [ ! -e /lib/modules/`uname -r`/misc/vboxdrv.ko ]; then
- cat << EOF
-WARNING: There is no module available for the current kernel (`uname -r`).
- Please recompile the kernel module and install it by:
-
- sudo emerge -1 app-emulation/virtualbox-modules
-
- You will not be able to start VMs until this problem is fixed.
-EOF
-elif ! lsmod|grep -q vboxdrv; then
- cat << EOF
-WARNING: The vboxdrv kernel module is not loaded.
- Please load the kernel module by:
-
- sudo modprobe vboxdrv
-
- You will not be able to start VMs until this problem is fixed.
-EOF
-elif [ ! -c /dev/vboxdrv ]; then
- cat << EOF
-WARNING: The character device /dev/vboxdrv does not exist.
- Please try to reload the kernel module by:
-
- sudo rmmod vboxdrv; sleep 2; sudo modprobe vboxdrv
-
- and if that is not successful, try to re-install the package by:
-
- sudo emerge -1 app-emulation/virtualbox-modules
-
- You will not be able to start VMs until this problem is fixed.
-EOF
-elif [ ! -w /dev/vboxdrv ]; then
- if [ "`id | grep vboxusers`" = "" ]; then
- cat << EOF
-WARNING: You are not a member of the "vboxusers" group.
- Please add yourself to this group before starting VirtualBox.
-
- You will not be able to start VMs until this problem is fixed.
-EOF
- else
- cat << EOF
-WARNING: /dev/vboxdrv not writable for some reason.
- If you recently added the current user to the "vboxusers" group
- then you have to logout and re-login to take the change effect.
-
- You will not be able to start VMs until this problem is fixed.
-EOF
- fi
-elif [ ! -e /usr/lib/libhal.so ]; then
- cat << EOF
-WARNING: libhal was not found on this system.
- This can create several side effects thus problems,
- when accessing host resources (eg: Cd/Dvd readers).
-
- The use of "sys-apps/hal" is still recommended, please install it
- to meet this requirement by:
-
- sudo emerge sys-apps/hal
-EOF
-fi
-
-export LD_LIBRARY_PATH="$INSTALL_DIR${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
-
-SERVER_PID=`ps -U \`whoami\` | grep VBoxSVC | awk '{ print $1 }'`
-if [ -z "$SERVER_PID" ]; then
- # Server not running yet/anymore, cleanup socket path.
- # See IPC_GetDefaultSocketPath()!
- if [ -n "$LOGNAME" ]; then
- rm -rf /tmp/.vbox-$LOGNAME-ipc > /dev/null 2>&1
- else
- rm -rf /tmp/.vbox-$USER-ipc > /dev/null 2>&1
- fi
-fi
-
-if [ "$SHUTDOWN" = "true" ]; then
- if [ -n "$SERVER_PID" ]; then
- kill -TERM $SERVER_PID
- sleep 2
- fi
- exit 0
-fi
-
-APP=`which $0`
-APP=`basename $APP`
-APP=${APP##/*/}
-case "$APP" in
- VirtualBox)
- exec "$INSTALL_DIR/VirtualBox" "$@"
- ;;
- VBoxManage)
- exec "$INSTALL_DIR/VBoxManage" "$@"
- ;;
- VBoxSDL)
- exec "$INSTALL_DIR/VBoxSDL" "$@"
- ;;
- VBoxVRDP)
- exec "$INSTALL_DIR/VBoxHeadless" "$@"
- ;;
- VBoxHeadless)
- exec "$INSTALL_DIR/VBoxHeadless" "$@"
- ;;
- *)
- echo "Unknown application - $APP"
- ;;
-esac
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-1.6.6-remove-unused.patch b/app-emulation/virtualbox-ose/files/virtualbox-ose-1.6.6-remove-unused.patch
deleted file mode 100644
index ad2ac6a..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-1.6.6-remove-unused.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- Config.kmk.orig 2008-09-03 01:49:46.000000000 +0200
-+++ Config.kmk 2008-09-03 01:53:48.000000000 +0200
-@@ -134,26 +134,26 @@
-
- # This indicates that additions (of some kind or another) is being _built_.
- # VBOX_WITHOUT_ADDITIONS overrides it.
--if1of ($(KBUILD_TARGET),l4 linux os2 solaris win)
-- VBOX_WITH_ADDITIONS = 1
--else ifdef VBOX_WITH_WIN32_ADDITIONS # for ssh cross builds -remove later!
-- VBOX_WITH_ADDITIONS = 1
--else ifdef VBOX_WITH_LINUX_ADDITIONS # for ssh cross builds - remove later!
-- VBOX_WITH_ADDITIONS = 1
--endif
-+#if1of ($(KBUILD_TARGET),l4 linux os2 solaris win)
-+# VBOX_WITH_ADDITIONS = 1
-+#else ifdef VBOX_WITH_WIN32_ADDITIONS # for ssh cross builds -remove later!
-+# VBOX_WITH_ADDITIONS = 1
-+#else ifdef VBOX_WITH_LINUX_ADDITIONS # for ssh cross builds - remove later!
-+# VBOX_WITH_ADDITIONS = 1
-+#endif
- # Build the optional ring-0 part of the additions for syntax checking.
- # (Ignored ifndef VBOX_WITH_ADDITIONS. Hack for 32/64 linux issues.)
--VBOX_WITH_ADDITION_DRIVERS = 1
-+#VBOX_WITH_ADDITION_DRIVERS = 1
- # Build win32 additions (cross building them on linux and l4 using wine).
--if1of ($(KBUILD_TARGET),l4 linux win)
-- VBOX_WITH_WIN32_ADDITIONS = 1
--endif
-+#if1of ($(KBUILD_TARGET),l4 linux win)
-+# VBOX_WITH_WIN32_ADDITIONS = 1
-+#endif
- # Build linux additions.
- # Note! VBOX_WITH_LINUX_ADDITIONS will be removed later and only
- # VBOX_WITH_WIN32_ADDITIONS will be kept around for cross building.
--if1of ($(KBUILD_TARGET),l4 linux)
-- VBOX_WITH_LINUX_ADDITIONS = 1
--endif
-+#if1of ($(KBUILD_TARGET),l4 linux)
-+# VBOX_WITH_LINUX_ADDITIONS = 1
-+#endif
- # Build X11 additions. Can be disabled separately.
- ifndef VBOX_WITH_X11_ADDITIONS
- ifdef VBOX_WITH_LINUX_ADDITIONS
-@@ -196,7 +196,7 @@
- # Activate this to force the VM to pre-allocate the guest RAM before startup
- VBOX_WITH_PREALLOC_RAM_BY_DEFAULT =
- # The kernel driver/module and related runtime libraries.
--VBOX_WITH_VBOXDRV = 1
-+#VBOX_WITH_VBOXDRV = 1
- # build with secure label support
- ifeq ($(filter win.amd64,$(KBUILD_TARGET).$(KBUILD_TARGET_ARCH)),) # too much work with freetype and all that.
- VBOX_WITH_SECURELABEL = 1
-@@ -209,7 +209,7 @@
- # The SDL based GUI.
- VBOX_WITH_VBOXSDL = 1
- # The basic frontend (w/o Main).
--VBOX_WITH_VBOXBFE = 1
-+#VBOX_WITH_VBOXBFE = 1
- # The Qt GUI.
- VBOX_WITH_QTGUI = 1
- # The Qt 4 GUI (experimental).
-@@ -245,9 +245,9 @@
- # Enable the kchmviewer
- VBOX_WITH_KCHMVIEWER = 1
- # Build the testsuite.
--VBOX_WITH_TESTSUITE = 1
-+#VBOX_WITH_TESTSUITE = 1
- # Build the testcases.
--VBOX_WITH_TESTCASES = 1
-+#VBOX_WITH_TESTCASES = 1
- # Set this to not use COM or XPCOM in places where it can be avoided.
- #VBOX_WITHOUT_COM = 1
- # Set this to skip installing the redistributable compiler runtime.
---- configure.orig 2008-09-03 01:49:51.000000000 +0200
-+++ configure 2008-09-03 01:54:33.000000000 +0200
-@@ -1790,14 +1790,14 @@
- # some things are not available in for OSE
- if [ $OSE -ge 1 ]; then
- cnf_append "VBOX_OSE" "1"
-- cnf_append "VBOX_WITH_TESTSUITE" ""
-+# cnf_append "VBOX_WITH_TESTSUITE" ""
- cnf_append "VBOX_WITH_WIN32_ADDITIONS" ""
-
-- if [ "$OS" = "linux" ]; then
-- cnf_append "VBOX_WITH_LINUX_ADDITIONS" "1"
-- else
-- cnf_append "VBOX_WITH_LINUX_ADDITIONS" ""
-- fi
-+# if [ "$OS" = "linux" ]; then
-+# cnf_append "VBOX_WITH_LINUX_ADDITIONS" "1"
-+# else
-+# cnf_append "VBOX_WITH_LINUX_ADDITIONS" ""
-+# fi
- echo >> $CNF
- fi
-
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-wrapper b/app-emulation/virtualbox-ose/files/virtualbox-ose-2-wrapper
deleted file mode 100644
index edf4e25..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-wrapper
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-#
-# Sun xVM VirtualBox
-#
-# Copyright (C) 2006-2007 Sun Microsystems, Inc.
-#
-# This file is part of VirtualBox Open Source Edition (OSE), as
-# available from http://www.virtualbox.org. This file is free software;
-# you can redistribute it and/or modify it under the terms of the GNU
-# General Public License (GPL) as published by the Free Software
-# Foundation, in version 2 as it comes in the "COPYING" file of the
-# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
-# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa
-# Clara, CA 95054 USA or visit http://www.sun.com if you need
-# additional information or have any questions.
-#
-
-PATH="/usr/bin:/bin:/usr/sbin:/sbin"
-CONFIG="/etc/vbox/vbox.cfg"
-
-if [ ! -r "$CONFIG" ]; then
- echo "Could not find VirtualBox installation. Please reinstall."
- exit 1
-fi
-
-. "$CONFIG"
-
-# Note: This script must not fail if the module was not successfully installed
-# because the user might not want to run a VM but only change VM params!
-
-if [ "$1" = "shutdown" ]; then
- SHUTDOWN="true"
-elif ! lsmod|grep -q vboxdrv; then
- cat << EOF
-WARNING: The vboxdrv kernel module is not loaded.
- Please load the kernel module by:
-
- sudo modprobe vboxdrv
-
- You will not be able to start VMs until this problem is fixed.
-EOF
-elif [ ! -c /dev/vboxdrv ]; then
- cat << EOF
-WARNING: The character device /dev/vboxdrv does not exist.
- Please try to reload the kernel module by:
-
- sudo rmmod vboxdrv; sleep 2; sudo modprobe vboxdrv
-
- and if that is not successful, try to re-install the package by:
-
- sudo emerge -1 app-emulation/virtualbox-modules
-
- You will not be able to start VMs until this problem is fixed.
-EOF
-fi
-
-SERVER_PID=`ps -U \`whoami\` | grep VBoxSVC | awk '{ print $1 }'`
-if [ -z "$SERVER_PID" ]; then
- # Server not running yet/anymore, cleanup socket path.
- # See IPC_GetDefaultSocketPath()!
- if [ -n "$LOGNAME" ]; then
- rm -rf /tmp/.vbox-$LOGNAME-ipc > /dev/null 2>&1
- else
- rm -rf /tmp/.vbox-$USER-ipc > /dev/null 2>&1
- fi
-fi
-
-if [ "$SHUTDOWN" = "true" ]; then
- if [ -n "$SERVER_PID" ]; then
- kill -TERM $SERVER_PID
- sleep 2
- fi
- exit 0
-fi
-
-APP=`which $0`
-APP=`basename $APP`
-APP=${APP##/*/}
-case "$APP" in
- VirtualBox)
- exec "$INSTALL_DIR/VirtualBox" "$@"
- ;;
- VBoxManage)
- exec "$INSTALL_DIR/VBoxManage" "$@"
- ;;
- VBoxSDL)
- exec "$INSTALL_DIR/VBoxSDL" "$@"
- ;;
- VBoxVRDP)
- exec "$INSTALL_DIR/VBoxHeadless" "$@"
- ;;
- VBoxHeadless)
- exec "$INSTALL_DIR/VBoxHeadless" "$@"
- ;;
- vboxwebsrv)
- exec "$INSTALL_DIR/vboxwebsrv" "$@"
- ;;
- *)
- echo "Unknown application - $APP"
- ;;
-esac
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-config b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-config
index d1e35d2..d1e35d2 100644
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-config
+++ b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-config
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-localconfig b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-localconfig
index 0c99788..0c99788 100644
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-2-localconfig
+++ b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-localconfig
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-3-wrapper b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-wrapper
index 0cf0597..6f2da49 100755
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-3-wrapper
+++ b/app-emulation/virtualbox-ose/files/virtualbox-ose-3-wrapper
@@ -37,7 +37,7 @@ elif ! lsmod|grep -q vboxdrv; then
WARNING: The VirtualBox kernel modules are not loaded.
Please load all the needed kernel modules by:
- for m in vbox{drv,netadp,netflt}; do modprobe $m; done
+ for m in vbox{drv,netadp,netflt}; do modprobe \$m; done
You will not be able to start VMs until this problem is fixed.
EOF
@@ -46,8 +46,8 @@ elif [ ! -c /dev/vboxdrv ]; then
WARNING: The character device /dev/vboxdrv does not exist.
Please try to reload all the needed kernel modules by:
- for m in vbox{netflt,netadp,drv}; do rmmod $m; done
- for m in vbox{drv,netadp,netflt}; do modprobe $m; done
+ for m in vbox{netflt,netadp,drv}; do rmmod \$m; done
+ for m in vbox{drv,netadp,netflt}; do modprobe \$m; done
and if that is not successful, try to re-install the package by:
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-insecure-lockfiles.patch b/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-insecure-lockfiles.patch
deleted file mode 100644
index 0df6290..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-insecure-lockfiles.patch
+++ /dev/null
@@ -1,94 +0,0 @@
---- src/libs/xpcom18a4/ipc/ipcd/daemon/src/ipcdUnix.cpp.orig 2008-11-09 19:48:22.000000000 +0100
-+++ src/libs/xpcom18a4/ipc/ipcd/daemon/src/ipcdUnix.cpp 2008-11-09 19:51:54.000000000 +0100
-@@ -93,7 +93,7 @@
- EOk = 0,
- ELockFileOpen = -1,
- ELockFileLock = -2,
--
-+ ELockFileOwner = -3,
- };
-
- static int ipcLockFD = 0;
-@@ -112,16 +112,70 @@
- lockFile[dirLen] = '/';
- memcpy(lockFile + dirLen + 1, lockName, sizeof(lockName));
-
-+#ifdef VBOX
-+ //
-+ // Security checks for the directory
-+ //
-+ struct stat st;
-+ if (stat(baseDir, &st) == -1)
-+ {
-+ printf("Cannot stat '%s'.\n", baseDir);
-+ return ELockFileOwner;
-+ }
-+
-+ if (st.st_uid != getuid() && st.st_uid != geteuid())
-+ {
-+ printf("Wrong owner (%d) of '%s'.\n", st.st_uid, baseDir);
-+ return ELockFileOwner;
-+ }
-+
-+ if (st.st_mode != (S_IRUSR | S_IWUSR | S_IXUSR | S_IFDIR))
-+ {
-+ printf("Wrong mode (%o) of '%s'.\n", st.st_mode, baseDir);
-+ return ELockFileOwner;
-+ }
-+#endif
-+
- //
- // open lock file. it remains open until we shutdown.
- //
- ipcLockFD = open(lockFile, O_WRONLY|O_CREAT, S_IWUSR|S_IRUSR);
-
-+#ifndef VBOX
- free(lockFile);
-+#endif
-
- if (ipcLockFD == -1)
- return ELockFileOpen;
-
-+#ifdef VBOX
-+ //
-+ // Security checks for the lock file
-+ //
-+ if (fstat(ipcLockFD, &st) == -1)
-+ {
-+ printf("Cannot stat '%s'.\n", lockFile);
-+ free(lockFile);
-+ return ELockFileOwner;
-+ }
-+
-+ if (st.st_uid != getuid() && st.st_uid != geteuid())
-+ {
-+ printf("Wrong owner (%d) of '%s'.\n", st.st_uid, lockFile);
-+ free(lockFile);
-+ return ELockFileOwner;
-+ }
-+
-+ if (st.st_mode != (S_IRUSR | S_IWUSR | S_IFREG))
-+ {
-+ printf("Wrong mode (%o) of '%s'.\n", st.st_mode, lockFile);
-+ free(lockFile);
-+ return ELockFileOwner;
-+ }
-+
-+ free(lockFile);
-+#endif
-+
- //
- // we use fcntl for locking. assumption: filesystem should be local.
- // this API is nice because the lock will be automatically released
-@@ -433,8 +487,9 @@
- // don't notify the parent to cause it to fail in PR_Read() after
- // we terminate
- #ifdef VBOX
-- printf("Cannot create a lock file for '%s'.\n"
-- "Check permissions.\n", addr.local.path);
-+ if (status != ELockFileOwner)
-+ printf("Cannot create a lock file for '%s'.\n"
-+ "Check permissions.\n", addr.local.path);
- #endif
- return 0;
- }
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-nodbus-build.patch b/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-nodbus-build.patch
deleted file mode 100644
index f81a2f9..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-fix-nodbus-build.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/VBox/Main/Makefile.kmk.orig 2009-01-26 23:18:28.000000000 +0100
-+++ src/VBox/Main/Makefile.kmk 2009-01-27 00:14:17.000000000 +0100
-@@ -290,10 +290,11 @@
- win/HostPowerWin.cpp \
- win/VBoxSVC.rc
-
-+VBoxSVC_SOURCES.linux = \
-+ linux/HostHardwareLinux.cpp
-+
- ifdef VBOX_WITH_DBUS
--VBoxSVC_SOURCES.linux += \
-- linux/HostHardwareLinux.cpp \
-- linux/vbox-dbus.cpp
-+ VBoxSVC_SOURCES.linux += linux/vbox-dbus.cpp
- endif
-
- VBoxSVC_SOURCES.solaris = \
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-interfaces b/app-emulation/virtualbox-ose/files/virtualbox-ose-interfaces
deleted file mode 100644
index ce2606b..0000000
--- a/app-emulation/virtualbox-ose/files/virtualbox-ose-interfaces
+++ /dev/null
@@ -1,4 +0,0 @@
-# This file is for registering VirtualBox permanent host networking interfaces
-# and optionally adding them to network bridges on the host.
-# Each line should be of the format <interface name> <user name> [<bridge>].
-