summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
committerBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
commitfb26a5c2df5e1fde31491ebeff69112712008353 (patch)
tree2f8414516404877c9df8e29df0c2b2536ab2bd5c /sci-mathematics/jags/jags-2.2.0.ebuild
downloadheroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.tar.gz
heroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.tar.bz2
heroxbd-fb26a5c2df5e1fde31491ebeff69112712008353.zip
initial commit
Diffstat (limited to 'sci-mathematics/jags/jags-2.2.0.ebuild')
-rw-r--r--sci-mathematics/jags/jags-2.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-mathematics/jags/jags-2.2.0.ebuild b/sci-mathematics/jags/jags-2.2.0.ebuild
new file mode 100644
index 0000000..249bab1
--- /dev/null
+++ b/sci-mathematics/jags/jags-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-2.2.0.ebuild,v 1.1 2011/02/12 11:50:38 tomka Exp $
+
+EAPI=2
+inherit autotools-utils
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://www-fis.iarc.fr/~martyn/software/jags/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/2.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE=""
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=(README NEWS TODO AUTHORS)
+
+src_configure() {
+ myeconfags=(
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ )
+ autotools-utils_src_configure
+}