summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2020-01-26 11:19:57 +0100
committerHans de Graaff <hans@degraaff.org>2020-01-26 11:25:44 +0100
commit5a3b01f0a5ea833a9621c0fddc10c94d04423995 (patch)
tree089d28b976b270af5b8ae0c3600de78805edeee1 /dev-util
parentdev-python/django-haystack: import from gentoo with python2_7 (diff)
downloadgraaff-5a3b01f0a5ea833a9621c0fddc10c94d04423995.tar.gz
graaff-5a3b01f0a5ea833a9621c0fddc10c94d04423995.tar.bz2
graaff-5a3b01f0a5ea833a9621c0fddc10c94d04423995.zip
dev-util/reviewboard: add 3.0.16
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/reviewboard/Manifest1
-rw-r--r--dev-util/reviewboard/reviewboard-3.0.16.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-util/reviewboard/Manifest b/dev-util/reviewboard/Manifest
index a4a05748..fd726356 100644
--- a/dev-util/reviewboard/Manifest
+++ b/dev-util/reviewboard/Manifest
@@ -1,3 +1,4 @@
DIST ReviewBoard-3.0.13.tar.gz 21255002 BLAKE2B 0d585187fc9135cdd6bc2c2df8705e24d3414dd9f1660c2fc513b0817a53a212e02e57d53250fcb72acfacfc62f20bc4cc7f862cfd2b4b8e8258da849c7b40ea SHA512 3910731023ec55815c12fae22290d5eb1bb9da68bc876a4dd2b4a07d2553a65368455763f8053ae39cd44ea3e7bbd8ea19ad1c9d7e721b9b16b1109ff195f09f
DIST ReviewBoard-3.0.14.tar.gz 21261370 BLAKE2B ff51924952918b097df3d03b8099aa037bbba37b96a7a4769ad7dced969762e2dee3f33128612efea39863b10005f2335fbdcb9e857277ab6a2d423708a48ada SHA512 e97b958e188dfb51b918e7153483d3cbb0e2788dc06560dc48b17bc70ae89bf73ef12a3e454a14c6672f394cfc799f5b344ef9c8e904ed375ee1b469ef12ee2d
DIST ReviewBoard-3.0.15.tar.gz 21264775 BLAKE2B 2656ee184d6f47dca95080f010c67d92bbd66d0c5f97658c4c9667463a515e173bfac6ef3175d0237c0468340b2018e960199ad02fda523d8a5fb6d15719d1a2 SHA512 1ca762e5e671550cc1e5713b524294e9f91cf847a8db4a5cc09989eaf3346d9f2d9238b9c18775eac4b907dbf216dd6e7173fd1c806cc4b88f3734966f86674a
+DIST ReviewBoard-3.0.16.tar.gz 21296360 BLAKE2B ddbb73c1b1b8ddeb3d2bf8b986d4c00369fe61f5691823a06cd47f6f4a5a3316074f87acdb592ccf6fa15e67598bb514502c31cc5b40eb647191c9fa69e6c03c SHA512 3b7a02ae2346cce55e3dc63072d23e1c0c47cdcea6abe5f9e38fea4a6b7da9b78674a078887e24e95cacacfa56635b350f34ff8b9c11871e2109943f803b3d88
diff --git a/dev-util/reviewboard/reviewboard-3.0.16.ebuild b/dev-util/reviewboard/reviewboard-3.0.16.ebuild
new file mode 100644
index 00000000..471c11a8
--- /dev/null
+++ b/dev-util/reviewboard/reviewboard-3.0.16.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_PN="ReviewBoard"
+DESCRIPTION="A web-based code review tool that offers developers a way to handle code reviews"
+HOMEPAGE="https://www.reviewboard.org/"
+SRC_URI="https://downloads.reviewboard.org/releases/${MY_PN}/3.0/${MY_PN}-${PV}.tar.gz"
+KEYWORDS="~amd64"
+IUSE="codebase doc manual ldap rnotes test"
+
+LICENSE="MIT"
+SLOT="0"
+S=${WORKDIR}/${MY_PN}-${PV}
+
+RDEPEND=">=dev-python/django-1.6.11.1[${PYTHON_USEDEP},sqlite]
+ <dev-python/django-1.7[${PYTHON_USEDEP},sqlite]
+ >=dev-python/django-cors-headers-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/django-cors-headers-1.2[${PYTHON_USEDEP}]
+ >=dev-python/django-evolution-0.7.7[${PYTHON_USEDEP}]
+ <dev-python/django-evolution-0.8[${PYTHON_USEDEP}]
+ =dev-python/django-haystack-2.4*[${PYTHON_USEDEP}]
+ dev-python/django-multiselectfield[${PYTHON_USEDEP}]
+ =dev-python/django-oauth-toolkit-0.9*[${PYTHON_USEDEP}]
+ =dev-python/Djblets-1.0*[${PYTHON_USEDEP}]
+ >=dev-python/Djblets-1.0.12[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.1[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.6.8[${PYTHON_USEDEP}]
+ <dev-python/markdown-2.7[${PYTHON_USEDEP}]
+ >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.12[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-3.4[${PYTHON_USEDEP}]
+ =dev-python/pymdown-extensions-3*[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ dev-python/python-memcached[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2015.2[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.6[${PYTHON_USEDEP}]
+ ldap? ( >=dev-python/python-ldap-2.4.21[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ net-libs/nodejs
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PDEPEND=" >=dev-python/rbintegrations-1.0.1[${PYTHON_USEDEP}]"
+
+REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
+# Tests mostly access the inet and when run mostly fail
+RESTRICT=test
+
+src_unpack() {
+ default
+
+ cd "${S}"
+ npm install less@3.9.0 less-plugin-autoprefix@2.0.0 uglify-js@2.4.10 babel-cli@6.5.1 babel-preset-es2015@6.5.0 babel-plugin-dedent@2.0.0 || die
+}
+
+python_prepare_all() {
+ # Running uglify is a problem right now, so skip this step. Rather
+ # have newer versions than compacted javascript.
+ sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i reviewboard/settings.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See https://code.google.com/p/reviewboard/issues/ #3009
+ # until build of manual can find and use ROOT_URLCONF, only possible build path for manual
+ # requires sacrificing the resources section, all of which call on ROOT_URLCONF
+ local msg="Generating docs for"
+ if use doc; then
+ if use manual; then
+ rm -rf docs/manual/webapi//2.0/resources/ || die
+ einfo;einfo "$msg manual"
+ DJANGO_SETTINGS_MODULE="django.conf" emake -C docs/manual html
+ fi
+
+ if use codebase; then
+ pushd docs/codebase &> /dev/null
+ ln -sf ../../contrib/internal/conf/settings_local.py .
+ popd &> /dev/null
+ einfo;einfo "$msg codebase"
+ emake -C docs/codebase html
+ fi
+
+ if use rnotes; then
+ einfo;einfo "$msg release notes"
+ emake -C docs/releasenotes html
+ fi
+ fi
+}
+
+python_test() {
+ pushd ${PN} > /dev/null
+ ln -sf contrib/internal/conf/settings_local.py .
+ "${PYTHON}" manage.py test || die
+}
+
+python_install_all() {
+ if use doc; then
+ if use manual; then
+ insinto /usr/share/doc/${PF}/manual
+ doins -r docs/manual/_build/html/
+ fi
+ if use codebase; then
+ insinto /usr/share/doc/${PF}/codebase
+ doins -r docs/codebase/_build/html/
+ fi
+ if use rnotes; then
+ insinto /usr/share/doc/${PF}/release_notes
+ doins -r docs/releasenotes/_build/html/
+ fi
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "You must install any VCS tool you wish ${PN} to support."
+ elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or dev-util/subversion."
+ elog
+ elog "Install dev-python/mysql-python for mysql support."
+ elog "Install dev-python/psycopg for postgres support."
+ elog
+ elog "For speed and responsiveness, consider installing net-misc/memcached"
+ elog "and dev-python/python-memcached"
+}