summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-01-04 01:04:20 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-01-04 01:04:20 +0100
commitb4242efcc30d6b6a4752ce7236fdb088b124ab9b (patch)
tree2bb13ba5515f02af5385911893dc51c77dee2ee9 /media-video/transmageddon
parentdev-util/valadoc: initial ebuild (diff)
downloadeva-b4242efcc30d6b6a4752ce7236fdb088b124ab9b.tar.gz
eva-b4242efcc30d6b6a4752ce7236fdb088b124ab9b.tar.bz2
eva-b4242efcc30d6b6a4752ce7236fdb088b124ab9b.zip
media-video/transmageddon: initial ebuild
Diffstat (limited to 'media-video/transmageddon')
-rw-r--r--media-video/transmageddon/Manifest11
-rw-r--r--media-video/transmageddon/metadata.xml8
-rw-r--r--media-video/transmageddon/transmageddon-0.25.ebuild41
3 files changed, 60 insertions, 0 deletions
diff --git a/media-video/transmageddon/Manifest b/media-video/transmageddon/Manifest
new file mode 100644
index 0000000..e6030ef
--- /dev/null
+++ b/media-video/transmageddon/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST transmageddon-0.25.tar.xz 215108 SHA256 c5b40d339083d95ea07005b908c752ae472fa5177caab21b5d6f74b8b66d528d SHA512 3793936866a9ecff02e3d17cfe708e5e0260059664d750267e52967850ada3eab1376b88e4fa8bd92630f6fbed3d9a011ee190b2b888e91e34713c214d72a294 WHIRLPOOL 1a86b34e06e2e3c8ba3c65d555f617529c45a907db1b401b07ca7316d00187d7862958dc2c21ba4ebcb8d7c68b5d369ef2c86a4d68b36b708e5eb965f398fe91
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlSog4QACgkQ1fmVwcYIWAYIjwCcCwTnfitDX6a65RTnYjn90rlx
+o+0AoOSbyVHacgNE+aMPtCJBffdWHwVE
+=EfnQ
+-----END PGP SIGNATURE-----
diff --git a/media-video/transmageddon/metadata.xml b/media-video/transmageddon/metadata.xml
new file mode 100644
index 0000000..23310c6
--- /dev/null
+++ b/media-video/transmageddon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/transmageddon/transmageddon-0.25.ebuild b/media-video/transmageddon/transmageddon-0.25.ebuild
new file mode 100644
index 0000000..b4867b4
--- /dev/null
+++ b/media-video/transmageddon/transmageddon-0.25.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit fdo-mime python-single-r1
+
+DESCRIPTION="Video transcoder using GStreamer"
+HOMEPAGE="http://www.linuxrising.org/"
+SRC_URI="http://www.linuxrising.org/files/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+
+ media-plugins/gst-plugins-meta:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35
+"
+
+pkg_postisnt() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}