summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <andreas.huettel@physik.uni-r.de>2011-01-24 18:49:40 +0100
committerAndreas K. Huettel <andreas.huettel@physik.uni-r.de>2011-01-24 18:59:44 +0100
commit362e46dda993f3eb518ad7138a56b28475daf41d (patch)
tree188747115f2dd726ab8080fd4b7e32580f263226 /sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch
parent[sci-libs/linux-gpib] Cleanups (diff)
downloaddilfridge-362e46dda993f3eb518ad7138a56b28475daf41d.tar.gz
dilfridge-362e46dda993f3eb518ad7138a56b28475daf41d.tar.bz2
dilfridge-362e46dda993f3eb518ad7138a56b28475daf41d.zip
[sci-libs/linux-gpib] Blind version bump
(Portage version: 2.1.9.31/git/Linux x86_64, signed Manifest commit with key 7887F787)
Diffstat (limited to 'sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch')
-rw-r--r--sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch b/sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch
new file mode 100644
index 0000000..767a89a
--- /dev/null
+++ b/sci-libs/linux-gpib/files/linux-gpib-3.2.15-drivers-make.am.patch
@@ -0,0 +1,36 @@
+--- drivers/Makefile.am.original 2007-04-20 00:21:04.000000000 +0900
++++ drivers/Makefile.am 2008-02-18 16:32:20.000000000 +0900
+@@ -31,18 +31,16 @@
+ $(MAKE) -C $(LINUX_SRCDIR) V=1 modules_install\
+ CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/driver/include -I@abs_top_srcdir@/include" \
+ SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)" INSTALL_MOD_DIR="gpib"
+- $(DEPMOD) -ae
+
+ /dev/gpib0:
+- groupadd gpib || echo "group gpib exists"
+ for i in `seq 0 15`; \
+ do \
+ mknod -m u=rw,g=rw,o= /dev/gpib$${i} c $(IBMAJOR) $${i} || exit 1; \
+ chown root:gpib /dev/gpib$${i}; \
+ done
+
+-.PHONY : device-file-check
+-device-file-check: /dev/gpib0
++.PHONY : device-file-check-emerge
++device-file-check-emerge: /dev/gpib0
+ @if [ ! -c /dev/gpib0 ]; then \
+ if [ -a /dev/gpib0 ]; then \
+ echo "A file or directory called /dev/gpib0 exists but it is not" \
+@@ -57,9 +55,11 @@
+ exit 1; \
+ fi
+
++.PHONY : device-file-check
++device-file-check:
++
+ #should move this to util/templates Makefile.am when it exists
+ /etc/gpib.conf:
+- $(INSTALL_DATA) -D $(top_srcdir)/util/templates/gpib.conf /etc/gpib.conf
+
+ #make sure compiled files, etc don't make it into distribution tarballs
+ dist-hook: