summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <mail@akhuettel.de>2011-04-30 18:02:58 +0200
committerAndreas K. Huettel (dilfridge) <mail@akhuettel.de>2011-04-30 18:02:58 +0200
commitb155d8e083e3adb218d2637926b6ad90becf21a1 (patch)
tree15b5b08d9aff23a80d02deaf48ccd71ef3d545dd /sci-libs/clapack/files
parent[media-video/bombono-dvd] Version bump (diff)
downloaddilfridge-b155d8e083e3adb218d2637926b6ad90becf21a1.tar.gz
dilfridge-b155d8e083e3adb218d2637926b6ad90becf21a1.tar.bz2
dilfridge-b155d8e083e3adb218d2637926b6ad90becf21a1.zip
[sci-libs/clapack] Abort attempts about removing Fortran; resync with tree
(Portage version: 2.1.9.46/git/Linux x86_64, signed Manifest commit with key B6C5F7DE)
Diffstat (limited to 'sci-libs/clapack/files')
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch25
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch2
2 files changed, 26 insertions, 1 deletions
diff --git a/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch b/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch
new file mode 100644
index 0000000..002336f
--- /dev/null
+++ b/sci-libs/clapack/files/clapack-3.2.1-fix_include_file.patch
@@ -0,0 +1,25 @@
+diff -urN clapack-3.2.1-CMAKE.old/INCLUDE/clapack.h clapack-3.2.1-CMAKE/INCLUDE/clapack.h
+--- clapack-3.2.1-CMAKE.old/INCLUDE/clapack.h 2011-04-30 11:39:51.000000000 +0200
++++ clapack-3.2.1-CMAKE/INCLUDE/clapack.h 2011-04-30 11:40:39.000000000 +0200
+@@ -3,6 +3,12 @@
+ #ifndef __CLAPACK_H
+ #define __CLAPACK_H
+
++#include <f2c.h>
++
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ /* Subroutine */ int caxpy_(integer *n, complex *ca, complex *cx, integer *
+ incx, complex *cy, integer *incy);
+
+@@ -7250,5 +7256,8 @@
+ integer ilaenv_(integer *ispec, char *name__, char *opts, integer *n1,
+ integer *n2, integer *n3, integer *n4);
+
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* __CLAPACK_H */
diff --git a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
index 53e3589..5ae9e63 100644
--- a/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
+++ b/sci-libs/clapack/files/clapack-3.2.1-noblasf2c.patch
@@ -66,7 +66,7 @@ diff -u -r -N clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SR
-target_link_libraries(lapack blas)
+add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
-+target_link_libraries(clapack blas f2c)
++target_link_libraries(clapack blas f2c m)
+set_target_properties(clapack PROPERTIES SOVERSION "${CLAPACK_VERSION}")
+
+install(