summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 17:43:34 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 17:43:51 +0200
commit35f94f3b364b8782bc13b705c2938cbc671c1b41 (patch)
treee61ce960676f4cc4eced0591fd567239fc43e33d
parentur-profile: un-force grub-static (diff)
downloaddilfridge-35f94f3b364b8782bc13b705c2938cbc671c1b41.tar.gz
dilfridge-35f94f3b364b8782bc13b705c2938cbc671c1b41.tar.bz2
dilfridge-35f94f3b364b8782bc13b705c2938cbc671c1b41.zip
sci-electronics/labone: Bump, work in progress
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
-rw-r--r--sci-electronics/labone/Manifest1
-rw-r--r--sci-electronics/labone/labone-21.08.20515.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-electronics/labone/Manifest b/sci-electronics/labone/Manifest
index 263583d..07b60b3 100644
--- a/sci-electronics/labone/Manifest
+++ b/sci-electronics/labone/Manifest
@@ -1,2 +1,3 @@
DIST LabOneLinux64-16.12.42529.tar.gz 120562203 BLAKE2B 5d5e3816ad47e79b8b029b318f76b72908949fb4f92b5497d4b03abf5562144951d2a95832cdd2112df8922a9ea002a508f0d81c5f1fee3a017540dceb70233a SHA512 31068792ca4c2ab88490eacf35a84f8a2c31b330087ee91154e5ecdae63bcf557563c80e45af4a855df9d7d9a1d5b5a761ef5d957ce357368706307ea5ea196b
DIST LabOneLinux64-20.07.2325.tar.gz 311600151 BLAKE2B ba5a699d22de76c4e861dc446c4a5781c8b100646d8dbd625a579886a5a898ab30d446ec24d7b28f3fe8c828a10dab351d70390aeaf6eb7ad8c3026de1c146f1 SHA512 730d705333ee7cf4c1fc56f8069764d9efdf179a673172928679f6c02dbb9406d5c66f6d8ef68f65fc28b6119aba66f8f26419618513a6f353098faa415f572d
+DIST LabOneLinux64-21.08.20515.tar.gz 399058267 BLAKE2B 624c4dc4a01edb69f9b36a435744d10b3638c91c7ac0c1e9765cf913e605fe32d1935fa131d650f38a5b713df916d92b985ac5f6489b031bba9b6ec8a1370d4a SHA512 f229a885ea91cc518c4819ad76a928829eb1699603ba48fb745d4a99faca116b100831c17a48243922912c68de27b7938387677ffa2e996a122f36c33d0a205c
diff --git a/sci-electronics/labone/labone-21.08.20515.ebuild b/sci-electronics/labone/labone-21.08.20515.ebuild
new file mode 100644
index 0000000..aa88d0e
--- /dev/null
+++ b/sci-electronics/labone/labone-21.08.20515.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Platform independent instrument control for Zurich Instruments devices"
+HOMEPAGE="https://www.zhinst.com/labone"
+SRC_URI="https://www.zhinst.com/sites/default/files/media/release_file/2021-09/LabOneLinux64-${PV}.tar.gz"
+
+LICENSE="zi-labone"
+SLOT="0"
+#KEYWORDS="-* ~amd64"
+RESTRICT="mirror bindist"
+IUSE="minimal"
+
+QA_PREBUILT="*"
+
+RDEPEND=""
+
+S=${WORKDIR}/LabOneLinux64-${PV}
+
+src_install() {
+ local instPath=/opt/zi
+ local instrDir="LabOne64-${PV}"
+
+ if ! use minimal ; then
+
+ dodir ${instPath}/${instrDir}
+ for dir in API DataServer Documentation WebServer Firmware release_notes_20.07.txt ; do
+ mv "$dir" "${D}${instPath}/${instrDir}/" || die
+ done
+
+ dosym ../..${instPath}/${instrDir}/DataServer/ziServer /opt/bin/ziServer
+ dosym ../..${instPath}/${instrDir}/DataServer/ziDataServer /opt/bin/ziDataServer
+
+ echo "#!/bin/bash" > "${T}/startWebServer" || die
+ echo "${instPath}/${instrDir}/WebServer/ziWebServer -r ${instPath}/${instrDir}/WebServer/html --ip 127.0.0.1 --server-port 8004" >> "${T}/startWebServer" || die
+ chmod 755 "${T}/startWebServer" || die
+ exeinto /opt/bin
+ doexe "${T}/startWebServer"
+ elog For security reasons the startWebServer script listens on the localhost interface only.
+ else
+
+ insinto "${instPath}/${instrDir}/API/C/lib"
+ doins API/C/lib/*.so
+ insinto "${instPath}/${instrDir}/API/C/include"
+ doins API/C/include/*.h
+
+ fi
+
+ dosym "../..${instPath}/${instrDir}/API/C/include/ziAPI.h" "usr/include/ziAPI.h"
+ dosym "../..${instPath}/${instrDir}/API/C/lib/libziAPI-linux64.so" "usr/$(get_libdir)/libziAPI-linux64.so"
+
+
+ # environment
+
+ cat > "${T}/55-zhinst" <<ENTE
+HF2_DATA_SERVER_PORT=8005
+HF2_DATA_SERVER="/opt/bin/ziServer"
+HF2_DATA_SERVER_ARGS="--debug 7"
+LABONE_DATA_SERVER_PORT=8005
+LABONE_DATA_SERVER="/opt/bin/ziDataServer"
+LABONE_DATA_SERVER_ARGS="--debug 7"
+ENTE
+
+ # the udev integration
+
+ sed -e 's:/usr/bin/ziServer:/opt/bin/ziServer:g' -i Installer/udev/55-zhinst.rules || die
+ insinto /lib/udev/rules.d
+ doins Installer/udev/55-zhinst.rules
+ exeinto /opt/bin
+ doexe Installer/udev/ziService
+
+ # just to make sure
+ dosym ../../opt/bin/ziService usr/bin/ziService
+}
+
+pkg_prerm() {
+ if [[ -x /opt/bin/ziService ]]; then
+ einfo "Stopping ziService for safe unmerge"
+ /opt/bin/ziService stop
+ fi
+}