summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pnp4nagios/pnp4nagios-9999.ebuild')
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-9999.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-9999.ebuild
new file mode 100644
index 0000000..160223d
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit confutils subversion
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+SRC_URI=""
+ESVN_REPO_URI="https://pnp4nagios.svn.sourceforge.net/svnroot/${PN}/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=dev-lang/php-4.3
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ confutils_require_built_with_all dev-lang/php gd pcre xml zlib
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" fullinstall || die "emake install failed"
+}