aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2010-01-01 22:14:08 -0600
committerDonnie Berkholz <dberkholz@gentoo.org>2010-01-01 22:14:08 -0600
commit37f250d57816e144d910dec63bb01e35745c15eb (patch)
treefae83ddde4704a3b78bc597c2c150676824d886b /sci-mathematics
parentNew package pymc: Markov chain Monte Carlo for Python. (diff)
downloaddberkholz-37f250d57816e144d910dec63bb01e35745c15eb.tar.gz
dberkholz-37f250d57816e144d910dec63bb01e35745c15eb.tar.bz2
dberkholz-37f250d57816e144d910dec63bb01e35745c15eb.zip
New package: mlpy (Machine Learning PYthon).
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mlpy/Manifest2
-rw-r--r--sci-mathematics/mlpy/mlpy-2.1.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/Manifest b/sci-mathematics/mlpy/Manifest
new file mode 100644
index 0000000..45f02b8
--- /dev/null
+++ b/sci-mathematics/mlpy/Manifest
@@ -0,0 +1,2 @@
+DIST MLPY-2.1.0.tar.gz 153360 RMD160 196fb0077a715612ceab3a655dcefb77b44ab98c SHA1 b4e0fae9ca2eb635b132a169354ac1c4e0dd718c SHA256 435d5802a94024330c70379cd14267e6f73013b4b6c1df0144ad358c0db721b5
+EBUILD mlpy-2.1.0.ebuild 670 RMD160 1d9b1e226243da1be6e9170a3d4056f306aebb49 SHA1 2a4fcd982ba720bbc590f8c3d9e27a8602d889c8 SHA256 0d609de78ae3c8eccf8c76898e270b133698ee5e488f357b773fba4caab54b40
diff --git a/sci-mathematics/mlpy/mlpy-2.1.0.ebuild b/sci-mathematics/mlpy/mlpy-2.1.0.ebuild
new file mode 100644
index 0000000..08774eb
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_PN="MLPY"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="https://mlpy.fbk.eu/download/src/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html || die
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}