aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-07-15 20:59:38 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-07-15 20:59:38 -0700
commit6689b61d6b4338e0a94a200734774a4ac7e307c2 (patch)
tree71d44d22a1aeb97cc9edf3a6ec9eefb6018abef6 /sci-chemistry/profit
parenteselect-blas/cblas/lapack: forgot to add man pages (diff)
downloaddberkholz-6689b61d6b4338e0a94a200734774a4ac7e307c2.tar.gz
dberkholz-6689b61d6b4338e0a94a200734774a4ac7e307c2.tar.bz2
dberkholz-6689b61d6b4338e0a94a200734774a4ac7e307c2.zip
profit: new protein least-squares alignment package.
The ebuild should be good, but the actual package seems to be missing a file. Emailed upstream about this and await a response.
Diffstat (limited to 'sci-chemistry/profit')
-rw-r--r--sci-chemistry/profit/profit-2.5.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-chemistry/profit/profit-2.5.3.ebuild b/sci-chemistry/profit/profit-2.5.3.ebuild
new file mode 100644
index 0000000..a155aa9
--- /dev/null
+++ b/sci-chemistry/profit/profit-2.5.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PN="ProFit"
+MY_P="${MY_PN}V${PV}"
+DESCRIPTION="Designed to be the ultimate protein least squares fitting program"
+HOMEPAGE="http://www.bioinf.org.uk/software/profit/"
+RESTRICT="fetch"
+ORIG_URI="${PN}.tar.gz"
+SRC_URI="${P}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gzip"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ elog "Download ${ORIG_URI} from ${HOMEPAGE}"
+ elog "Rename it to ${SRC_URI} and place it in ${DISTDIR}."
+}
+
+src_compile() {
+ use gzip && append-flags -DGUNZIP_SUPPORT
+
+ emake \
+ CC=$(tc-getCC) \
+ COPT="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ doexe src/${PN}
+ insinto /usr/share/${PN}
+ doins ProFit.help mdm78.mat
+
+ cat << EOF >> "${T}"/${PN}
+HELPDIR="/usr/share/${PN}"
+DATADIR="/usr/share/${PN}"
+EOF
+
+ newenvd "${T}"/${PN} 50${PN}
+
+ dodoc 00NEW.FEATURES 00Read.Me COPYING.DOC HISTORY INSTALL doc/ProFit.pdf
+}